Joystick fourth axis: speed

For test results, bug reports, announcements of new builds etc.

Moderators: another_commander, winston, Getafix

Post Reply
dybal
Dangerous
Dangerous
Posts: 98
Joined: Mon Feb 10, 2020 12:47 pm
Location: São Paulo, Brasil

Joystick fourth axis: speed

Post by dybal »

I have a 4-axis joystick, so I set the fourth axis as throttle, associated with speed - very convenient to change speed quickly in combat.

Then I installed Power to Engines and Masslock Compensator OXPs, but whatever the circunstances, when I slide the throttle to max I only get the nominal max speed for my ship, no bonus form the OXPs.

I put some traces in the OXPs' code, printing player.ship.maxSpeed to the Latest.log, and it was being set to higher values... then as an experiment, I changed the setting for increasing decreasing speed from the joystick fourth axis to buttons, and now I can reach the bonus speeds...

I did not look at the code, but it behaves as if the joystick 4th axis is being mapped directly to 0-maxSpeed (at startup or launch time)... wouldn't it work better if mapped to 0-1 and used as a multiplier to whatever value maxSpeed has at the time?

dybal
Dangerous
Dangerous
Posts: 98
Joined: Mon Feb 10, 2020 12:47 pm
Location: São Paulo, Brasil

Re: Joystick fourth axis: speed

Post by dybal »

Yesterday I was doing a binary search of OXPs looking for the culprit of another problem, and suddenly I could accelerate with the joystick into the speed bonus from Power to Engines OXP.

So this problem was caused by an OXP , HardWay.

Sorry for crying wolf... I should have done a test without any unnecessary OXPs installed before reporting a bug :oops:

Post Reply