Suggestion: option '-nosound'

An area for discussing new ideas and additions to Oolite.

Moderators: winston, another_commander

Post Reply
gt52
Average
Average
Posts: 11
Joined: Fri Oct 21, 2016 10:00 am

Suggestion: option '-nosound'

Post by gt52 » Fri Oct 21, 2016 10:28 am

Sound/Pulseaudio is somewhat broken on my system (since module-x11-smp is not loaded by pa when you startx from bash) and I can not always reboot to make it work. Besides, even though I once thought it was impossible, I've done quite well adapting to 'silent' play.

A command-line and 'hidden' option to have the sound-system not enabled on startup would let me keep from stopping pulseaudio before I start ooLite (only to reactivate it immediately thereafter since this x11-smp thing is a problem that :only: appears with FTL and ooLite. seriously.

[yes, gt52 is game-tourist and he plays a lot of different games if only for a little bit. nothing in the debian repos, nothing else build from source, nothing run from windows vms, no linux audio application, no browser game etc have ever exhibited this symptom. this truly, over 4 years, only affects FTL and ooLite!]

Thus my petition for a '-nosound'. if applied the sound system calls would be stubbed and Latest.log would not fill up with audio-system sample load errors. That would be cool. Please consider. Thanks. and Hi!

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5389
Joined: Wed Feb 28, 2007 7:54 am

Re: Suggestion: option '-nosound'

Post by another_commander » Sat Nov 05, 2016 9:33 pm

Command line option -nosound implemented with commit 11c639a. The sound volume setting in Game Options is disabled when the game is launched with this command line switch. Please test the next nightly.

Post Reply