Joystick behavior change starting with 1.74

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
caracal
Deadly
Deadly
Posts: 205
Joined: Wed Jun 25, 2008 11:31 am
Location: The Desert, USA
Contact:

Joystick behavior change starting with 1.74

Post by caracal » Sat Jun 19, 2010 4:13 pm

This isn't really a bug per se, and I'm sure it's specific to Linux joysticks, but it is a difference between 1.73.4 and 1.74 (or at least the pre-1.74-release nightly builds, and continuing through today with 1.75.0.3573), so I figured it was worth mentioning.

In 1.73 and previous, when I launched from the station the throttle would change to whatever level I had set the joystick throttle. That is, this joystick has a wheel that I have configured to be the throttle axis, and wherever I left it, that's where my ship's throttle went to, first launch and every launch.

Starting with the pre-1.74 nightlies, the behavior is a little different: On the first launch after I start the game, no matter where the wheel is set, the throttle of my ship is set to 50%, period. If I "jiggle" the throttle wheel, move it just a fraction either way, then the ship's throttle setting quickly moves to track the wheel's setting and then stays there. After that, it always stays with the wheel.

Note this only happens on the very first launch after I start the app. Subsequently, the throttle tracks the wheel perfectly. Heck, maybe the 50% initial value is intentional. It's really just a minor annoyance for me, so I thought I'd note it here.

Also, my sound level at startup is wildly variable. Sometimes I have to immediately turn it way down, sometimes it is almost inaudible and needs to be cranked up. But I think that's more of an issue with my system configuration rather than oolite, cuz all sorts of audio-related things have been acting cranky since I installed PulseAudio. :x

Post Reply