Installation 1.74 on Ubuntu 9.10, no start

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
rasibok
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun Jan 10, 2010 1:10 pm

Installation 1.74 on Ubuntu 9.10, no start

Post by rasibok » Sun Jan 10, 2010 1:17 pm

Hello there!

Thanks for this superfriendly forum, I am really looking forward playing Oolite but unfortunately I got some troubles with getting it running.

I installed the game via synaptic-packages by adding the sources, so I retrieved version 1.74
After checking the dependencies and installing a few other packages I tried to run it, but it stops/quits shortly after displaying a small splash-screen.

Here is the log, maybe it helps you more than me:
[log.header]: Opening log for Oolite version 1.74 (x86-32 test release) under Linux at 2010-01-10 15:09:03 +0200.
2 processors detected.
Oolite options: GLSL shaders, procedural planet textures, docking clearance, wormhole scanner, target incoming missiles, JavaScript console support, OXP verifier, localization tools, debug GraphViz support.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

[joystickHandler.init]: Number of joysticks detected: 0
[display.mode.list.native]: X11 native resolution detected: 1280 x 800
[size.dump]: Entity: 280 bytes
[size.dump]: ShipEntity: 1384 bytes
[size.dump]: ParticleEntity: 311260 bytes
[size.dump]: OOExhaustPlumeEntity: 2024 bytes
[size.dump]: OOFlasherEntity: 328 bytes
[size.dump]: OOSparkEntity: 324 bytes
[size.dump]: OOECMBlastEntity: 292 bytes
[size.dump]: SkyEntity: 288 bytes
[size.dump]: PlanetEntity: 1139560 bytes
[rendering.opengl.version]: OpenGL renderer version: 3.0.0 ("3.0.0 NVIDIA 185.18.36")
Vendor: NVIDIA Corporation
Renderer: GeForce 8600M GT/PCI/SSE2
[rendering.opengl.extensions]: OpenGL extensions (160):
GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_framebuffer_object GL_ARB_geometry_shader4 GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_bindable_uniform GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_texture_shared_exponent GL_EXT_timer_query GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_buffer_float GL_NV_conditional_render GL_NV_depth_clamp GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_NV_vertex_buffer_unified_memory GL_NV_shader_buffer_load GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
[dataCache.notFound]: No data cache found, starting from scratch.
[searchPaths.dumpAll]: ---> OXP search paths:
("/usr/lib/GNUstep/Applications/oolite.app/Resources", AddOns, "/home/andreas/.Oolite/AddOns")
[shipData.load.begin]: Loading ship data...
[plist.parse.failed]: Failed to parse /usr/lib/GNUstep/Applications/oolite.app/Resources/Config/shipdata.plist as a property list.
Parse failed at line 2646 (char 68837) - unexpected character (wanted '=')
[startup.exception]: ***** Unhandled exception during startup: OOShipRegistryLoadFailure (Could not load any ship data.).

Closing log at 2010-01-10 15:09:04 +0200.
Can you help me identify the problem? Thanks a lot in advance.

Kind regards,
Andreas

User avatar
Kaks
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 3009
Joined: Mon Jan 21, 2008 11:41 pm
Location: The Big Smoke

Post by Kaks » Sun Jan 10, 2010 2:05 pm

What it says at the end is that somehow your shipdata.plist file is broken at line 2646. It should be 2766 lines long, and is in ascii, so you can open it with a text editor.

If you want to compile 1.74, the best thing to do is to grab the files directly from the Berlios SVN directory. Or you could try grabbing the synaptic packages again, hopefully without any broken files the second time 'round.

And before I forget: welcome to the friendliest forum this side of Riedquat!
Hey, free OXPs: farsun v1.05 & tty v0.5! :0)

User avatar
Micha
Commodore
Commodore
Posts: 815
Joined: Tue Sep 02, 2008 2:01 pm
Location: London, UK
Contact:

Post by Micha » Sun Jan 10, 2010 10:34 pm

Hi rasibok,

Please note that the 1.74 version currently is 'trunk' - it is unstable and may or may not work. (It -should-, but since the package is automatically regenerated every night from the latest svn sources, it may be broken on a particular night). Since it's also regenerated pretty much every night with a new version, you'll be updating almost every night, unless you lock the version. 'trunk' is really only for cutting-edge testers.

For general playing, you should grab the 1.73.x version. There's v1.73.4 'test' (which isn't available for Karmic in the repository) which is the most stable of our current work, and v.173.5 'maint' which is basically 'test' plus a few patches (and will become the next 'test' unless 'trunk' beats it to that honour).

If you really want 1.73.4 for Karmic, try the autopackaged version, or, I think, playdeb may have an unofficial build as well.

Cheers,
- Micha.
The glass is twice as big as it needs to be.

rasibok
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun Jan 10, 2010 1:10 pm

Post by rasibok » Mon Jan 11, 2010 12:45 pm

ok, thanks for the info.
I downloaded the 1.74 via adding the package-sources - deinstalled and downloaded the 1.73.4 package manually. Now it works!

Lots of appreciation for your support!

Greetings,

Andreas

TriCircle
Poor
Poor
Posts: 4
Joined: Sat Feb 13, 2010 8:12 pm

Some annoyance with Karmic and 1.73.4

Post by TriCircle » Sat Feb 13, 2010 8:25 pm

Hi,

I'll hijack this thread to inform about some annoying bug(?) with 1.73.4.

Otherwise it works fine, but first of all, no sound. Sound worked with 1.65 but when espeak came along all you hear is the sound of silence :-)

And the thing that really gets me annoyed is the fact that every time I kill a pirate (or anyone else) the game crashes. It does how ever leave some traces when run from the console, so I'll paste them below:

Code: Select all

xxxx@xxxx:~$ oolite
xxxx@xxxx:~$ /usr/share/GNUstep/Makefiles/GNUstep.sh: 291: /usr/share/GNUstep/Makefiles/print_unique_pathlist.sh: not found
/usr/share/GNUstep/Makefiles/GNUstep.sh: 303: /usr/share/GNUstep/Makefiles/print_unique_pathlist.sh: not found              
/usr/share/GNUstep/Makefiles/GNUstep.sh: 358: /usr/share/GNUstep/Makefiles/print_unique_pathlist.sh: not found              
/usr/share/GNUstep/Makefiles/GNUstep.sh: 483: /usr/share/GNUstep/Makefiles/print_unique_pathlist.sh: not found              
/usr/share/GNUstep/Makefiles/GNUstep.sh: 520: /usr/share/GNUstep/Makefiles/print_unique_pathlist.sh: not found              
*** glibc detected *** /usr/lib/GNUstep/Applications/oolite.app/oolite: free(): invalid next size (fast): 0x9f4a6fa0 ***    
======= Backtrace: =========                                                                                                
/lib/tls/i686/cmov/libc.so.6[0x940ff1]                                                                                      
/lib/tls/i686/cmov/libc.so.6[0x9426f2]                                                                                      
/lib/tls/i686/cmov/libc.so.6(cfree+0x6d)[0x9457cd]                                                                          
/usr/lib/GNUstep/Applications/oolite.app/oolite[0x82089d2]                                                                  
/usr/lib/GNUstep/Applications/oolite.app/oolite[0x81e57e1]                                                                  
/usr/lib/GNUstep/Applications/oolite.app/oolite[0x81e27c4]                                                                  
/usr/lib/libgnustep-base.so.1.19[0x58da7d]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5c19c5]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x58da7d]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5f488c]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5c3ed4]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5c4b37]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5c4dcc]                                                                                  
/usr/lib/libgnustep-base.so.1.19[0x5c4cf5]                                                                                  
/usr/lib/GNUstep/Applications/oolite.app/oolite[0x81cbb64]                                                                  
/usr/lib/GNUstep/Applications/oolite.app/oolite(main+0x1eb)[0x81cda6b]                                                      
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x8ecb56]                                                              
/usr/lib/GNUstep/Applications/oolite.app/oolite[0x8067021]                                                                  
======= Memory map: ========                                                                                                
00110000-00137000 r-xp 00000000 08:01 1360214    /usr/lib/libSDL_mixer-1.2.so.0.2.6                                         
00137000-00138000 r--p 00026000 08:01 1360214    /usr/lib/libSDL_mixer-1.2.so.0.2.6                                         
00138000-00141000 rw-p 00027000 08:01 1360214    /usr/lib/libSDL_mixer-1.2.so.0.2.6                                         
00141000-0016b000 rw-p 00000000 00:00 0                                                                                     
0016b000-00179000 r-xp 00000000 08:01 1359874    /usr/lib/libXext.so.6.4.0                                                  
00179000-0017a000 r--p 0000d000 08:01 1359874    /usr/lib/libXext.so.6.4.0                                                  
0017a000-0017b000 rw-p 0000e000 08:01 1359874    /usr/lib/libXext.so.6.4.0                                                  
0017b000-0017f000 r-xp 00000000 08:01 1360584    /usr/lib/libXxf86vm.so.1.0.0                                               
0017f000-00180000 r--p 00003000 08:01 1360584    /usr/lib/libXxf86vm.so.1.0.0                                               
00180000-00181000 rw-p 00004000 08:01 1360584    /usr/lib/libXxf86vm.so.1.0.0                                               
00181000-00183000 r-xp 00000000 08:01 1362402    /usr/lib/libXdamage.so.1.1.0                                               
00183000-00184000 rw-p 00001000 08:01 1362402    /usr/lib/libXdamage.so.1.1.0                                               
00184000-00188000 r-xp 00000000 08:01 1360006    /usr/lib/libXfixes.so.3.1.0                                                
00188000-00189000 r--p 00003000 08:01 1360006    /usr/lib/libXfixes.so.3.1.0                                                
00189000-0018a000 rw-p 00004000 08:01 1360006    /usr/lib/libXfixes.so.3.1.0
0018a000-00192000 r-xp 00000000 08:01 1362349    /usr/lib/libdrm.so.2.4.0
00192000-00193000 r--p 00007000 08:01 1362349    /usr/lib/libdrm.so.2.4.0
00193000-00194000 rw-p 00008000 08:01 1362349    /usr/lib/libdrm.so.2.4.0
00194000-0019c000 r-xp 00000000 08:01 1360728    /usr/lib/libfusion-1.2.so.0.7.0
0019c000-0019d000 r--p 00007000 08:01 1360728    /usr/lib/libfusion-1.2.so.0.7.0
0019d000-0019e000 rw-p 00008000 08:01 1360728    /usr/lib/libfusion-1.2.so.0.7.0
0019e000-001b4000 r-xp 00000000 08:01 1360726    /usr/lib/libdirect-1.2.so.0.7.0
001b4000-001b5000 r--p 00015000 08:01 1360726    /usr/lib/libdirect-1.2.so.0.7.0
001b5000-001b6000 rw-p 00016000 08:01 1360726    /usr/lib/libdirect-1.2.so.0.7.0
001b6000-001bd000 r-xp 00000000 08:01 1360906    /usr/lib/libvorbisfile.so.3.2.0
001bd000-001be000 r--p 00006000 08:01 1360906    /usr/lib/libvorbisfile.so.3.2.0
001be000-001bf000 rw-p 00007000 08:01 1360906    /usr/lib/libvorbisfile.so.3.2.0
001bf000-001c6000 r-xp 00000000 08:01 1360451    /usr/lib/libdns_sd.so.1.0.0
001c6000-001c7000 r--p 00006000 08:01 1360451    /usr/lib/libdns_sd.so.1.0.0
001c7000-001c8000 rw-p 00007000 08:01 1360451    /usr/lib/libdns_sd.so.1.0.0
001c8000-001cd000 r-xp 00000000 08:01 1360074    /usr/lib/libffi.so.5.0.8
001cd000-001ce000 ---p 00005000 08:01 1360074    /usr/lib/libffi.so.5.0.8
001ce000-001cf000 r--p 00005000 08:01 1360074    /usr/lib/libffi.so.5.0.8
001cf000-001d0000 rw-p 00006000 08:01 1360074    /usr/lib/libffi.so.5.0.8
001d0000-001d2000 r-xp 00000000 08:01 1362612    /usr/lib/libXau.so.6.0.0
001d2000-001d3000 r--p 00001000 08:01 1362612    /usr/lib/libXau.so.6.0.0
001d3000-001d4000 rw-p 00002000 08:01 1362612    /usr/lib/libXau.so.6.0.0
001d6000-00206000 r-xp 00000000 08:01 1359909    /usr/lib/libespeak.so.1.1.41
00206000-00207000 r--p 00030000 08:01 1359909    /usr/lib/libespeak.so.1.1.41
00207000-0020a000 rw-p 00031000 08:01 1359909    /usr/lib/libespeak.so.1.1.41
0020a000-00235000 rw-p 00000000 00:00 0
00235000-00248000 r-xp 00000000 08:01 14213175   /lib/tls/i686/cmov/libnsl-2.10.1.so
00248000-00249000 r--p 00012000 08:01 14213175   /lib/tls/i686/cmov/libnsl-2.10.1.so
00249000-0024a000 rw-p 00013000 08:01 14213175   /lib/tls/i686/cmov/libnsl-2.10.1.so
0024a000-0024c000 rw-p 00000000 00:00 0
0024c000-00268000 r-xp 00000000 08:01 1362392    /usr/lib/libxcb.so.1.1.0
00268000-00269000 r--p 0001c000 08:01 1362392    /usr/lib/libxcb.so.1.1.0
00269000-0026a000 rw-p 0001d000 08:01 1362392    /usr/lib/libxcb.so.1.1.0
0026b000-0028f000 r-xp 00000000 08:01 14213173   /lib/tls/i686/cmov/libm-2.10.1.so
0028f000-00290000 r--p 00023000 08:01 14213173   /lib/tls/i686/cmov/libm-2.10.1.so
00290000-00291000 rw-p 00024000 08:01 14213173   /lib/tls/i686/cmov/libm-2.10.1.so
00291000-00377000 r-xp 00000000 08:01 1360809    /usr/lib/libstdc++.so.6.0.13
00377000-0037b000 r--p 000e6000 08:01 1360809    /usr/lib/libstdc++.so.6.0.13
0037b000-0037c000 rw-p 000ea000 08:01 1360809    /usr/lib/libstdc++.so.6.0.13
0037c000-00383000 rw-p 00000000 00:00 0
00383000-003a7000 r-xp 00000000 08:01 1365048    /usr/lib/libportaudio.so.2.0.0
003a7000-003a8000 r--p 00023000 08:01 1365048    /usr/lib/libportaudio.so.2.0.0
003a8000-003a9000 rw-p 00024000 08:01 1365048    /usr/lib/libportaudio.so.2.0.0
003a9000-003b0000 r-xp 00000000 08:01 14213185   /lib/tls/i686/cmov/librt-2.10.1.so
003b0000-003b1000 r--p 00006000 08:01 14213185   /lib/tls/i686/cmov/librt-2.10.1.so
003b1000-003b2000 rw-p 00007000 08:01 14213185   /lib/tls/i686/cmov/librt-2.10.1.so
003b2000-003b4000 r-xp 00000000 08:01 3571957    /usr/lib/gconv/UTF-16.so
003b4000-003b5000 r--p 00001000 08:01 3571957    /usr/lib/gconv/UTF-16.so
003b5000-003b6000 rw-p 00002000 08:01 3571957    /usr/lib/gconv/UTF-16.so
003b6000-003cb000 r-xp 00000000 08:01 14213183   /lib/tls/i686/cmov/libpthread-2.10.1.so
003cb000-003cc000 r--p 00014000 08:01 14213183   /lib/tls/i686/cmov/libpthread-2.10.1.so
003cc000-003cd000 rw-p 00015000 08:01 14213183   /lib/tls/i686/cmov/libpthread-2.10.1.so
003cd000-003cf000 rw-p 00000000 00:00 0
003cf000-003dd000 r-xp 00000000 08:01 1360684    /usr/lib/libavahi-client.so.3.2.5
003dd000-003de000 ---p 0000e000 08:01 1360684    /usr/lib/libavahi-client.so.3.2.5
003de000-003df000 r--p 0000e000 08:01 1360684    /usr/lib/libavahi-client.so.3.2.5
003df000-003e0000 rw-p 0000f000 08:01 1360684    /usr/lib/libavahi-client.so.3.2.5
003e0000-003e4000 r-xp 00000000 08:01 1362404    /usr/lib/libXdmcp.so.6.0.0
003e4000-003e5000 rw-p 00003000 08:01 1362404    /usr/lib/libXdmcp.so.6.0.0
003e5000-003e8000 r-xp 00000000 08:01 2351115    /lib/libgpg-error.so.0.4.0
003e8000-003e9000 r--p 00002000 08:01 2351115    /lib/libgpg-error.so.0.4.0
003e9000-003ea000 rw-p 00003000 08:01 2351115    /lib/libgpg-error.so.0.4.0
003eb000-00411000 r-xp 00000000 08:01 1363019    /usr/lib/libpng12.so.0.37.0

User avatar
Micha
Commodore
Commodore
Posts: 815
Joined: Tue Sep 02, 2008 2:01 pm
Location: London, UK
Contact:

Post by Micha » Mon Feb 15, 2010 4:45 pm

Hi TriCircle,

Did you get the 'official' 1.73.4 ".deb" package, the 'official' 1.73.4 autopackage, the 'unofficial' package from debplay (or elsewhere), or even build it yourself?

Also, can you please post the log file when the game crashed (should be in ~/.Oolite/Logs/Latest.log).

Cheers,
- Micha.
The glass is twice as big as it needs to be.

TriCircle
Poor
Poor
Posts: 4
Joined: Sat Feb 13, 2010 8:12 pm

Post by TriCircle » Mon Feb 15, 2010 7:02 pm

Micha wrote:Hi TriCircle,

Did you get the 'official' 1.73.4 ".deb" package, the 'official' 1.73.4 autopackage, the 'unofficial' package from debplay (or elsewhere), or even build it yourself?

Also, can you please post the log file when the game crashed (should be in ~/.Oolite/Logs/Latest.log).

Cheers,
- Micha.
It was the 'official' packages. I don't have logs unfortunately, since I removed the debs and installed 1.74 from source (which works perfectly by the way:)) and have been playing it for couple of days.

I did try and reinstalled the official packages, but for some reason now it seems to work ok. (No sound still though, something strangeness with espeak) So I guess it was some weird misalignment on the libraries or something :roll:

User avatar
Micha
Commodore
Commodore
Posts: 815
Joined: Tue Sep 02, 2008 2:01 pm
Location: London, UK
Contact:

Post by Micha » Mon Feb 15, 2010 7:36 pm

Hmm, ok, well I'm glad you're up and playing. Would be good to try to track down why it was broken though as it may affect other people. Based on the fact that in the meantime you compiled from source and now the packages work, I'd guestimate a missing dependency.. hmm. :(

Also please note that 1.74 may be unplayable at times - it is the current development version and hence cutting edge with features added/removed/broken/fixed on an almost daily basis. Also, not all OXPs work (correctly or at all) with 1.74.

Hence for general playing 1.73.4 is recommended.


Oh, and welcome to the Friendliest Board this side of Riedquat :)

Cheers,
- Micha.
The glass is twice as big as it needs to be.

TriCircle
Poor
Poor
Posts: 4
Joined: Sat Feb 13, 2010 8:12 pm

Post by TriCircle » Tue Feb 16, 2010 5:38 am

Micha wrote:Hmm, ok, well I'm glad you're up and playing. Would be good to try to track down why it was broken though as it may affect other people. Based on the fact that in the meantime you compiled from source and now the packages work, I'd guestimate a missing dependency.. hmm. :(

Also please note that 1.74 may be unplayable at times - it is the current development version and hence cutting edge with features added/removed/broken/fixed on an almost daily basis. Also, not all OXPs work (correctly or at all) with 1.74.

Hence for general playing 1.73.4 is recommended.


Oh, and welcome to the Friendliest Board this side of Riedquat :)

Cheers,
- Micha.
Thanks,

Love the game :-)

I will try to reproduce the problem, but since it seems to have gone away, it would suggest that it indeed was missing something and when I installed everything needed for compilation I installed the missing piece.

And yes, I do realise that 1.74 is work in progress, so I wont be as quick to complain as I was with 1.73.4 :-)

User avatar
Commander McLane
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 9520
Joined: Thu Dec 14, 2006 9:08 am
Location: a Hacker Outpost in a moderately remote area
Contact:

Post by Commander McLane » Wed Feb 17, 2010 9:47 pm

TriCircle wrote:And yes, I do realise that 1.74 is work in progress,
In order to make that crystal clear you shouldn't call it "1.74" in the first place, because there is no such thing as Oolite 1.74 yet. There is only "trunk", which at some point in the future will evolve into what will then be called "1.74". Nobody in this whole wide world can know how much the trunk version you installed will have to to with what will eventually be released as "1.74". The only thing I know for sure is that "1.74" will be different from the current trunk. Therefore it makes no sense to call the trunk "1.74". According to logic, because the two will be different, you would have to call it "not 1.74".

Abstaining from confusing the two with each other will also help to prevent dozens of people frantically asking where they can download the 1.74 version (which doesn't exist and therefore cannot be downloaded).

TriCircle
Poor
Poor
Posts: 4
Joined: Sat Feb 13, 2010 8:12 pm

Post by TriCircle » Thu Feb 18, 2010 4:42 pm

Commander McLane wrote:
TriCircle wrote:And yes, I do realise that 1.74 is work in progress,
In order to make that crystal clear you shouldn't call it "1.74" in the first place, because there is no such thing as Oolite 1.74 yet. There is only "trunk", which at some point in the future will evolve into what will then be called "1.74". Nobody in this whole wide world can know how much the trunk version you installed will have to to with what will eventually be released as "1.74". The only thing I know for sure is that "1.74" will be different from the current trunk. Therefore it makes no sense to call the trunk "1.74". According to logic, because the two will be different, you would have to call it "not 1.74".

Abstaining from confusing the two with each other will also help to prevent dozens of people frantically asking where they can download the 1.74 version (which doesn't exist and therefore cannot be downloaded).
As the game window says 1.74, who am I to contradict it? I just play the game. And as long as the game says 1.74, it's 1.74 to me :)

Post Reply