Slow Oolite in openSUSE

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
vadimuzzz
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Tue Dec 15, 2009 2:36 am

Slow Oolite in openSUSE

Post by vadimuzzz » Tue Dec 15, 2009 2:49 am

My problem is Oolite (versions 1.73.4 and 1.65) running very slow in openSUSE 11.2 (~4FPS) with ATI x300 video card.
Log:
[gnustep]: 2009-12-14 10:47:56.840 oolite[20991] Unknown time zone name `OMST'.

[gnustep]: 2009-12-14 10:47:56.840 oolite[20991] Using time zone with absolute offset 0.

[log.header]: Opening log for Oolite version 1.73.4 (x86-64 test release) under Linux at 2009-12-14 10:47:56 +0000.
2 processors detected.
Oolite Options: [Procedural Planets] [Docking Clearance] [Wormhole Scanner] [Target Incoming Missiles]

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

[joystickHandler.init]: Number of joysticks detected: 0
[display.mode.list.native]: X11 native resolution detected: 1280 x 1024
[rendering.opengl.version]: OpenGL renderer version: 1.5.0 ("1.5 Mesa 7.6")
Vendor: DRI R300 Project
Renderer: Mesa DRI R300 (RV380 5B60) 20090101 TCL
[rendering.opengl.extensions]: OpenGL extensions (91):
GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
[rendering.opengl.shader.support]: Shaders will not be used (OpenGL extension GL_ARB_shading_language_100 is not available).
[searchPaths.dumpAll]: ---> OXP search paths:
("/usr/share/GNUstep/System/Applications/oolite.app/Resources", AddOns, "/home/vadik/.Oolite/AddOns")
[dataCache.upToDate]: Data cache is up to date.
[script.load.world.listAll]: Loaded 5 world scripts: "oolite-cloaking-device" 1.73.4, "oolite-constrictor-hunt" 1.73.4, "oolite-nova" 1.73.4, "oolite-thargoid-plans" 1.73.4, "oolite-trumbles" 1.73.4
[dataCache.willWrite]: About to write data cache.
[dataCache.write.success]: Wrote data cache.
[gameController.exitApp]: .GNUstepDefaults synchronized.

Closing log at 2009-12-14 10:48:02 +0000.
Another games works good. On my laptop with openSUSE 11.2 and Intel x3100 oolite works very good.

User avatar
_ds_
Deadly
Deadly
Posts: 180
Joined: Thu Jan 22, 2009 5:34 pm
Location: In a cloaked ship behind you

Re: Slow Oolite in openSUSE

Post by _ds_ » Tue Dec 15, 2009 3:19 am

vadimuzzz wrote:My problem is Oolite (versions 1.73.4 and 1.65) running very slow in openSUSE 11.2 (~4FPS) with ATI x300 video card.
The usual cause on R300-series cards when using Mesa xf86-video-ati is anti-aliased line drawing. For some reason, this isn't accelerated. The solution is simple: run driconf (install it first if needed), and enable the "disable low-impact fallback" option. This will disable anti-aliasing.
Last edited by _ds_ on Tue Dec 15, 2009 7:47 pm, edited 1 time in total.
http://tartarus.org/~ds/oolite/patches, Buzzer OXP etc.

vadimuzzz
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Tue Dec 15, 2009 2:36 am

Post by vadimuzzz » Tue Dec 15, 2009 4:48 am

thanks!

Post Reply