[Solved] Acer One OOLITE Linpus Lite

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

[Solved] Acer One OOLITE Linpus Lite

Post by phildeem » Mon Nov 23, 2009 12:00 pm

Hi All,

I've recently found OOLITE for Windows and have been enjoying it immensely.........

..........but i'm going away somewhere remote for Christmas and want to play OOLITE on my Acer One netbook while i'm away (Linpus Lite Linux which I think is Fedora 8 based).........

I've downloaded the latest OOLITE Linux test package and get an install success message..........but can't find it anywhere on the harddisk - trying to run from the terminal command line can't find the program!

I've hunted around the forum and seen reference to hidden files and folders, Fedora execheap changes (advice must be for other versions of Linux)...........and am getting no where..........

Has anyone out there got OOLITE running on an Acer One? If so, how did you do it? I quite like my little netbook and don't really want to change the os................

Guidance / comments appreciated,

Cheers

Phil
Last edited by phildeem on Wed Nov 25, 2009 2:10 pm, edited 1 time in total.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Acer One OOLITE

Post by Getafix » Mon Nov 23, 2009 12:18 pm

Hello phildeem, and welcome to the friendliest board this side of Riedquat!

Could you post the filename of the package you installed?
Last edited by Getafix on Wed Nov 25, 2009 1:49 pm, edited 1 time in total.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

Acer One OOLITE

Post by phildeem » Tue Nov 24, 2009 4:26 pm

Hi,

Apologies for the hazy posting - i'm new to bulletin boards!

The package I installed was oolite-1.73.4-test.x86.package

Thanks,

Phil

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Acer One OOLITE

Post by Getafix » Wed Nov 25, 2009 2:27 pm

While I am trying to get my hands on a Linpus box, please:
a. Post the result of the following:

Code: Select all

# cd /
# find . -name *oolite* -print 2> /dev/null
b. Post the result of the following:

Code: Select all

# cd /
# find . -name *autopackage* -print 2> /dev/null
c. If there is a "/usr/bin/oolite" file, please post its contents.

d. How did you try to run oolite? The following should be enough:

Code: Select all

# oolite
e. Did your Linpus box have a working internet connection, when you tried to install?
(The working internet connection is mandatory the first time you try to install an
autopackage package, since it will try to download this runtime library.)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

Acer One OOLITE

Post by phildeem » Thu Nov 26, 2009 11:33 am

Hi,

Thanks for your help, I do really appreciate the help...........

The results of the two command line sets as follows:

Code: Select all

[user@localhost bin]$ cd /
[user@localhost /]$ find . -name *oolite* -print 2> /dev/null
./tmp/autopackage.208367395/meta/@oolite-linux.berlios.de
./tmp/autopackage.208367395/meta/@oolite-linux.berlios.de/oolite:1.73.4-test
./tmp/autopackage.208367395/payload/@oolite-linux.berlios.de
./tmp/autopackage.208367395/payload/@oolite-linux.berlios.de/oolite:1.73.4-test
./home/user/Downloads/oolite-1.73.4-test.x86.package
./mnt/home/Downloads/oolite-1.73.4-test.x86.package

[user@localhost /]$ find . -name *autopackage* -print 2> /dev/null
./tmp/autopackage.session.20091126112655
./tmp/autopackage.208367395
./tmp/autopackage.242387181
./etc/autopackage
./usr/share/applications/autopackage-launcher-gtk.desktop
./usr/share/applications/autopackage-manager-gtk.desktop
./usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/icons/hicolor/48x48/apps/autopackage-installer.png
./usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/icons/hicolor/scalable/mimetypes/gnome-mime-application-x-autopackage.svg
./usr/share/locale/ru/LC_MESSAGES/autopackage.mo
./usr/share/locale/ru/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/ar/LC_MESSAGES/autopackage.mo
./usr/share/locale/ar/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/el/LC_MESSAGES/autopackage.mo
./usr/share/locale/el/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/hu/LC_MESSAGES/autopackage.mo
./usr/share/locale/hu/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/es/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/fr/LC_MESSAGES/autopackage.mo
./usr/share/locale/fr/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/sv/LC_MESSAGES/autopackage.mo
./usr/share/locale/sv/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/it/LC_MESSAGES/autopackage.mo
./usr/share/locale/it/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/ja/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/nl/LC_MESSAGES/autopackage.mo
./usr/share/locale/nl/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/cs/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/pt/LC_MESSAGES/autopackage.mo
./usr/share/locale/pt/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/pt_BR/LC_MESSAGES/autopackage.mo
./usr/share/locale/pt_BR/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/es_ES/LC_MESSAGES/autopackage.mo
./usr/share/locale/es_ES/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/de/LC_MESSAGES/autopackage.mo
./usr/share/locale/de/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/ko/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/pa/LC_MESSAGES/autopackage.mo
./usr/share/locale/pa/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/pl/LC_MESSAGES/autopackage.mo
./usr/share/locale/pl/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/sq/LC_MESSAGES/autopackage.mo
./usr/share/locale/sq/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/da/LC_MESSAGES/autopackage.mo
./usr/share/locale/da/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/sl/LC_MESSAGES/autopackage.mo
./usr/share/locale/sl/LC_MESSAGES/autopackage-gtk.mo
./usr/share/locale/es_CO/LC_MESSAGES/autopackage.mo
./usr/share/locale/es_CO/LC_MESSAGES/autopackage-gtk.mo
./usr/share/pixmaps/hicolor/16x16/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/pixmaps/hicolor/32x32/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/pixmaps/hicolor/48x48/apps/autopackage-installer.png
./usr/share/pixmaps/hicolor/48x48/mimetypes/gnome-mime-application-x-autopackage.png
./usr/share/pixmaps/hicolor/scalable/mimetypes/gnome-mime-application-x-autopackage.svg
./usr/share/mime/packages/autopackage.xml
./usr/share/mime/application/x-autopackage.xml
./usr/share/autopackage
./usr/share/autopackage-gtk
./usr/share/autopackage-manager
./usr/bin/autopackage
./usr/bin/autopackage-frontend-gtk
./usr/bin/autopackage-launcher-gtk
./usr/bin/autopackage-launcher-gtk-nautilus-wrapper
./usr/bin/autopackage-manager-gtk
./usr/libexec/autopackage
./usr/libexec/autopackage-gtk
./var/packages/@autopackage.org
./var/packages/@autopackage.org/autopackage-gtk:1.4.2
./var/packages/autopackage-gtk-1.4.2
./var/packages/autopackage-gtk
I can find no OOLITE directory and typing OOLITE from the command prompt has no effect!

Thanks again,

Phil

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Thu Nov 26, 2009 3:36 pm

From what you have posted, i see that oolite is not installed.
Let's do it manually, in order to have control over the installation process! :wink:

Please do the following:
1. Download the autopackage runtime from
http://autopackage.googlecode.com/files ... 86.tar.bz2

2. Go to the folder where the runtime is downloaded and execute:

Code: Select all

# tar xjvf autopackage-1.4.2-x86.tar.bz2
# cd autopackage
# su
# ./install
# exit
3. Go to the folder where the oolite package is located and execute:

Code: Select all

# chmod 744 oolite-1.73.4-test.x86.package
# ./oolite-1.73.4-test.x86.package
Note: Provide your password if requested.

4. You should now have oolite installed. Execute:

Code: Select all

# oolite
5. In any case post any error messages that appear in the terminal and also post the contents of ~/.Oolite/Logs/Latest.log

Code: Select all

# cat ~/.Oolite/Logs/Latest.log
I will be waiting for your feedback. :)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

Acer One OOLITE

Post by phildeem » Thu Nov 26, 2009 10:54 pm

Hi,

Just a quick response..........

The su did prompt for a password..........but the password I gave it was not recognised! (even though it was correct - I only have the password for the root user!).

I did the install anyway - which didn't error - but I don't think it worked!

The chmod worked on the package..............but then the ./ line gave results like this:

[user@localhost Downloads]$ ./oolite-1.73.4-test.x86.package
FAIL:Install the package with the command 'package install' instead.

I am grateful for your help so far, sorry to be so "needy"!

Regards

Phil

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Fri Nov 27, 2009 5:26 am

Let's do what it prompts you to do.

In the folder where the oolite package resides, execute:

Code: Select all

# package install oolite-1.73.4-test.x86.package
As always, post any message that comes up.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

Post by phildeem » Fri Nov 27, 2009 12:45 pm

Hi Getafix............

I get the same response again..............

[user@localhost Downloads]$ package install oolite-1.73.4-test.x86.package


FAIL:Install the package with the command 'package install' instead.

It is so frustrating - I'm just glad your here to guide me!

Regards

Phil

phildeem
Poor
Poor
Posts: 6
Joined: Mon Nov 23, 2009 11:48 am

Acer One OOLITE - Success

Post by phildeem » Fri Nov 27, 2009 1:03 pm

Hi Getafix,

You are a genius............and i've got one very strange Acer One.................

After the latest failure I went back to your original instructions...............and repeated the process from the SU line (where it seemed to go wrong before!)...........and it kept rejecting my password time after time.........just like before..............and then one time it simply accepted the password..............and the rest of the process worked perfectly - just like you described it!

The problem must have been me (i'm embarassed to say!).

Luckily you were very patient and ready and willing to help!

I owe you a virtual pint! Thanks for all your help!

Cheers

Phil

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Fri Nov 27, 2009 2:49 pm

It was really very interesting for me.
This was my first effort to make oolite run on a netbook.
I am glad we have been successful on this.

Happy Oolite-ing during Christmas! 8)

EDIT: Oh!... and thanks for the pint... hick!
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Post Reply