[Solved]Dependency issue with 1.73.4 d/l from alternate site

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
Garrett
Above Average
Above Average
Posts: 31
Joined: Fri Oct 09, 2009 11:11 pm
Location: London

[Solved]Dependency issue with 1.73.4 d/l from alternate site

Post by Garrett » Fri Nov 06, 2009 9:56 am

Hey guys,

Has anyone got Oolite 1.73.4 working in Ubuntu 9.10? I tried installing Oolite in the new Ubuntu 9.10 x86 from Dizzy's site (tried the 9.04 version), but got a dependency error about gunstep-base being 1.19 but it needing 1.16. I will happily compile it myself if someone walks me through it :) Thanks!
Last edited by Garrett on Sun Nov 15, 2009 6:12 pm, edited 1 time in total.

User avatar
Thargoid
Thargoid
Thargoid
Posts: 5510
Joined: Thu Jun 12, 2008 6:55 pm

Post by Thargoid » Fri Nov 06, 2009 10:12 am

I've had the standard Berlios package of 1.73.4 working fine under 9.10.

If you're using Dizzy's package (ooer), is it 1.73.4 or 1.74 trunk? Not tried the latter yet, but I did try the bleeding edge package build from the sticky thread above, and that failed along those lines (don't remember the exact error).

Garrett
Above Average
Above Average
Posts: 31
Joined: Fri Oct 09, 2009 11:11 pm
Location: London

Post by Garrett » Fri Nov 06, 2009 10:59 am

Thanks, will try the Berlios package in my lunchbreak. The version I tried from Dizzy's site was 1.73.4. Will let you know how I get on.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Tue Nov 10, 2009 12:52 pm

The remainder of this discussion, concerned AddOns and therefore, has been split and moved here.
Last edited by Getafix on Tue Nov 10, 2009 1:29 pm, edited 2 times in total.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Thargoid
Thargoid
Thargoid
Posts: 5510
Joined: Thu Jun 12, 2008 6:55 pm

Post by Thargoid » Tue Nov 10, 2009 1:06 pm

The nightly builds still fail under 9.10 unfortunately. When I run the autopackage I get:
Extracting: [100%]
Creating Oolite-trunk directory in /usr/lib/Oolite-trunk
Unpacking and installing resources and dependencies
Copying files to /usr/lib/Oolite-trunk/oolite.app
Copying: [100%]
Copying files to /usr/lib/Oolite-trunk/oolite-deps
Copying: [100%]
Copying files to /usr/lib/Oolite-trunk/oolite-deps/GNUstep/Library/DTDs
Installing documentation
Copying files to /usr/lib/Oolite-trunk/doc
Copying: [100%]
Copying files to /usr/lib/Oolite-trunk
Error: Package Oolite-trunk for Linux could not be installed.
And something analogous if I don't use the root password (same structure, just with different folder location).

Is there any log anywhere to find and reproduce there that might shed more light as to what's choking it?

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Tue Nov 10, 2009 2:35 pm

Garrett's issue has nothing to do with Thargoid's issue.

@Garrett:
I have pinged Diziet, to get some info on the kind of distributed files.

@Thargoid:
In 8.04 the trunk package works fine. I am currently setting up a 9.10 box to check your case.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Tue Nov 17, 2009 6:24 am

@Thargoid:
The trunk package should now install fine.
Feel free to check it out.

@Garrett:
Still digging into the alternate download for 1.73.4 package. :?
Garrett, which package have you tried from the
alternate download site; the .package or the .deb?
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Thargoid
Thargoid
Thargoid
Posts: 5510
Joined: Thu Jun 12, 2008 6:55 pm

Post by Thargoid » Tue Nov 17, 2009 6:58 am

Will have a look at the weekend (I'm a timezone and a couple of thousand miles from my Linux box at the moment).

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Tue Nov 17, 2009 10:56 am

I have just successfully installed 1.73.4-test package (i.e. Linux Autopackage) from Diziet's alternate d/l site.

Therefore, considering what Garrett said in the first post
Garrett wrote:I tried installing Oolite in the new Ubuntu 9.10 x86 from Dizzy's site (tried the 9.04 version)
my understanding is that he tried to install the 9.04 deb package into 9.10.
Well, if I remember right this is not possible. Specific deb package has to be built for 9.10.
Isn't that right, Micha?

EDIT 19/Nov/2009: Case closed, I presume.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Post Reply