[Solved] Messed up textures and no text

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Cows
Dangerous
Dangerous
Posts: 81
Joined: Fri Jun 19, 2009 1:36 am
Location: Milliways

[Solved] Messed up textures and no text

Post by Cows » Wed Sep 30, 2009 12:50 am

Is the autopackage download 1.73.4 on oolite.org compatible with Ubuntu 8.10, Intrepid Ibex? I successfully installed it using autopackage, however, the textures were messed up, black with strange green stripes, and the text was missing. The screen was flashing too.

zevans
---- E L I T E ----
---- E L I T E ----
Posts: 322
Joined: Mon Jul 06, 2009 11:12 pm
Location: Uncharted backwaters of the unfashionable end of the western spiral arm

Post by zevans » Wed Sep 30, 2009 1:38 am

Should be. What graphics chipset do you have, and have you tried any other 3d games on it?

Chrisfs
---- E L I T E ----
---- E L I T E ----
Posts: 433
Joined: Sun Sep 20, 2009 10:24 am
Location: California

Post by Chrisfs » Wed Sep 30, 2009 2:04 am

Try adjusting the size of the window, it's weird but it may work

User avatar
Cows
Dangerous
Dangerous
Posts: 81
Joined: Fri Jun 19, 2009 1:36 am
Location: Milliways

Post by Cows » Wed Sep 30, 2009 2:36 am

I have the Intel gma 3100 chipset and Oolite doesn't have these problems on Windows. All other games that don't have shaders (normal maps, lights, etc) work, and Oolite won't even let me run shaders so it isn't a problem with shaders (I don't think). Resizing the window stopped the flickering, but still no text and the textures are still freakishly messed up.


http://img21.imageshack.us/img21/4919/oolite003.png
http://img29.imageshack.us/img29/4523/oolite001.png
http://img38.imageshack.us/img38/3650/oolite009.png

Moderator: replaced inline giant images with links.

User avatar
DaddyHoggy
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 8501
Joined: Tue Dec 05, 2006 9:43 pm
Location: Newbury, UK
Contact:

Post by DaddyHoggy » Wed Sep 30, 2009 9:10 am

I used the autopackager on an older version of Ubuntu than you - Gutsy to be precise - it works just fine (well 1.73.3 did - I haven't got 1.73.4 yet - I lost the posting to Micha's repository).

I'm using an Athlon XP 2800+ with a GF6600GT and Nivdia's latest restricted drivers. Your screenshots certainly indicate that, yet again, intel gfx are to blame.
Selezen wrote:Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Wed Sep 30, 2009 11:53 am

The package is compatible with 8.10.

Try disabling compiz via the
System menu --> Preferences --> Appearance --> Visual Effects tab and select None.
Let us know if this fixed oolite graphics.

edit: Could you post the result of the following?

Code: Select all

glxinfo | grep rendering
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Cows
Dangerous
Dangerous
Posts: 81
Joined: Fri Jun 19, 2009 1:36 am
Location: Milliways

Post by Cows » Wed Sep 30, 2009 1:35 pm

Thanks! Getting rid of the visual effects got rid of all my problems and even got ride of the horrible z-fighting problems I've been having on windows.
edit: Could you post the result of the following?
Code:
glxinfo | grep rendering
Yes

Code: Select all

Direct Rendering:Yes

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Wed Sep 30, 2009 1:47 pm

It's always a pleasure to be of assistance. :)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Post by Getafix » Wed Sep 30, 2009 1:52 pm

Altered the topic to something more comprehensive.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Post Reply