[Solved] shaders not available...

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

User avatar
DaddyHoggy
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 8501
Joined: Tue Dec 05, 2006 9:43 pm
Location: Newbury, UK
Contact:

Post by DaddyHoggy » Fri May 07, 2010 8:46 am

Jiawen wrote:I'm having same problem as DaddyHoggy; the Shaders option line is greyed out. I'm using Ubuntu 8.04 and Oolite 1.73.4-0. Here's the relevant output:
rachel@rachel-desktop:/usr/lib$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce3/AGP/SSE2
OpenGL version string: 1.5.8 NVIDIA 96.43.05
OpenGL extensions:
rachel@rachel-desktop:/usr/lib$ glxinfo | grep direct
direct rendering: Yes
Does this mean I won't be able to get full shaders? It's still prettier than 1.65, but I'd love to be able to get all those lovely lighting effects.

Hope this kind of thread necromancy is okay here. :oops:
I'm fairly certain your GF3 doesn't support shaders under Oolite (OpenGL v2+ - and you're Nvidia driver is v1.5) - Ahruman's new tweaks going into the trunk will mean you will get some lighting effects even in the basic non-shader version of the game - but things like decals and engine glows - nope - you're not going to see them.

Go to this thread: http://aegidian.org/bb/viewtopic.php?t=6612 and follow the instructions there and post your results - this way Ahruman can find it more easily than here
Selezen wrote:Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here

Post Reply