Page 2 of 13

Posted: Sat May 31, 2008 9:37 am
by DaddyHoggy
tried reinstalling and adding additional gnustep apps from SPM - makes no difference

:(

still get same nulls

:(

so no new version and no excellent looking oxp from LB

:(

Posted: Mon Jun 02, 2008 3:38 pm
by DaddyHoggy
UPDATE: having installed several additional libraries to get easycam2 to work (to try and get my webcam to work - which it didn't) - I tried to get oolite to compile again - and - despite those pesky nulls still being present - this time it did indeed compile - and seems to run ok.

Are the several thousand warnings about pointers the norm?

Posted: Tue Jun 03, 2008 7:25 pm
by JensAyton
DaddyHoggy wrote:Are the several thousand warnings about pointers the norm?
Yes. (Fixed for 1.72.)

Help on similar issue...

Posted: Thu Oct 02, 2008 4:23 pm
by newtonke
Help, I have GNUmakefile. Appreciated. Ubuntu 64 on a Core2 w/4gig ram

I followed all the steps..

trunk$ make debug=no
GNUmakefile:1: /common.make: No such file or directory
GNUmakefile:31: /objc.make: No such file or directory
make: *** No rule to make target `/objc.make'. Stop.

Re: Help on similar issue...

Posted: Thu Oct 02, 2008 5:06 pm
by JensAyton
newtonke wrote:Help, I have GNUmakefile. Appreciated. Ubuntu 64 on a Core2 w/4gig ram

I followed all the steps..

trunk$ make debug=no
GNUmakefile:1: /common.make: No such file or directory
GNUmakefile:31: /objc.make: No such file or directory
make: *** No rule to make target `/objc.make'. Stop.
Sounds like an issue with step 1.2 in Getafix’s write-up. Also, you probably need to start a new shell after that step.

Posted: Thu Oct 02, 2008 5:21 pm
by Micha
Run this before you type 'make':

Code: Select all

$ . `locate GNUstep.sh`
This sets up your GNU-Step development environment.

If you don't have GNUstep.sh (use 'locate' to find it) on your system then you haven't fully installed your development environment.

You can also put this into your .bashrc (if you use bash) in order to set this up automatically for every new shell.

<edit>This is actually step 1.2 of the howto</edit>

Re: Help on similar issue...

Posted: Wed Oct 22, 2008 6:56 pm
by MilqToaste
Ahruman wrote:
newtonke wrote:Help, I have GNUmakefile. Appreciated. Ubuntu 64 on a Core2 w/4gig ram

I followed all the steps..

trunk$ make debug=no
GNUmakefile:1: /common.make: No such file or directory
GNUmakefile:31: /objc.make: No such file or directory
make: *** No rule to make target `/objc.make'. Stop.
Sounds like an issue with step 1.2 in Getafix’s write-up. Also, you probably need to start a new shell after that step.
A odd note: I was only able to get past this by
a) launching an instance of bash as my shell (default shell is zsh) and
b) by explicitly running (in the bash shell)

Code: Select all

           %>source  /usr/share/GNUstep/Makefiles/GNUstep.sh 
before executing (also in the bash shell)

Code: Select all

           %>make debug=no

Another linux user! :)

Posted: Sun Oct 26, 2008 5:02 am
by bullfrog
Hi guys!
First of all, many compliments for the good work on this game! It's very cool and it's nice to see that old good games never die! :)

Then, the bitter part... I'm using Debian testing, I've followed the instructions as per this thread but seems at the very end something goes wrong:
.
.
.
rm -rf oolite.app
/usr/share/GNUstep/Makefiles/mkinstalldirs oolite.app
/usr/share/GNUstep/Makefiles/mkinstalldirs oolite.app /Resources
cp -r Resources oolite.app
cp -r Schemata oolite.app /Resources
cp src/Cocoa/Info-Oolite.plist oolite.app /Resources/Info-gnustep.plist
cp: target `/Resources/Info-gnustep.plist' is not a directory
make: *** [after-all] Error 1
Seems it creates a /Resouces dir in the main root, which I believe is not what is supposed to happen.
The prg is compiled and I found it in obj/oolite so I put Schemata and Resources into oolite.app dir, together with the binary. Seems working but I haven't had time to test it, yet, so dunno if there's something else missing (it may be working using the data installed by the stable deb package I've on my system).

Maybe you're already aware of this but I thought that I would find a reason to win my lazyness and post my appreciation for your efforts! ;)

Keep up the good work!

EDIT: actually, I found http://www.alioth.net/oolite/status.html which depicts how things should go. Modified it to match the location of mkinstalldirs for Debian and now I think I'm good to go! :)
Hopefully this will help anyone else in trouble compiling the game from src.

Posted: Sun Oct 26, 2008 7:52 pm
by DaddyHoggy
Wecome Bullfrog - enjoy both the game and this forum!

Beijing? Wow - has it recovered from the Olympics yet?

uh oh

Posted: Mon Nov 03, 2008 1:59 am
by chomann
so i just upgraded to intrepid ibex and now oolite wont even start...when i try to run it ...the only error i get is that
"The program 'oolite' is currently not installed. You can install it by typing:
sudo apt-get install oolite"

how can i get oolite back???!!!!


im running the 1.7 version

Posted: Mon Nov 03, 2008 6:59 am
by Micha
Considering default Ubuntu Oolite is still at 1.65 you must have compiled it yourself. How did you compile it (make or dpkg-buildpackage?) and if the former, where did you install it? If the latter, it's possible the upgrade removed it for some reason (shouldn't have but you never know).
You can try typing:

Code: Select all

$ locate oolite.app
to find it.

Posted: Mon Nov 03, 2008 6:40 pm
by chomann
Micha wrote:Considering default Ubuntu Oolite is still at 1.65 you must have compiled it yourself. How did you compile it (make or dpkg-buildpackage?) and if the former, where did you install it? If the latter, it's possible the upgrade removed it for some reason (shouldn't have but you never know).
You can try typing:

Code: Select all

$ locate oolite.app
to find it.
I built ir just as told on this threads original post. I also re-did all the steps to re-install 1.71 and still nothing... the tree is /home/.oolite/oolite.app/oolite.... and even this does nt run it... nothing works.. i did notice that in ibex the gnustep was removed, but as i said ive put it all back in and still nothing.....

Posted: Mon Nov 03, 2008 8:06 pm
by Micha
When you say 'nothing' do you mean to say literally nothing appears on the terminal after you run it apart from another command prompt? No error messages at all?

What about in the Oolite log files? (~/.Oolite/Logs by default).

Also, "/home/.oolite/oolite.app/oolite" is a rather odd directory - did you mean "/home/<your user name>/.oolite/oolite.app/oolite"?

Posted: Mon Nov 03, 2008 8:47 pm
by chomann
yes i meant the second one... and as for nothing i literally mean nothing...nothing in the log and when i try to run it straight from terminal all i ge is a message saying that oolite is not installed and to install it go to the repositories... when the repositories only have 1.65 i have the 1.71 development version...which for some wierd reaon will not run under ibex

Posted: Mon Nov 03, 2008 10:27 pm
by JensAyton
I’m downloading Ibex tonight and I’ll give it a shot sometime this week.

In the meantime, if you want to follow the releases using svn, the command for 1.72 is:

Code: Select all

svn co -r1826 http://svn.berlios.de/svnroot/repos/oolite-linux/branches/1.72-maintenance/