[Solved] Joystick problems after working flawlessly.

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
woodcrafter
Poor
Poor
Posts: 4
Joined: Fri Mar 03, 2017 5:19 am

[Solved] Joystick problems after working flawlessly.

Post by woodcrafter » Sat Mar 04, 2017 6:37 pm

Greetings all.
I am not new to the Oolite forums at all. Just recently returned from a prolonged absence.

As I mentioned in the subject, the joystick was working great after installing Oolite then all of a sudden it stopped, and I cannot get it to work again.
The computer is an HP 2000 laptop, running LXLE Eclectica 16.04.1 32bit.
The controller (joystick) is a modified Microsoft Xbox controller. As I mentioned, it was working great.
When I run the command lsusb I can see the controller but if I run a system summary report, nothing shows up under the USB category so I don't think the OS even sees it.

I would appreciate any suggestions.
Please advise if I have left out any critical information.
Thanks in advance for the help.
Joe
Last edited by Getafix on Wed Mar 08, 2017 10:22 am, edited 1 time in total.
Reason: Marked as "Solved".

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13693
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Joystick problems after working flawlessly.

Post by Cody » Sat Mar 04, 2017 7:09 pm

Hi... it might be useful to know which version of Oolite you're running... 1.84, yes?
Their dreams a tattered sail in the wind

woodcrafter
Poor
Poor
Posts: 4
Joined: Fri Mar 03, 2017 5:19 am

Re: Joystick problems after working flawlessly.

Post by woodcrafter » Sat Mar 04, 2017 11:21 pm

Cody wrote: Hi... it might be useful to know which version of Oolite you're running... 1.84, yes?
I apologize Cody. Yes. It is version 1.84 that I have installed.
I can't believe that I overlooked including the version of Oolite I'm using. Doh!

Thanks for the response.

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: Joystick problems after working flawlessly.

Post by Norby » Sun Mar 05, 2017 1:15 pm

Welcome woodcrafter!

Just a general advice: try to close out a hardware problem first, so test the joy in other machine and/or plug in another stick. If you can boot another OS then you can test there also. Even a boot from a LiveCD with other Linux could help.

If HW is ok but not appear in any games then maybe your OS is misconfigured or changed somehow. If you successfully narrowed the problem to this case then tell here and most likely you will get questions from a penguinist about your config files.

If your stick is working in other games (or at least show life signs in control panel or in any calibrate tool) but Oolite refuse it then ask again here, posting the content of your ~/.Oolite/Logs/Latest.log file, probably a developer will help you. ;)

More info in the wiki:
Joystick problems Linux
Linux_Joysticks_and_Gamepads
Dizzy's_guide_to_Setting_up_Joystick_Axis_Profiles

woodcrafter
Poor
Poor
Posts: 4
Joined: Fri Mar 03, 2017 5:19 am

Re: Joystick problems after working flawlessly.

Post by woodcrafter » Sun Mar 05, 2017 9:39 pm

Thank you Norby, for the suggestions and for the links you provided. I will follow the suggestions you have laid out and hopefully discover the cause for the problem.
I believe the problem may have started after an update on the computer.
I will repost when I have found something.

Thank you again.
Joe

woodcrafter
Poor
Poor
Posts: 4
Joined: Fri Mar 03, 2017 5:19 am

Re: Joystick problems after working flawlessly.

Post by woodcrafter » Wed Mar 08, 2017 3:25 am

The joystick is working again!!! I don't know what happened but it is now working.

I will try to explain what occurred prior to my noticing the joystick working again.
I read through the information that Norby provided.
First I attached the joystick (xbox controller) to another computer to rule out hardware issues. The joystick worked fine on that machine.
So I had a thought....I went back to the laptop where this issue started and, because I have several commanders saved; each with different ship types, commander names and missions assigned to each, I reattached the joystick and opened the game, selected a different commander from the list and started the game. The joystick worked fine with that commander.
So I closed and reopened Oolite, selected the commander that I originally had the issue with and the joystick was working again!
Although, none of the original joystick settings that I applied held. I had to go into the menu and reapply the 'stick settings. But it is working again.
I did not apply any of the suggestions from the information provided by Norby because the joystick was working. Although, there is some great information there and I will keep it for future reference.

Thank you Norby, for your help.
And Cody, for catching the information I left out in my original post. (Oolite version)
With much gratitude. :)
-Joe-

Post Reply