[Solved] Help to build oolite 1.82 on slackware 14.1

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
franzen
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun Jan 10, 2016 2:13 pm

[Solved] Help to build oolite 1.82 on slackware 14.1

Post by franzen » Sun Jan 10, 2016 2:29 pm

Hi,

i'm trying to build oolite on slackware 14.1, and fail.
gnustep-make is installed, i tried building oolite with these commands:

Code: Select all

source /usr/share/GNUstep/Makefiles/GNUstep.sh
export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
sed -i "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions/" GNUmakefile
make -f libjs.make debug=no 
make -f Makefile ESPEAK=yes release-deployment 
Following error occourcs:

Code: Select all

make -f GNUmakefile DEPLOYMENT_RELEASE_CONFIGURATION=yes debug=no
This is gnustep-make 2.6.7. Type 'gmake print-gnustep-make-help' for help.
make[1]: Entering directory `/usr/src/build/kaffee/oolite/oolite-source-1.82'
/usr/share/GNUstep/Makefiles/objc.make:30: objc.make is deprecated.  Please use tool.make instead
/usr/share/GNUstep/Makefiles/objc.make:30: objc.make is deprecated.  Please use tool.make instead
Making all for objc_program oolite...
/usr/share/GNUstep/Makefiles/objc.make:30: objc.make is deprecated.  Please use tool.make instead
/usr/share/GNUstep/Makefiles/objc.make:30: objc.make is deprecated.  Please use tool.make instead
 Compiling file src/Core/OOPlanetData.c ...
In file included from src/Core/OOPlanetData.h:10:0,
                 from src/Core/OOPlanetData.c:10:
src/Core/OOOpenGLOnly.h:70:2: error: #error OOOpenGL.h: unknown target!
 #error OOOpenGL.h: unknown target!
  ^
Thanks for your help!

Franzen
Last edited by Getafix on Thu Mar 24, 2016 6:29 pm, edited 1 time in total.
Reason: Marked as "Solved"

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5394
Joined: Wed Feb 28, 2007 7:54 am

Re: Help to build oolite 1.82 on slackware 14.1

Post by another_commander » Sun Jan 10, 2016 3:52 pm

It looks like the build is failing because the GNUSTEP macro is not defined, which suggests that gnustep-base might be missing. Have you installed it?

Hopefully a more Linux-savvy person will be here soon to assist you more efficiently.

Edit: In the meantime, try to build using make messages=yes and see if GNUSTEP appears as a defined macro in the build command line.

franzen
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun Jan 10, 2016 2:13 pm

Re: Help to build oolite 1.82 on slackware 14.1

Post by franzen » Sun Jan 10, 2016 7:56 pm

another_commander wrote:It looks like the build is failing because the GNUSTEP macro is not defined, which suggests that gnustep-base might be missing. Have you installed it?
That's it! I builded/installed gnstep-base, now also oolite compiles, big thanks!
According to http://wiki.alioth.net/index.php/Runnin ... rom_source i thought gnustep-startup or gnustep-make would be sufficient.
Now i'll practice flying :D

Franzen

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13616
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Help to build oolite 1.82 on slackware 14.1

Post by Cody » Sun Jan 10, 2016 8:03 pm

Cool... welcome aboard, Commander!

Post Reply