Oolite Bulletins

For information and discussion about Oolite.
It is currently Fri Dec 15, 2017 7:41 pm

All times are UTC




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Sep 11, 2015 4:44 pm 
Offline
Retired Assassin
Retired Assassin
User avatar

Joined: Thu Aug 12, 2004 4:54 pm
Posts: 1739
Location: Belgium
Very entertaining bug (or feature!)

I just installed Oolite 1.82 in Debian Testing, and it's pretty dang totally amazing (I had a hiatus since somewhere around 1.76, I think)

But... My ship seemed to have a mind of its own... It went everywhere, couldn't fly in a straight line.

Turns out my laptop (Oldish core2duo MacBook) 'sees' the accelerometers (applesmc) as joystick input by default!

I can fly it by tilting the laptop, very cool, amazingly geeky... for about two minutes, then the gorilla arm syndrome kicks in. 't aint no no fancy airbook :mrgreen:

So... How do I fix this?

...

(EDIT: Hmmm this should go in testing and bugreports?)


Last edited by Getafix on Mon Sep 14, 2015 7:46 am, edited 1 time in total.
Marked as "Solved"


Top
   
PostPosted: Fri Sep 11, 2015 5:38 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Fri Nov 11, 2011 6:19 pm
Posts: 4015
There's probably a way to stop them registering as joysticks at all, but I've no idea what. You should be able to use the Oolite in-game joystick config to unbind them from the axes - or failing that at least set a deadzone large enough that you don't turn unless you really tilt the laptop hard.

_________________
OXPs: [EliteWiki] New Cargoes, [EliteWiki] Skilled NPCs, [EliteWiki] Curse of the Black Sunspot, and more


Top
   
PostPosted: Fri Sep 11, 2015 8:54 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 08, 2007 10:59 pm
Posts: 545
Location: Netherlands
Rxke,

search for a file with *joystick.conf as name (50-joystick.conf is the most common name, and it's likely in /etc/X11/xorg.conf.d or /usr/share/X11/xorg.conf.d ).

If it's not present on your system, try installing a package called xf86-input-joystick (no idea how debian calls it) .

------------------------
X nowadays mostly uses evdev for input support, and the package xf86-input-joystick is evdev-aware.
By tweaking 50-joystick.conf you can change many settings .

example : by default X sends joystick events not only to the (virtual) joystick input device, but also to mouse and keyboard input devices.
I disabled that behaviour by tweaking 50-joystick.conf .

_________________
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.


Top
   
PostPosted: Sat Sep 12, 2015 4:47 am 
Offline
Retired Assassin
Retired Assassin
User avatar

Joined: Thu Aug 12, 2004 4:54 pm
Posts: 1739
Location: Belgium
cim's suggestion of increasing the dead zone did the trick, now I can still use it if I tilt the laptop more than 45-ish degrees.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited