Occasional stuttering sound under Oolite v1.8x / Linux Mint

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Ranthe
---- E L I T E ----
---- E L I T E ----
Posts: 330
Joined: Sat Oct 13, 2012 7:35 pm
Location: Paraparaumu, New Zealand (TL 8, Rich Agricultural, Multi-Government)

Occasional stuttering sound under Oolite v1.8x / Linux Mint

Post by Ranthe » Sat Jun 06, 2015 8:17 pm

Hi,

I've noticed on occasion when running Oolite v1.80 and v1.82 under Linux Mint 17.1 that I get a sound stuttering problem turning up. Most of the time I have to restart the game to fix it, but sometimes it seems to resolve itself - and it doesn't appear to affect the 'read messages' voice. It doesn't seem to matter whether i'm running under the Cinnamon or Xfce desktop.

I recall when I was running the Windows version of Oolite there was an additional .DLL or config change that could be done to resolve stuttering. Is there an equivalent config change under Linux?

The output from inxi -Fxz on my system is below.

Code: Select all

System:    Host: Vixen-IV-L Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Gnome Distro: Linux Mint 17.1 Rebecca
Machine:   Mobo: Gigabyte model: GA-MA78GM-S2H version: x.x Bios: Award version: F5 date: 06/18/2008
CPU:       Dual core AMD Athlon 64 X2 5000+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 4008.62 
           Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 610] bus-ID: 01:00.0 
           X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1680x1050@60.0hz 
           GLX Renderer: GeForce GT 610/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.113 Direct Rendering: Yes
Audio:     Card-1: NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Commander Ranthe: Flying the Anaconda-class transport Atomic Annie through Galaxy 2.
Combat Ranking: Dangerous
"Big ships take more booty on your interstellar flights..."

User avatar
Lone_Wolf
---- E L I T E ----
---- E L I T E ----
Posts: 545
Joined: Wed Aug 08, 2007 10:59 pm
Location: Netherlands

Re: Occasional stuttering sound under Oolite v1.8x / Linux M

Post by Lone_Wolf » Sun Jun 07, 2015 10:02 am

Please post a latest.log of such a crash

dmesg or journal output would also help.

Is this a pure alsa system or do you also use pulseaudio ?

HDMI audio or onboard audio ?
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.

Post Reply