Oolite Bulletins

For information and discussion about Oolite.
It is currently Thu Sep 21, 2017 8:26 am

All times are UTC




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat Dec 06, 2014 4:31 am 
Offline
Competent
Competent
User avatar

Joined: Fri Sep 14, 2012 3:17 am
Posts: 53
Location: Texas QLD
Did update recently, prior to which Oolite was going well. Now, it won't boot - following is content of log file:
----------------------------------------------------------------------------------------------------------

Opening log for Oolite version 1.80 (x86-32) under Linux 3.16.0-4-686-pae at 2014-12-06 14:23:18 +1000.
4 processors detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

14:23:26.498 [display.mode.list.native]: X11 native resolution detected: 1366 x 768
14:23:26.499 [display.mode.error]: ***** ERROR: Could not create display surface: Couldn't find matching GLX visual

Closing log at 2014-12-06 14:23:26 +1000.
----------------------------------------------------------------------------------------------------------
Any ideas to fix would be greatfully appreciated.

_________________
"Blessed are the cracked, for they let the light shine in". Spike Milligan
Location: G3. Flying: Dark Star. Status: Clean. Rating: Dangerous
Ubuntu 12.04/XFCE4/Unity on Toshiba Laptop


Top
   
PostPosted: Sat Dec 06, 2014 4:57 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon Apr 06, 2009 12:20 pm
Posts: 6178
Location: Aboard the Pitviper S.E. "Blackwidow"
It would appear to be graphics related.. what graphics chip and drivers/version are you using?

_________________
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied


Top
   
PostPosted: Sat Dec 06, 2014 10:36 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon May 20, 2013 9:53 pm
Posts: 2388
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Make sure you have Mesa driver and some tools. I have the following packages:
Code:
libglu1-mesa
libgl1-mesa-glx
libgl1-mesa-dri
libglapi-mesa
mesa-utils
pciutils
Then type lspci to know your graphics card and glxinfo for more information about your Mesa driver. Then post the outputs back here. Here is my glxinfo:
Code:
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, 
    GLX_INTEL_swap_event
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_create_context_es2_profile, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control, 
    GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap, GLX_INTEL_swap_event
GLX version: 1.4
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control, 
    GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Desktop x86/MMX/SSE2
OpenGL version string: 3.0 Mesa 8.0.5
OpenGL shading language version string: 1.30
...

_________________
OXPs by Norby


Top
   
PostPosted: Sun Dec 07, 2014 1:38 am 
Offline
Competent
Competent
User avatar

Joined: Fri Sep 14, 2012 3:17 am
Posts: 53
Location: Texas QLD
lspci:
-------------------------------------------------------------------
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
----------------------------------------------------
glxinfo:
----------------------------------------------------
name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
----------------------------------------------------------------------------
Now, will try and find out why went MIA.

Everything was running great, did upgrade that got interupted due to storm. At least I know have Xwindows back as it was, but lots of nvidia drivers etc loaded

_________________
"Blessed are the cracked, for they let the light shine in". Spike Milligan
Location: G3. Flying: Dark Star. Status: Clean. Rating: Dangerous
Ubuntu 12.04/XFCE4/Unity on Toshiba Laptop


Top
   
PostPosted: Sun Dec 07, 2014 4:49 am 
Offline
Competent
Competent
User avatar

Joined: Fri Sep 14, 2012 3:17 am
Posts: 53
Location: Texas QLD
At last starting to make some progress, so recording this information here for others:

--------------------------------------------------------------------------------------------------------------------------------
I have the following card:
Code:
$lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
The results of glxinfo is:
Code:
$glxinfo
name of display: :0 Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Error: couldn't find RGB GLX visual or fbconfig Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0".

Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0".
How can I fix that? I everything on google about this talks about nvidia cards, I only have the intel one. I'm trying ti with the gears test:
Code:
$ glxgears Xlib: extension "GLX" missing on display ":0". Error: couldn't get an RGB, Double-buffered visual
Edit

After a lot of digging around the problem was the nvidia drivers that steam installed without tellign me.

Solve it by
Code:
apt-get purge nvidia*

sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

sudo dpkg-reconfigure xserver-xorg
And then linking the mesa libgl.so.1 to the system one:
Code:
 sudo ln -s /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1 /usr/lib/libGL.so.1
And then a reboot. Steam still doesn't work however with:
Code:
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
EDIT2

Success for steam too! Turns out the problems is that steam is a 32bit app and needs the 32bit libraries, and the nvidia files were still being pointed to by the simlinks, solved that by:
Code:
sudo rm /usr/lib/i386-linux-gnu/libGL.so.1
sudo ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so.1
I am happy I figured this out, I am not happy I have steam on my computer again.
-----------------------------------------------------------------------------------------------------------------------------
Taken from this post: https://www.reddit.com/r/debian/comment ... display_0/

_________________
"Blessed are the cracked, for they let the light shine in". Spike Milligan
Location: G3. Flying: Dark Star. Status: Clean. Rating: Dangerous
Ubuntu 12.04/XFCE4/Unity on Toshiba Laptop


Top
   
PostPosted: Mon Dec 08, 2014 11:26 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon Apr 06, 2009 12:20 pm
Posts: 6178
Location: Aboard the Pitviper S.E. "Blackwidow"
Congratulations on solving the problem(s)!
Quote:
I am not happy I have steam on my computer again.
So, ummm.. why do you have it?

_________________
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited