[Solved] Failed to initialize backend "pulse"

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Failed to initialize backend "pulse"

Post by Getafix » Tue Jun 10, 2014 8:01 am

Neelix wrote:...I'm still running Ubuntu 10.04.
This shouldn't be an issue.


Please, open a terminal and post here the result of the following:

Code: Select all

$ uname -a
EDIT 2:
cim wrote:Okay, so that is in OpenAL - looks like some conflict between OpenAL and ALSA (libasound) on your system. You might have some luck by changing the "drivers=" line in /etc/openal/alsoft.conf to exclude the "alsa" driver.
Revert the alsoft.conf change to the original configuration.

Then, please, execute the following

Code: Select all

$ cd /opt/Oolite-trunk/oolite-deps/lib
$ sudo mv libopenal.so.1 libopenal.so.1.oolite
$ cd ~
$ oolite-trunk
This will force oolite-trunk to use your system's libopenal.so.1 library
(considering that you have one installed, of course; at my vanilla Ubuntu 10.04 installation resides at /usr/lib/libopenal.so.1).
Last edited by Getafix on Tue Jun 10, 2014 10:22 am, edited 1 time in total.
Reason: Updated title following "split" operation
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Neelix
---- E L I T E ----
---- E L I T E ----
Posts: 288
Joined: Sat May 31, 2014 9:02 pm
Location: Melbourne, Australia

[Solved] Re: Failed to initialize backend "pulse"

Post by Neelix » Tue Jun 10, 2014 9:23 am

Getafix wrote: Please, open a terminal and post here the result of the following:

Code: Select all

$ uname -a
Linux nb-fezzik 2.6.32-57-generic #119-Ubuntu SMP Wed Feb 19 01:04:55 UTC 2014 i686 GNU/Linux

Getafix wrote: EDIT 2:
cim wrote:Okay, so that is in OpenAL - looks like some conflict between OpenAL and ALSA (libasound) on your system. You might have some luck by changing the "drivers=" line in /etc/openal/alsoft.conf to exclude the "alsa" driver.
Revert the alsoft.conf change to the original configuration.

Then, please, execute the following

Code: Select all

$ cd /opt/Oolite-trunk/oolite-deps/lib
$ sudo mv libopenal.so.1 libopenal.so.1.oolite
$ cd ~
$ oolite-trunk
This will force oolite-trunk to use your system's libopenal.so.1 library
(considering that you have one installed, of course; at my vanilla Ubuntu 10.04 installation resides at /usr/lib/libopenal.so.1).
That worked! :-) I can now start oolite-trunk and the sound works too. Many thanks. :-)

- Neelix
Last edited by Getafix on Tue Jun 10, 2014 10:23 am, edited 2 times in total.
Reason: Updated title following "split" operation
Talaxian Enterprises: [wiki]Vacuum Pump[/wiki] [wiki]Waypoint Here[/wiki]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Failed to initialize backend "pulse"

Post by Getafix » Tue Jun 10, 2014 10:14 am

Neelix wrote:That worked! :-) I can now start oolite-trunk and the sound works too. Many thanks. :-)
Good to hear this Neelix.

I also checked that on Kubuntu 10.04 vanilla installation, no such issue exist.
Last edited by Getafix on Tue Jun 10, 2014 10:23 am, edited 1 time in total.
Reason: Updated title following "split" operation
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Fri Oct 23, 2015 12:36 pm

So, what happened there?
I'm getting the same sort of errors
~$ oolite
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
*** Error in `./oolite.app/oolite': double free or corruption (!prev): 0x09d6c268 ***
Aborted (core dumped)
Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.
I tried getting "pulse" to work, but it shut down my sound in Skype (essential when I'm on a different continent to the wife) and after several days of work I managed to get that working again. No more mucking around with the sound system then.
But I'm still getting crashes on 1.82 after a few minutes of play. Normally when the game starts to get complicated.
You asked about the system details :
~$ uname -a
Linux aidank-ThinkPad-X60 3.16.0-44-generic #59-Ubuntu SMP Tue Jul 7 02:14:37 UTC 2015 i686 i686 i686 GNU/Linux
I've uninstalled almost all OXPs (version 1.82 is the only one that I've ever succeeded in getting an OXP to work on, as far as I know) except the Captain's Log and Behemoth, none of which ask for things like "shaders" (if that's a component of the graphics card, I'm pretty sure that I don't have one).
Actually, I'm just going to uninstall all of them and live without them. Is it common to require things like "shaders" without testing for their presence?
An Nvidia driver was mentioned. If there is one present, I don't know why because I think it's an Intel graphics card.

EDIT : uninstalled the last of the OXPs. Nothing left. Still the same sort of crash.
~$ oolite
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
*** Error in `./oolite.app/oolite': free(): invalid next size (normal): 0x09cb8900 ***
Aborted (core dumped)
Erk. ...
Hang on - that "AL lib is about the ALSA sound system isn't it? But this has pulse? Is that right? I know nothing about sound systems and care even less as long as it works.
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Failed to initialize backend "pulse"

Post by Getafix » Fri Oct 23, 2015 2:11 pm

Is it possible for you to perform the following, please?
cim wrote:...Could you try the following, please:
1) Install gdb if it's not already installed
2) Edit the "oolite.app/oolite-wrapper" file to replace ./oolite.app/oolite "$@" with gdb ./oolite.app/oolite "$@"
3) Run oolite-trunk again. At the gdb prompt, type "run", and then when it crashes, type "bt".
4) Paste the entire output of gdb here.
Please, also post the ~/.Oolite/Logs/Latest.log contents.

EDIT: where "oolite-trunk" is just "oolite" for your case.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Fri Oct 23, 2015 4:15 pm

Install gdb
Is installing an entire programming environment necessary? I really don't want to do more than is absolutely necessary.
I'm tempted just to go back to the last version. I really do not need to waste another day messing with the depths of the sound system. Or a programming environment.

EDIT
I checked. It's not installed. Nearly 300 packages in GDB according to Synaptic. Nope, that it far too big a minefield. I don't see any versions with built-in debugging, so ... upgrade to the old version seems to be the solution.
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Fri Oct 23, 2015 4:44 pm

Oh well, that's the problem solved now. It doesn't work at all after a re-install.
I'll try the next version.
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Fri Oct 30, 2015 10:53 am

It would look like there were other problems building up in the computer - something falling apart in Lubuntu, which I'm going to have to address separately. But the machine stopped working at all (oddly, first symptom was the battery suddenly failing to report charge sanely), then simply wouldn't boot. So ... I put in the original hard drive which has an almost vanilla install of Trisquel on it. That boots fine, so apart from the battery going, the hardware is OK (the machine is a reconditioned ThinkPad X60 ; solid as bricks and about as exciting).
However, for shits and giggles I put the current version of Oolite onto it .... and got the same sort of crash as I had previously on the Lubuntu install, so I'm guessing that there is something about the hardware which is tripping things up.
Given that this is a very dull and extremely corporate machine, that may be a more interesting question.
The crash report I got from the Trisquel install is much more detailed than what I got from the Lubuntu install.
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
*** glibc detected *** ./oolite.app/oolite: double free or corruption (!prev): 0x0a2785d8 ***
======= Backtrace: =========
/lib/i386-linux-gnu/libc.so.6(+0x74f82)[0xfe6f82]
/usr/lib/i386-linux-gnu/dri/i915_dri.so(intelDestroyContext+0x7f)[0x77982af]
/usr/lib/i386-linux-gnu/dri/i915_dri.so(+0xd70a)[0x777470a]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x403ca)[0x2363ca]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(glXDestroyContext+0x102)[0x20cda2]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(+0x41476)[0x151476]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(+0x45807)[0x155807]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(+0x45a39)[0x155a39]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(SDL_VideoQuit+0x50)[0x1419e0]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(SDL_QuitSubSystem+0x64)[0x115c04]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(SDL_Quit+0x1e)[0x115c7e]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0(+0x64af)[0x1164af]
[0xa37400]
./oolite.app/oolite[0x817ac21]
./oolite.app/oolite[0x807abdb]
./oolite.app/oolite[0x8115bdf]
./oolite.app/oolite[0x82aba80]
./oolite.app/oolite[0x827a18c]
./oolite.app/oolite[0x8274f70]
./oolite.app/oolite[0x8274fee]
./oolite.app/oolite[0x8275038]
./oolite.app/oolite[0x826ea2b]
./oolite.app/oolite[0x826dbde]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x177cf5)[0x68dcf5]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x1e80c5)[0x6fe0c5]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x1b58c7)[0x6cb8c7]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x1b6a4d)[0x6cca4d]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x1b6cd6)[0x6cccd6]
/home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20(+0x1b6bb8)[0x6ccbb8]
./oolite.app/oolite[0x826e416]
./oolite.app/oolite(main+0x1f0)[0x82748f0]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0xf8b4d3]
======= Memory map: ========
00110000-00177000 r-xp 00000000 08:06 1744830625 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0
00177000-00178000 rw-p 00067000 08:06 1744830625 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libSDL-1.2.so.0
00178000-001a4000 rw-p 00000000 00:00 0
001a4000-001bb000 r-xp 00000000 08:01 266654 /lib/i386-linux-gnu/libpthread-2.15.so
001bb000-001bc000 r--p 00016000 08:01 266654 /lib/i386-linux-gnu/libpthread-2.15.so
001bc000-001bd000 rw-p 00017000 08:01 266654 /lib/i386-linux-gnu/libpthread-2.15.so
001bd000-001bf000 rw-p 00000000 00:00 0
001bf000-001e2000 r-xp 00000000 08:06 1744830623 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libpng14.so.14
001e2000-001e3000 rw-p 00022000 08:06 1744830623 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libpng14.so.14
001e3000-001f3000 r-xp 00000000 08:01 4522 /usr/lib/i386-linux-gnu/libXext.so.6.4.0
001f3000-001f4000 r--p 0000f000 08:01 4522 /usr/lib/i386-linux-gnu/libXext.so.6.4.0
001f4000-001f5000 rw-p 00010000 08:01 4522 /usr/lib/i386-linux-gnu/libXext.so.6.4.0
001f5000-001f6000 rwxp 00000000 00:00 0
001f6000-00248000 r-xp 00000000 08:01 5812 /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2
00248000-0024a000 r--p 00051000 08:01 5812 /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2
0024a000-0024f000 rwxp 00053000 08:01 5812 /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2
0024f000-0026b000 r-xp 00000000 08:01 261792 /lib/i386-linux-gnu/libgcc_s.so.1
0026b000-0026c000 r--p 0001b000 08:01 261792 /lib/i386-linux-gnu/libgcc_s.so.1
0026c000-0026d000 rw-p 0001c000 08:01 261792 /lib/i386-linux-gnu/libgcc_s.so.1
0026d000-00271000 r-xp 00000000 08:01 65 /usr/lib/i386-linux-gnu/libXfixes.so.3.1.0
00271000-00272000 r--p 00004000 08:01 65 /usr/lib/i386-linux-gnu/libXfixes.so.3.1.0
00272000-00273000 rw-p 00005000 08:01 65 /usr/lib/i386-linux-gnu/libXfixes.so.3.1.0
00273000-00274000 rwxp 00000000 00:00 0
00275000-00276000 rwxp 00000000 00:00 0
00276000-00279000 r-xp 00000000 08:01 279245 /lib/i386-linux-gnu/libdl-2.15.so
00279000-0027a000 r--p 00002000 08:01 279245 /lib/i386-linux-gnu/libdl-2.15.so
0027a000-0027b000 rw-p 00003000 08:01 279245 /lib/i386-linux-gnu/libdl-2.15.so
0027b000-00353000 r-xp 00000000 08:01 5058 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16
00353000-00354000 ---p 000d8000 08:01 5058 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16
00354000-00358000 r--p 000d8000 08:01 5058 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16
00358000-00359000 rw-p 000dc000 08:01 5058 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16
00359000-00360000 rw-p 00000000 00:00 0
00360000-003a9000 r-xp 00000000 08:06 1744830616 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libopenal.so.1
003a9000-003ab000 rw-p 00049000 08:06 1744830616 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libopenal.so.1
003ab000-003dd000 r-xp 00000000 08:06 1744830617 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libespeak.so.1
003dd000-003e0000 rw-p 00031000 08:06 1744830617 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libespeak.so.1
003e0000-0040d000 rw-p 00000000 00:00 0
0040d000-00437000 r-xp 00000000 08:01 279243 /lib/i386-linux-gnu/libm-2.15.so
00437000-00438000 r--p 00029000 08:01 279243 /lib/i386-linux-gnu/libm-2.15.so
00438000-00439000 rw-p 0002a000 08:01 279243 /lib/i386-linux-gnu/libm-2.15.so
00439000-00448000 r-xp 00000000 08:01 4756 /usr/lib/i386-linux-gnu/libglapi.so.0.0.0
00448000-0044a000 r--p 0000f000 08:01 4756 /usr/lib/i386-linux-gnu/libglapi.so.0.0.0
0044a000-0044f000 rwxp 00011000 08:01 4756 /usr/lib/i386-linux-gnu/libglapi.so.0.0.0
00452000-00454000 r-xp 00000000 08:01 4534 /usr/lib/i386-linux-gnu/libXdamage.so.1.1.0
00454000-00455000 r--p 00001000 08:01 4534 /usr/lib/i386-linux-gnu/libXdamage.so.1.1.0
00455000-00456000 rw-p 00002000 08:01 4534 /usr/lib/i386-linux-gnu/libXdamage.so.1.1.0
00456000-0045b000 r-xp 00000000 08:06 1744834517 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libffi.so.4
0045b000-0045c000 rw-p 00005000 08:06 1744834517 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libffi.so.4
0045c000-0047c000 r-xp 00000000 08:06 1744830629 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libportaudio.so.2
0047c000-0047d000 rw-p 00020000 08:06 1744830629 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libportaudio.so.2
0047d000-00482000 r-xp 00000000 08:01 4536 /usr/lib/i386-linux-gnu/libXdmcp.so.6.0.0
00482000-00483000 r--p 00004000 08:01 4536 /usr/lib/i386-linux-gnu/libXdmcp.so.6.0.0
00483000-00484000 rw-p 00005000 08:01 4536 /usr/lib/i386-linux-gnu/libXdmcp.so.6.0.0
00484000-00487000 r-xp 00000000 08:01 8012 /usr/lib/i386-linux-gnu/gconv/UTF-16.so
00487000-00488000 r--p 00002000 08:01 8012 /usr/lib/i386-linux-gnu/gconv/UTF-16.so
00488000-00489000 rw-p 00003000 08:01 8012 /usr/lib/i386-linux-gnu/gconv/UTF-16.so
00489000-00494000 r-xp 00000000 08:01 266656 /lib/i386-linux-gnu/libnss_files-2.15.so
00494000-00495000 r--p 0000a000 08:01 266656 /lib/i386-linux-gnu/libnss_files-2.15.so
00495000-00496000 rw-p 0000b000 08:01 266656 /lib/i386-linux-gnu/libnss_files-2.15.so
00496000-0049f000 r-xp 00000000 08:01 4532 /usr/lib/i386-linux-gnu/libXcursor.so.1.0.2
0049f000-004a0000 r--p 00008000 08:01 4532 /usr/lib/i386-linux-gnu/libXcursor.so.1.0.2
004a0000-004a1000 rw-p 00009000 08:01 4532 /usr/lib/i386-linux-gnu/libXcursor.so.1.0.2
004a1000-00514000 r-xp 00000000 08:01 4500 /usr/lib/i386-linux-gnu/libGLU.so.1.3.08004
00514000-00515000 r--p 00072000 08:01 4500 /usr/lib/i386-linux-gnu/libGLU.so.1.3.08004
00515000-00516000 rw-p 00073000 08:01 4500 /usr/lib/i386-linux-gnu/libGLU.so.1.3.08004
00516000-00808000 r-xp 00000000 08:06 1744830622 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20
00808000-00899000 rw-p 002f1000 08:06 1744830622 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libgnustep-base.so.1.20
00899000-0089a000 rw-p 00000000 00:00 0
0089a000-008a2000 r-xp 00000000 08:01 4539 /usr/lib/i386-linux-gnu/libXrender.so.1.3.0
008a2000-008a3000 r--p 00007000 08:01 4539 /usr/lib/i386-linux-gnu/libXrender.so.1.3.0
008a3000-008a4000 rw-p 00008000 08:01 4539 /usr/lib/i386-linux-gnu/libXrender.so.1.3.0
008a4000-008a7000 r-xp 00000000 08:01 5003 /usr/lib/i386-linux-gnu/libpulse-simple.so.0.0.3
008a7000-008a8000 r--p 00002000 08:01 5003 /usr/lib/i386-linux-gnu/libpulse-simple.so.0.0.3
008a8000-008a9000 rw-p 00003000 08:01 5003 /usr/lib/i386-linux-gnu/libpulse-simple.so.0.0.3
008a9000-008b0000 r-xp 00000000 08:01 6327 /usr/lib/i386-linux-gnu/libjson.so.0.0.1
008b0000-008b1000 r--p 00006000 08:01 6327 /usr/lib/i386-linux-gnu/libjson.so.0.0.1
008b1000-008b2000 rw-p 00007000 08:01 6327 /usr/lib/i386-linux-gnu/libjson.so.0.0.1
008b2000-008b4000 r-xp 00000000 08:01 7905 /usr/lib/i386-linux-gnu/gconv/CP1252.so
008b4000-008b5000 r--p 00001000 08:01 7905 /usr/lib/i386-linux-gnu/gconv/CP1252.so
008b5000-008b6000 rw-p 00002000 08:01 7905 /usr/lib/i386-linux-gnu/gconv/CP1252.so
008b8000-008c3000 r-xp 00000000 08:01 1340 /usr/lib/i386-linux-gnu/libdrm.so.2.4.0
008c3000-008c4000 r--p 0000a000 08:01 1340 /usr/lib/i386-linux-gnu/libdrm.so.2.4.0
008c4000-008c5000 rw-p 0000b000 08:01 1340 /usr/lib/i386-linux-gnu/libdrm.so.2.4.0
008c5000-00911000 r-xp 00000000 08:01 5005 /usr/lib/i386-linux-gnu/libpulse.so.0.13.5
00911000-00912000 r--p 0004b000 08:01 5005 /usr/lib/i386-linux-gnu/libpulse.so.0.13.5
00912000-00913000 rw-p 0004c000 08:01 5005 /usr/lib/i386-linux-gnu/libpulse.so.0.13.5
00913000-00918000 r-xp 00000000 08:01 4586 /usr/lib/i386-linux-gnu/libasyncns.so.0.3.1
00918000-00919000 r--p 00004000 08:01 4586 /usr/lib/i386-linux-gnu/libasyncns.so.0.3.1
00919000-0091a000 rw-p 00005000 08:01 4586 /usr/lib/i386-linux-gnu/libasyncns.so.0.3.1
0091f000-00982000 r-xp 00000000 08:01 5006 /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
00982000-00983000 r--p 00062000 08:01 5006 /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
00983000-00984000 rw-p 00063000 08:01 5006 /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
00984000-0098c000 r-xp 00000000 08:01 261884 /lib/i386-linux-gnu/libwrap.so.0.7.6
0098c000-0098d000 r--p 00007000 08:01 261884 /lib/i386-linux-gnu/libwrap.so.0.7.6
0098d000-0098e000 rw-p 00008000 08:01 261884 /lib/i386-linux-gnu/libwrap.so.0.7.6
0098e000-00993000 r-xp 00000000 08:01 5145 /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
00993000-00994000 r--p 00004000 08:01 5145 /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
00994000-00995000 rw-p 00005000 08:01 5145 /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
00995000-0099e000 r-xp 00000000 08:01 4971 /usr/lib/i386-linux-gnu/libpciaccess.so.0.11.0
0099e000-0099f000 r--p 00008000 08:01 4971 /usr/lib/i386-linux-gnu/libpciaccess.so.0.11.0
0099f000-009a0000 rw-p 00009000 08:01 4971 /usr/lib/i386-linux-gnu/libpciaccess.so.0.11.0
009a2000-009a6000 r-xp 00000000 08:01 4568 /usr/lib/i386-linux-gnu/libXxf86vm.so.1.0.0
009a6000-009a7000 r--p 00003000 08:01 4568 /usr/lib/i386-linux-gnu/libXxf86vm.so.1.0.0
009a7000-009a8000 rw-p 00004000 08:01 4568 /usr/lib/i386-linux-gnu/libXxf86vm.so.1.0.0
009a8000-009ef000 r-xp 00000000 08:01 261657 /lib/i386-linux-gnu/libdbus-1.so.3.5.8
009ef000-009f0000 ---p 00047000 08:01 261657 /lib/i386-linux-gnu/libdbus-1.so.3.5.8
009f0000-009f1000 r--p 00047000 08:01 261657 /lib/i386-linux-gnu/libdbus-1.so.3.5.8
009f1000-009f2000 rw-p 00048000 08:01 261657 /lib/i386-linux-gnu/libdbus-1.so.3.5.8
009f7000-009f8000 r-xp 00000000 08:01 1346 /usr/lib/i386-linux-gnu/libX11-xcb.so.1.0.0
009f8000-009f9000 r--p 00000000 08:01 1346 /usr/lib/i386-linux-gnu/libX11-xcb.so.1.0.0
009f9000-009fa000 rw-p 00001000 08:01 1346 /usr/lib/i386-linux-gnu/libX11-xcb.so.1.0.0
009fa000-00a0d000 r-xp 00000000 08:01 268362 /lib/i386-linux-gnu/libresolv-2.15.so
00a0d000-00a0e000 ---p 00013000 08:01 268362 /lib/i386-linux-gnu/libresolv-2.15.so
00a0e000-00a0f000 r--p 00013000 08:01 268362 /lib/i386-linux-gnu/libresolv-2.15.so
00a0f000-00a10000 rw-p 00014000 08:01 268362 /lib/i386-linux-gnu/libresolv-2.15.so
00a10000-00a12000 rw-p 00000000 00:00 0
00a12000-00a33000 r-xp 00000000 08:01 2837 /usr/lib/i386-linux-gnu/libdrm_intel.so.1.0.0
00a33000-00a34000 r--p 00020000 08:01 2837 /usr/lib/i386-linux-gnu/libdrm_intel.so.1.0.0
00a34000-00a35000 rw-p 00021000 08:01 2837 /usr/lib/i386-linux-gnu/libdrm_intel.so.1.0.0
00a37000-00a38000 r-xp 00000000 00:00 0 [vdso]
00a38000-00a84000 r-xp 00000000 08:01 4658 /usr/lib/i386-linux-gnu/libFLAC.so.8.2.0
00a84000-00a85000 r--p 0004b000 08:01 4658 /usr/lib/i386-linux-gnu/libFLAC.so.8.2.0
00a85000-00a86000 rw-p 0004c000 08:01 4658 /usr/lib/i386-linux-gnu/libFLAC.so.8.2.0
00a93000-00a9a000 r-xp 00000000 08:01 279246 /lib/i386-linux-gnu/libnss_compat-2.15.so
00a9a000-00a9b000 r--p 00006000 08:01 279246 /lib/i386-linux-gnu/libnss_compat-2.15.so
00a9b000-00a9c000 rw-p 00007000 08:01 279246 /lib/i386-linux-gnu/libnss_compat-2.15.so
00a9c000-00ac2000 r-xp 00000000 08:01 261854 /lib/i386-linux-gnu/libexpat.so.1.5.2
00ac2000-00ac3000 ---p 00026000 08:01 261854 /lib/i386-linux-gnu/libexpat.so.1.5.2
00ac3000-00ac5000 r--p 00026000 08:01 261854 /lib/i386-linux-gnu/libexpat.so.1.5.2
00ac5000-00ac6000 rw-p 00028000 08:01 261854 /lib/i386-linux-gnu/libexpat.so.1.5.2
00ad5000-00add000 r-xp 00000000 08:06 1744830652 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libvorbisfile.so.3
00add000-00ade000 rw-p 00007000 08:06 1744830652 /home/user/GNUstep/Applications/Oolite/oolite-deps/lib/libvorbisfile.so.3Aborted

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)
Does that mean anything more to anyone?

Hardwarily, according to Lenovo, the machine contains
- Processor: 1.66 GHz Intel Core Duo T2300E/ Core Solo 1.6 (X60) / L2400 (X60s)
- RAM: up to 2GB DDR2 SDRAM (I've got 3GB, I think.)
- Display: 12.1inch (1024x768 resolution) TFT display
- Graphics: Videochipsets: Intel GMA 950 - integrated graphics chipset
- Sound : Audio Chipset is AD1981HD Intel High Definition Audio (Azalia) compatible One 0.5watt internal speaker (mono)

I'm somewhat surprised that old and presumably well-known hardware like this seems to be causing problems. If it is the sound that is causing the problem.

I admit to knowing nothing about sound technology and caring even less. With significant hearing loss rom a childhood disease, it has never been an important issue for me.
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 270
Joined: Sat Aug 09, 2014 4:16 pm

Re: [Solved] Failed to initialize backend "pulse"

Post by Commander_X » Fri Oct 30, 2015 2:14 pm

RockDoctor wrote:[...]/lib/i386-linux-gnu/[...]
You might be attempting Oolite x86 (32bit) on an x86_64 (64 bit) system (from the looks of the location your system libraries are loading from)? Why don't you try the native x86_64 build instead?

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Sat Oct 31, 2015 9:18 am

You might be attempting Oolite x86 (32bit) on an x86_64 (64 bit) system
From the System information application (there's probably a command line for it, but I can't remember it.)
Release 6.0.1 (toutatis) 32-bit
...
Processor : Genuine Intel® CPU 1400 @ 1.66GHz × 2
But more generally, this is a 2006 to 2008 model laptop. I don't think that 64 bit processors had made it to the laptop market then. The badging doesn't even mention whether it's 32 or 64 bit because that simply wasn't a question. (My first desktop it was a question whether you had a 16 or 32 bit processor and/ or memory bus. And that ran elite just fine. From a 5.25in floppy.)
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by Norby » Sat Oct 31, 2015 9:12 pm

RockDoctor wrote:Graphics: Videochipsets: Intel GMA 950 - integrated graphics chipset
Maybe your videocard or the driver is the source of the problem? Are you tried other 3D games (Supertuxkart, TORCS)?

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 270
Joined: Sat Aug 09, 2014 4:16 pm

Re: [Solved] Failed to initialize backend "pulse"

Post by Commander_X » Sun Nov 01, 2015 3:24 am

RockDoctor wrote:[...](there's probably a command line for it, but I can't remember it.)[...]
I do:

Code: Select all

uname -a
Just a quick heads up, your CPU is obviously capable of running x86_64 (hint: "x 2" at the end of the "Processor" line).

User avatar
RockDoctor
Deadly
Deadly
Posts: 246
Joined: Sat May 01, 2010 9:05 pm
Location: Scotland
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by RockDoctor » Sun Nov 01, 2015 11:44 am

Maybe your videocard or the driver is the source of the problem? Are you tried other 3D games (Supertuxkart, TORCS)?
I've never made any investigations into the graphics system - I do web browsing, email, expenses and alien shooting (Oolite) on it, and it works ; that's good enough for me. Any drivers would be the stock install with Lubuntu.
<P>But again - this is a 2006 to 2008 model laptop. I honestly haven't ever even thought about anything "3d accelerated" and wouldn't know where to start (or for that matter, why to start). I've been trying to use a seismic data analysis suite recently and found that that is struggling seriously (3-8 hours to load a dataset), so I have thought about possibly having to get new hardware for that (the coders try to offload work from the main processor to any graphics card they can find, but if there isn't one, they do the work on the main processor). But again, I wouldn't even know where to start.
<P>Are you saying that the recent re-writes (from about v1.73 to present) have added 3d code, and that may be breaking on older hardware, or trying to drive older hardware to procedures which it can't do?
your CPU is obviously capable of running x86_64 (hint: "x 2" at the end of the "Processor" line).
I'll take your word for it, but that isn't obvious to me. SHRUG. The system details box very explicitly states (and I'm back on the hard drive with the OS as installed by the (re-)manufacturers that it's a "32-bit" OS, so even if the processor is capable of performing 64 bit codes, it's not going to be passed such code by the OS. Is it?
uname -a
Linux user-ThinkPad-X60 3.2.0-92-generic #1trisquel1 SMP Thu Oct 22 18:26:25 UTC 2015 i686 i686 i386 GNU/Linu
Am I going to have to go through the whole accursed rigmarole of trying to find a distro which is 64-bit and which covers my hardware?
--
Shooting aliens for fun and ... well more fun.
"I'm just stepping out of the airlock for a breath of fresh vacuum. I may be gone some time."

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Solved] Failed to initialize backend "pulse"

Post by Norby » Sun Nov 01, 2015 12:56 pm

RockDoctor wrote:Are you saying that the recent re-writes (from about v1.73 to present) have added 3d code, and that may be breaking on older hardware
I am not sure but a -noshaders parameter worth a try.

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 270
Joined: Sat Aug 09, 2014 4:16 pm

Re: [Solved] Failed to initialize backend "pulse"

Post by Commander_X » Sun Nov 01, 2015 5:59 pm

RockDoctor wrote:I'll take your word for it, but that isn't obvious to me.
:oops: Mea culpa: I did some more digging and it turned only Core 2 Duo multicore CPUs were 64 bit ready. (... and the safest way to figure out if your CPU supports x86_64 is to check for the "lm" -- long mode -- flag in the /proc/cpuinfo page). Well, that's it from someone who didn't pay a penny to Intel in a very, very long time. 8)

Post Reply