Oolite Bulletins

For information and discussion about Oolite.
It is currently Wed Nov 22, 2017 1:36 am

All times are UTC




Post new topic  Reply to topic  [ 94 posts ]  Go to page Previous 1 2 3 4 57 Next
Author Message
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 3:58 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 848
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Quote:
Code:
mandoman@mandoman-5800 ~ $ ~/GNUstep/Applications/Oolite/oolite.app/oolite
/home/mandoman/GNUstep/Applications/Oolite/oolite.app/oolite: error while loading shared libraries: libgnustep-base.so.1.20: cannot open shared object file: No such file or directory
mandoman@mandoman-5800 ~ $ 
My bad... :oops: ... the following is the correct one
Code:
$ ~/GNUstep/Applications/Oolite/oolite
As soon as Oolite starts, pres F12 key and proceed with step 4, please.

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 4:10 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
Code:
mandoman@mandoman-5800 ~ $ ~/GNUstep/Applications/Oolite/oolite

It seems that your operating system does not have a valid timezone name
configured and is using an abbreviation instead.  By comparing timezone
file data it is has been possible to find the actual timezone used, but
doing that is a slow process.

You can avoid slowness of this time zone detecting approach
by setting the environment variable TZ='posix/US/Central'
Or You can override the timezone name by setting the 'Local Time Zone'
NSUserDefault via the 'defaults' command line utility, a Preferences
application, or some other utility.
eg "defaults write NSGlobalDomain 'Local Time Zone' 'posix/US/Central'"

bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
Not sure what that's all about, as that was all set up during installation of Linux Mint.

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 4:17 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 848
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Could you post the full Latest.log that resides in ~/.Oolite/Logs folder, please?
In order to keep it short, just execute oolite and exit.

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 4:29 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
Code:
Opening log for Oolite version 1.77.1 (x86-64) under Linux 3.11.0-12-generic at 2014-05-10 11:13:14 -0500.
2 processors detected.
Build options: spoken messages, mass/fuel pricing.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

11:13:15.507 [display.mode.list.native]: X11 native resolution detected: 1280 x 1024
11:13:15.551 [joystick.init]: Number of joysticks detected: 0
11:13:15.552 [rendering.opengl.version]: OpenGL renderer version: 1.4.0 ("1.4 Mesa 9.2.1"). Vendor: "Intel Open Source Technology Center". Renderer: "Mesa DRI Intel(R) G33 ".
11:13:15.552 [rendering.opengl.extensions]: OpenGL extensions (119):
GL_ARB_depth_texture, GL_ARB_invalidate_subdata, GL_ARB_texture_env_add, GL_EXT_pixel_buffer_object, GL_IBM_multimode_draw_arrays, GL_EXT_texture3D, GL_EXT_compiled_vertex_array, GL_ARB_framebuffer_object, GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_texture_cube_map, GL_EXT_rescale_normal, GL_ATI_draw_buffers, GL_ARB_transpose_matrix, GL_ARB_half_float_pixel, GL_EXT_stencil_two_side, GL_ARB_texture_border_clamp, GL_ARB_multisample, GL_ATI_separate_stencil, GL_ARB_texture_non_power_of_two, GL_INGR_blend_func_separate, GL_EXT_bgra, GL_ARB_sync, GL_EXT_texture_env_dot3, GL_EXT_provoking_vertex, GL_APPLE_packed_pixels, GL_NV_light_max_exponent, GL_ARB_sampler_objects, GL_SUN_multi_draw_arrays, GL_ARB_map_buffer_range, GL_ARB_vertex_shader, GL_ARB_shader_objects, GL_NV_texgen_reflection, GL_EXT_multi_draw_arrays, GL_ARB_vertex_program, GL_IBM_rasterpos_clip, GL_EXT_texture_object, GL_ARB_get_program_binary, GL_ATI_texture_env_combine3, GL_NV_texture_env_combine4, GL_EXT_stencil_wrap, GL_EXT_framebuffer_blit, GL_MESA_pack_invert, GL_NV_packed_depth_stencil, GL_ARB_texture_compression, GL_ARB_vertex_array_object, GL_EXT_blend_color, GL_EXT_blend_minmax, GL_APPLE_vertex_array_object, GL_EXT_subtexture, GL_ARB_debug_output, GL_ARB_point_sprite, GL_EXT_vertex_array, GL_EXT_abgr, GL_ARB_vertex_buffer_object, GL_NV_blend_square, GL_NV_texture_rectangle, GL_ARB_multitexture, GL_EXT_texture, GL_ARB_copy_buffer, GL_ARB_draw_elements_base_vertex, GL_APPLE_object_purgeable, GL_ARB_shadow, GL_EXT_blend_subtract, GL_EXT_separate_shader_objects, GL_ARB_internalformat_query, GL_MESA_window_pos, GL_ARB_texture_storage, GL_ARB_window_pos, GL_EXT_texture_lod_bias, GL_IBM_texture_mirrored_repeat, GL_ARB_texture_env_crossbar, GL_ARB_point_parameters, GL_EXT_texture_sRGB_decode, GL_ARB_robustness, GL_EXT_texture_edge_clamp, GL_EXT_copy_texture, GL_ANGLE_texture_compression_dxt3, GL_EXT_texture_sRGB, GL_EXT_texture_compression_dxt1, GL_MESA_ycbcr_texture, GL_ARB_texture_env_combine, GL_ANGLE_texture_compression_dxt5, GL_ARB_fragment_program, GL_ARB_explicit_attrib_location, GL_EXT_texture_filter_anisotropic, GL_EXT_draw_range_elements, GL_ARB_pixel_buffer_object, GL_EXT_packed_depth_stencil, GL_ARB_texture_rectangle, GL_EXT_fog_coord, GL_ARB_ES2_compatibility, GL_SGIS_texture_lod, GL_3DFX_texture_compression_FXT1, GL_EXT_gpu_program_parameters, GL_ARB_fragment_shader, GL_OES_EGL_image, GL_EXT_polygon_offset, GL_ARB_shading_language_100, GL_SGIS_texture_border_clamp, GL_EXT_secondary_color, GL_EXT_point_parameters, GL_ARB_draw_buffers, GL_SGIS_generate_mipmap, GL_EXT_texture_rectangle, GL_ATI_blend_equation_separate, GL_OES_read_format, GL_EXT_blend_func_separate, GL_ARB_texture_cube_map, GL_S3_s3tc, GL_EXT_framebuffer_object, GL_EXT_packed_pixels, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_env_dot3, GL_ARB_provoking_vertex, GL_EXT_blend_equation_separate, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_SGIS_texture_edge_clamp
11:13:15.561 [rendering.opengl.shader.support]: Shaders are supported.
11:13:15.754 [searchPaths.dumpAll]: Strict mode - resource path:
    ~/GNUstep/Applications/Oolite/oolite.app/Resources
11:13:15.843 [shipData.load.begin]: Loading ship data.
11:13:15.980 [script.javascript.init]: JavaScript reset successful.
11:13:16.003 [script.load.world.listAll]: Loaded 9 world scripts:
    oolite-cloaking-device 1.77.1
    oolite-constrictor-hunt 1.77.1
    oolite-contracts-cargo 1.77.1
    oolite-contracts-helpers 1.77.1
    oolite-contracts-parcels 1.77.1
    oolite-contracts-passengers 1.77.1
    oolite-nova 1.77.1
    oolite-thargoid-plans 1.77.1
    oolite-trumbles 1.77.1
11:13:16.650 [startup.complete]: ========== Loading complete in 1.19 seconds. ==========
11:13:50.605 [exit.context]: Exiting: Shift-escape pressed.
11:13:50.606 [gameController.exitApp]: .GNUstepDefaults synchronized.

Closing log at 2014-05-10 11:13:50 -0500.

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 5:21 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 848
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Would you go for setting up the nvidia proprietary driver? Read here...
While pondering this option, please, post the result of the following
Code:
$ lspci -vnn | grep VGA -A 12

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 7:40 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
Does that come with the NVidea X Server, by any chance? I got that out of Package Installer just to check it out, but haven't done anything with it yet.
Code:
lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard [1043:82b0]
	Flags: bus master, fast devsel, latency 0, IRQ 42
	Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at dc00 [size=8]
	Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915

00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 01)
	Subsystem: ASUSTeK Computer Inc. P5KPL-CM Motherboard [1043:82ea]

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 8:24 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Apr 07, 2012 7:35 pm
Posts: 1132
Location: US
I use Mint 13 with MATE desktop, so it might be slightly different from your setup. Go to System -> Preferences -> Additional Drivers. That will take you to a window that should bring up your Nvidia card. Install the driver, and reboot. If you're still having problems, then I'd use the driver from the Nvidia website. (After removing the old driver, of course).

Edit: Actually pressing Alt+F2 and typing 'jockey-gtk' should be even easier way to get to "Additional Drivers".

_________________
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 8:28 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Apr 07, 2012 7:35 pm
Posts: 1132
Location: US
Quote:
Basically, package installations on Linux, whether via apt, Synaptic, Software Centre or even RPM, can scatter numerous files in various places across the system, unlike, for example, Macs, where all the files for a package are generally kept in one place. I've seen Mac users describe the Linux method as a "shotgun install"..

That's why it's important to use the same package installation system to uninstall anything that was installed by it in the first place.. it keeps a record of all the files, and where they're located, so that nothing gets left behind.
:lol: "shotgun" install - that's exactly right.

_________________
"I'll laser the mark all while munching a fistful of popcorn." - Markgräf von Ededleen, Marquess, Brutal Great One, Assassins' Guild Exterminator
---------------------------
At the helm of the Caduceus Omega, 'Murderous Morrígan'


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 8:55 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
Quote:
I use Mint 13 with MATE desktop, so it might be slightly different from your setup. Go to System -> Preferences -> Additional Drivers. That will take you to a window that should bring up your Nvidia card. Install the driver, and reboot. If you're still having problems, then I'd use the driver from the Nvidia website. (After removing the old driver, of course).

Edit: Actually pressing Alt+F2 and typing 'jockey-gtk' should be even easier way to get to "Additional Drivers".
Well, I would do that, but I don't have the GeForce card in the machine anymore. If Windows wouldn't use it, Mint Couldn't use it. I simply could not even get the Linux drive to boot, if the NVidea driver didn't work on XP. It's been that way since I got the machine. I all ran smooth, as long as XP could use the card correctly, but since the whole thing crashed, and I had to reload (the XP dive, that is), I haven't been able to use the GeForce card.

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sat May 10, 2014 9:05 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
Quote:
Basically, package installations on Linux, whether via apt, Synaptic, Software Centre or even RPM, can scatter numerous files in various places across the system, unlike, for example, Macs, where all the files for a package are generally kept in one place. I've seen Mac users describe the Linux method as a "shotgun install"..
I suppose, but then again, Mac users have to pay up the butt for just about any software they use, unless they turn to the Linux software. :P

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sun May 11, 2014 9:54 am 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 848
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Quote:
Does that come with the NVidea X Server, by any chance? I got that out of Package Installer just to check it out, but haven't done anything with it yet.
Code:
lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10) 	
...
Kernel driver in use: i915
...
I think i got confused. You don't have the nVidia card physically installed yet, right?
In that case, no need to mess with the nVidia drivers yet.

Are you running in strict mode?
If you resize the window (F12 for windowed mode) do you see performance improvement?
Can you try running in full-screen non-strict mode and reduce the graphics details from Oolite options menu?

Does any of these changes reduce the "jerkiness"? :?

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sun May 11, 2014 10:33 am 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Fri Nov 11, 2011 6:19 pm
Posts: 4015
Quote:
Code:
11:13:15.552 [rendering.opengl.version]: OpenGL renderer version: 1.4.0 ("1.4 Mesa 9.2.1"). Vendor: "Intel Open Source Technology Center". Renderer: "Mesa DRI Intel(R) G33 
[...]
GL_ARB_shading_language_100, 
[...]
11:13:15.561 [rendering.opengl.shader.support]: Shaders are supported.
This might be the problem - the driver is claiming shader support, but the card as a whole only supports OpenGL 1.4, so it probably doesn't provide very quick shader support. It wouldn't be the first old on-board card we've seen to support shaders but do so badly enough that it would be better if it didn't. If that's it, switching the graphics settings to non-shader mode will probably solve the problem.

_________________
OXPs: [EliteWiki] New Cargoes, [EliteWiki] Skilled NPCs, [EliteWiki] Curse of the Black Sunspot, and more


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sun May 11, 2014 2:37 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon Apr 06, 2009 12:20 pm
Posts: 6241
Location: Aboard the Pitviper S.E. "Blackwidow"
Quote:
I don't have the GeForce card in the machine anymore. If Windows wouldn't use it, Mint Couldn't use it. I simply could not even get the Linux drive to boot, if the NVidea driver didn't work on XP. It's been that way since I got the machine. I all ran smooth, as long as XP could use the card correctly, but since the whole thing crashed, and I had to reload (the XP dive, that is), I haven't been able to use the GeForce card.
This, to me, makes no sense at all.. XP and it's drivers are totally irrelevant to Linux. Not a factor at all. The only way I could see this happening was if something during the crash (or an XP driver update) had bricked the GeForce card.

Mandoman, do you have access to any other computers you could test the GeForce card with?

_________________
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sun May 11, 2014 2:56 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon Apr 06, 2009 12:20 pm
Posts: 6241
Location: Aboard the Pitviper S.E. "Blackwidow"
Intel's Graphics Drivers for Linux may be worth considering, also.. your on-board Graphics chip is supported.

_________________
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied


Top
   
 Post subject: Re: Sound Absent
PostPosted: Sun May 11, 2014 3:05 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Thu Apr 28, 2011 3:17 pm
Posts: 1368
I think Diziet Sma has it nailed. I've thought as much myself, I just don't know how to prove it. A lot of suggestions here for me to try, and I'll get right on them. Thanks all, and I'll be back with the results. :)

_________________
Mandotech Industries Wiki Page.

http://wiki.alioth.net/index.php/User:Mandoman


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 94 posts ]  Go to page Previous 1 2 3 4 57 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited