Oolite Bulletins

For information and discussion about Oolite.
It is currently Wed Jul 26, 2017 12:38 pm

All times are UTC




Post new topic  Reply to topic  [ 33 posts ]  Go to page 1 2 3 Next
Author Message
 Post subject: Noob Question
PostPosted: Sun May 17, 2015 9:55 pm 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
For some reason I can not read any of the text in the game. The text appears blurred at all resolutions.


Top
   
 Post subject: Re: Noob Question
PostPosted: Sun May 17, 2015 10:18 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12665
Location: Corke's Drift
Welcome - just so as we know, which version of Oolite and which OS are you running?

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Noob Question
PostPosted: Sun May 17, 2015 10:24 pm 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
1.8
windows 7 64 bit


Top
   
 Post subject: Re: Noob Question
PostPosted: Sun May 17, 2015 10:28 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12665
Location: Corke's Drift
Thanks - and could you also post the Latest.log (found in ~\Oolite\oolite.app\Logs). It might give a clue for the boffins.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Noob Question
PostPosted: Sun May 17, 2015 10:32 pm 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
Opening log for Oolite version 1.80 (x86-64) under Windows 6.1.7601 Service Pack 1 64-bit at 2015-05-17 14:19:42 -0700.
4 processors detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

14:19:42.748 [dataCache.notFound]: No data cache found, starting from scratch.
14:19:44.731 [display.mode.list.native]: Windows native resolution detected: 1920 x 1080
14:19:49.624 [joystick.init]: Number of joysticks detected: 0
14:19:49.625 [rendering.opengl.version]: OpenGL renderer version: 3.1.0 ("3.1.0 - Build 8.15.10.2476"). Vendor: "Intel". Renderer: "Intel(R) HD Graphics Family".
14:19:49.625 [rendering.opengl.extensions]: OpenGL extensions (103):
GL_NV_primitive_restart, GL_ARB_texture_env_crossbar, GL_EXT_abgr, GL_ARB_shadow, GL_IBM_texture_mirrored_repeat, GL_EXT_separate_specular_color, GL_EXT_texture_edge_clamp, GL_EXT_blend_minmax, GL_EXT_draw_buffers2, GL_ARB_texture_env_add, GL_ARB_draw_elements_base_vertex, GL_ARB_sampler_objects, GL_EXT_framebuffer_blit, GL_EXT_transform_feedback, GL_ARB_texture_env_dot3, GL_EXT_framebuffer_object, GL_EXT_blend_subtract, GL_3DFX_texture_compression_FXT1, GL_NV_conditional_render, GL_ARB_vertex_array_bgra, GL_EXT_texture_snorm, GL_ARB_multitexture, GL_EXT_stencil_wrap, GL_ARB_texture_border_clamp, GL_ARB_framebuffer_sRGB, GL_ARB_texture_env_combine, GL_EXT_framebuffer_multisample, GL_EXT_texture_env_add, GL_EXT_packed_pixels, GL_SGIS_texture_edge_clamp, GL_ARB_depth_clamp, GL_INTEL_performance_queries, GL_ARB_uniform_buffer_object, GL_ARB_depth_texture, GL_SGIS_texture_lod, GL_ARB_occlusion_query, GL_ARB_transpose_matrix, GL_NV_texgen_reflection, GL_EXT_stencil_two_side, GL_ARB_seamless_cube_map, GL_ARB_fragment_program_shadow, GL_ARB_shading_language_100, GL_ARB_texture_compression_rgtc, GL_EXT_gpu_program_parameters, GL_EXT_texture_shared_exponent, GL_EXT_rescale_normal, GL_ARB_map_buffer_range, GL_ARB_pixel_buffer_object, GL_EXT_secondary_color, GL_ARB_copy_buffer, GL_ARB_half_float_pixel, GL_EXT_blend_equation_separate, GL_EXT_draw_range_elements, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_ARB_half_float_vertex, GL_EXT_texture_swizzle, GL_SGIS_generate_mipmap, GL_ARB_texture_rectangle, GL_ARB_texture_non_power_of_two, GL_ARB_point_sprite, GL_EXT_packed_depth_stencil, GL_ARB_vertex_shader, GL_EXT_texture_compression_s3tc, GL_EXT_texture_integer, GL_ARB_depth_buffer_float, GL_ARB_sync, GL_ARB_draw_instanced, GL_ARB_vertex_buffer_object, GL_WIN_swap_hint, GL_ARB_color_buffer_float, GL_ARB_shader_objects, GL_EXT_texture_array, GL_ATI_separate_stencil, GL_ARB_framebuffer_object, GL_EXT_packed_float, GL_ARB_compatibility, GL_EXT_texture_rectangle, GL_ARB_texture_rg, GL_ARB_fragment_shader, GL_EXT_fog_coord, GL_EXT_texture3D, GL_ARB_window_pos, GL_ARB_fragment_program, GL_ARB_vertex_program, GL_EXT_texture_env_combine, GL_ARB_point_parameters, GL_ARB_texture_cube_map, GL_EXT_bgra, GL_EXT_compiled_vertex_array, GL_ARB_multisample, GL_ARB_vertex_array_object, GL_ARB_draw_buffers, GL_ARB_texture_compression, GL_EXT_multi_draw_arrays, GL_ARB_fragment_coord_conventions, GL_ARB_texture_float, GL_EXT_blend_func_separate, GL_EXT_texture_sRGB, GL_EXT_shadow_funcs, GL_EXT_clip_volume_hint, GL_EXT_blend_color, GL_NV_blend_square
14:19:49.716 [rendering.opengl.shader.support]: Shaders are supported.
14:19:49.716 [dataCache.notFound]: No data cache found, starting from scratch.
14:19:49.717 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
Resources
../AddOns
14:19:52.165 [shipData.load.begin]: Loading ship data.
14:20:01.489 [startup.complete]: ========== Loading complete in 18.74 seconds. ==========
14:20:12.746 [gnustep]: 2015-05-17 14:20:12.746 oolite[14440] Defaults path 'C:\Oolite/oolite.app/GNUstep/Defaults' did not exist - created it

14:20:12.747 [gnustep]: 2015-05-17 14:20:12.747 oolite[14440] Creating empty user defaults database

15:03:34.284 [exit.context]: Exiting: SDL_QUIT event received.
15:03:34.284 [gameController.exitApp]: .GNUstepDefaults synchronized.

Closing log at 2015-05-17 15:03:34 -0700.


Top
   
 Post subject: Re: Noob Question
PostPosted: Sun May 17, 2015 11:24 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon May 20, 2013 9:53 pm
Posts: 2310
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Welcome in the Oolite galaxy! :)
Quote:
The text appears blurred at all resolutions.
Could you make some screenshots (press * in the game then check oolite-saves/snapshots/oolite-001.png), upload (for example to postimage.org) and insert the direct link between [img]...[/img], please?

_________________
OXPs by Norby


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 12:08 am 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
Image


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 12:31 am 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12665
Location: Corke's Drift
Hmm, not just the text - it isn't rendering the ship properly either. <scratches head>

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 2:56 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Mar 28, 2015 11:14 pm
Posts: 355
Hmm! The model for the ship looks intact but there's no texture wrapped around it! The oolite fonts are also stored in the Resources --> Textures folders as well. Maestro (or Madame, whichever is the case) Flameaway, is your textures folder perhaps moved/missing? It would be along the file path Oolite--> Oolite.app--> Resources-->Textures. It should be full of many juicy and brightly-hued textures of many sorts including an oolite-font.png. Are they present and accounted for?

Ah, and welcome, as well, yes, indeedy do. *tips hat*

_________________
Reports of my death have been greatly underestimated.


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 3:18 am 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
There is a font png. There are 153 total items in the Textures folder.


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 3:32 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Mar 28, 2015 11:14 pm
Posts: 355
"Curiouser and curiouser!" Cried Alice (she was so much surprised, that for the moment she quite forgot how to speak good English).

Hmm! Have you advanced past the starting screen and seen how the game is rendering the rest of the graphics? If so, are you able to see stars, planets, stations, other ships with textures? Or does everything else look grey and featureless like the Cobra III on the startup screen?

_________________
Reports of my death have been greatly underestimated.


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 5:55 am 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Fri Nov 11, 2011 6:19 pm
Posts: 4007
Quote:
Hmm! The model for the ship looks intact but there's no texture wrapped around it!
It looks textured - there are some definite light and dark patches, and it's not pure white.

I suspect that the graphics driver is reporting a really low maximum texture size somewhere, so all the textures are being downscaled a lot. If you look at the text in the options list, you can see hollow boxes about where the spaces would be, and on the ends of the lines.

The default size if the graphics driver doesn't report a value for GL_MAX_TEXTURE_SIZE is 64 pixels, which would give this sort of effect.

flameaway: could you try updating your graphics drivers? What sort of graphics card do you have - the log says an Intel one, but not which sort.

_________________
OXPs: [EliteWiki] New Cargoes, [EliteWiki] Skilled NPCs, [EliteWiki] Curse of the Black Sunspot, and more


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 12:19 pm 
Online
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 4883
The maximum texture size can also be set from the preferences file. You can try opening oolite.app\GNUstep\Defaults\.GNUstepDefaults in a text editor (other than Notepad) and add this line before the last closing brace:
Code:
"max-texture-size" = 4096;
You can experiment with the actual value, but if the game sets maximum texture size to 64, you may want to try to force it to higher and that maybe can make things work better.


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 2:01 pm 
Offline
Average
Average

Joined: Sun May 17, 2015 9:48 pm
Posts: 8
I set max texture. Did not work. I updated the drivers, did not work. Thanks to you all.
:)


Top
   
 Post subject: Re: Noob Question
PostPosted: Mon May 18, 2015 2:11 pm 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 804
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
@flameaway
Is this a "fresh" 1.80 installation from scratch (no previous C:\Oolite folder existed before this installation) or an upgrade from previous version?

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Last edited by Getafix on Mon May 18, 2015 2:13 pm, edited 1 time in total.

Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 33 posts ]  Go to page 1 2 3 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited