Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Nov 20, 2017 9:08 pm

All times are UTC




Post new topic  Reply to topic  [ 64 posts ]  Go to page 1 2 3 4 5 Next
Author Message
PostPosted: Wed Oct 09, 2013 7:36 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5015
The thing I like most about community-driven projects is that the resources for testing new project features are virtually endless and correspond to the size of the communities themselves. Therefore, I'd like to take this opportunity and request from the Windows user base of Oolite to become testers (see disclaimer though) for what will hopefully be the next generation of Oolite for Windows: the long-awaited native 64-bit version of the game.

The link to the tentative 64-bit Windows port of Oolite is https://drive.google.com/file/d/0BwG6R5 ... sp=sharing . It corresponds to the 1.77.1 version of the game. To use it, just drop oolite_x64.app inside the root folder of your 1.77.1 installation, at the same folder level as the standard 32-bit oolite.app. Then run any of the included executables. There are versions for both Deployment and Test Release builds inside oolite_x64.app.

What you should know about this build:
- Disclaimer: There are absolutely no guarantees of good functionality on this one. If you are afraid that it may fry your PC, do not use it.
- In case you do decide to use it, be aware that it is not officially supported for gameplay. If it runs well for you, feel free to continue running it and I urge you to report any problem you discover about it; but do not expect immediate responses and solutions to any of the issues that might be reported. Remember, this version of the game is fully experimental and is published for testing purposes only.
- There is a known issue of occasional crashes on exit. Additionally, your stderr.txt will most likely always contain this line at the end of execution:
WARNING thread 0000000000000000 terminated without calling +exit!
You do not need to report this one, but please DO report if you do NOT get the above message in stderr.txt when you exit the game. We are currently troubleshooting and attempting to fix the issue.
- This is now fixed. Download link updated.
- This build is optimized for SSE2. If your computer is 64-bit capable, then it is probably safe to assume that it supports the SSE2 instruction set as well.
- The entire package, i.e. the Oolite executable itself, as well as all of the supporting shared libraries, have been re-compiled from scratch for 64-bit processors. Dependency Walker reports it as a full 64-bit binary. Same goes for Windows Task Manager. There should be no 32-bit dependencies left whatsoever.
- If you have found an issue you would like to report, please include in your report the version of Windows you are running, plus system memory, processor and GPU information. If you would like to just report that it works fine for you, I kindly ask that you include the same information regardless. So far, we know that this package works well (apart from the aforementioned occasional crash upon exit) on Windows 7 64-bit Enterprise, Intel M640 Corei7 @ 2.80GHz, with 4GB of memory and an Intel HD Graphics system, which is the system I am running it on.

Thank you all in advance for helping out in the development of the game and looking forward to your reports, hopefully of good functionality ;-).

Edit 15 Oct 2013: Updated package to version 0.2, containing the correct version of gnustep-base-1_20.dll, which fixes the thread crash on exit.
Edit: 29 Oct 2013: Updated package to version 0.3, containing a full rebuild of the game, this time using an exception model that hopefully does not crash.


Top
   
PostPosted: Wed Oct 09, 2013 8:01 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12918
Location: Corke's Drift
Both builds have been running fine on my system: Win 7 Ultimate x64; i5 760 @2.8; 8GB RAM; nVidia GTX 550Ti 1GB (cranked-up).
Note that each .exe will happily use the AddOns folder of the root installation, but you'll need to copy save-games over into both builds.

_________________
The only good fnord is a dead fnord!


Top
   
PostPosted: Wed Oct 09, 2013 8:22 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Tue Sep 01, 2009 11:55 pm
Posts: 677
Location: in maZe
Quick test on my work laptop looks good (deployment .exe).
Machine specs:
Intel Core i7-2630QM @ 2.0 GHz
16 GB RAM
NVidia Quadro 1000M
Win 7 pro SP1 64bit

_________________
...and keep it under lightspeed!

Friendliest Meteor Police that side of Riedquat

[EliteWiki] Far Arm ships
[EliteWiki] Z-ships
[EliteWiki] Baakili Far Trader
[EliteWiki] Tin of SPAM


Top
   
PostPosted: Wed Oct 09, 2013 8:26 pm 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Sat Dec 31, 2011 2:58 pm
Posts: 483
It's working fine on my Windows 8, 64bit Lap top

i5 processor , 8 GB Ram.

_________________
Flying Python Class Cruiser, Chapter & Verse IV


Top
   
PostPosted: Wed Oct 09, 2013 8:52 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Aug 29, 2006 5:02 pm
Posts: 2073
Location: Norway
Works fine on my Laptop.

HP EliteBook 8560W
Windows 7 64bit Ultimate
Intel Core i7-2670QM 2.20 GHz
12GB RAM
nVidia Quadro 1000M 1GB

I did get the expected error on exit.
Windows generated a set of error files that it wanted to send to Microsoft. I kept a copy, but I expect that you have all you need.

_________________
"A brilliant game of blasting and trading... Truly a mega-game... The game of a lifetime."
(Gold Medal Award, Zzap!64 May 1985).
Also, my tiny contribution to the Ooniverse


Top
   
PostPosted: Wed Oct 09, 2013 9:26 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Aug 29, 2006 5:02 pm
Posts: 2073
Location: Norway
Have now tested some more. Both "oolite.exe" and "ooliteDeployment.exe" seem to work fine, but the behaviour on exit is slightly different.
With "oolite.exe" Windows gives me a warning the Oolite.exe has stopped and then generates the error message in stderr.txt and the error message files for sending to microsoft.
With "ooliteDeployment.exe" Oolite just exits with the same error message in stderr.txt but no warning from Windows.

Not sure if this is relevant.

_________________
"A brilliant game of blasting and trading... Truly a mega-game... The game of a lifetime."
(Gold Medal Award, Zzap!64 May 1985).
Also, my tiny contribution to the Ooniverse


Last edited by Gimi on Thu Oct 10, 2013 1:21 pm, edited 1 time in total.

Top
   
PostPosted: Thu Oct 10, 2013 1:23 am 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Sat Sep 12, 2009 11:58 pm
Posts: 989
Location: Essex (mainly industrial and occasionally anarchic)
I've just tried it (well, the deployment version), briefly. All seemed good and the latest.log looked clean. Speed seemed good, too. Great! I did, as expected, get the error message in stderr.txt.

My setup:
  • Windows 8, 64-bit version [Edit: Pro edition, with Media Centre']

    System memory: 4 GB (but only 3.24 usable, despite having 64-bit Windows - it's a chipset limitation, that I get round, sort of, via a ramdisk that can access the hidden RAM)

    Processor: Intel Core 2 Quad QG700, 2.66 Ghz (but running at 2705).

    GPU: ATI HD 5570 (overclocked) [Edit: and with 1GB RAM].


Last edited by UK_Eliter on Thu Oct 10, 2013 1:19 pm, edited 1 time in total.

Top
   
PostPosted: Thu Oct 10, 2013 1:04 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Tue Sep 22, 2009 11:07 am
Posts: 2988
Location: Enfield, Middlesex
I'm also been trying it out. No crashes, all seemed to work.

I checked my latest log, there's a few errors/warnings I'm not used to seeing. Don't know if they are related to the 64-bit version or OXP problems.
Code:
Opening log for Oolite version 1.77.1 (x86-64 test release) under Windows 6.1.7601 Service Pack 1 64-bit at 2013-10-10 13:20:19 +0100.
8 processors detected.
Woooh! 8)
Code:
13:22:32.342 [script.javaScript.exception.unexpectedType]: ***** JavaScript exception (zygo_traffic 0.1a): TypeError: group is undefined
...cut...
13:24:17.619 [script.javaScript.exception.unexpectedType]: ***** JavaScript exception (stations_for_extra_planets_populator 1.3): TypeError: system.addShips(stations[stationInd], 1, planets[i].position.add(planetToStation)) is null
...cut...
13:26:03.254 [script.javaScript.exception.unexpectedType]: ***** JavaScript exception (stations_for_extra_planets_populator 1.3): TypeError: system.addShips(stations[stationInd], 1, planets[i].position.add(planetToStation)) is null
13:32:22.569 [script.javaScript.exception.ooliteDefined]: ***** JavaScript exception (militarytargettingsystem 1.0): Error: Cannot set property scannerDisplayColor1 of instance of Ship to invalid value undefined.
13:33:07.680 [script.javaScript.exception.ooliteDefined]: ***** JavaScript exception (militarytargettingsystem 1.0): Error: Cannot set property scannerDisplayColor1 of instance of Ship to invalid value undefined.
...cut...
13:38:20.895 [script.javaScript.exception.notFunction]: ***** JavaScript exception (<unidentified script>): TypeError: entity.hasRole is not a function
13:39:10.555 [script.javaScript.exception.ooliteDefined]: ***** JavaScript exception (militarytargettingsystem 1.0): Error: Cannot set property scannerDisplayColor1 of instance of Ship to invalid value undefined.
13:40:00.349 [script.javaScript.exception.ooliteDefined]: ***** JavaScript exception (militarytargettingsystem 1.0): Error: Cannot set property scannerDisplayColor1 of instance of Ship to invalid value undefined.
13:50:02.734 [exit.context]: Exiting: Exit Game selected on options screen.
13:50:02.773 [gameController.exitApp]: .GNUstepDefaults synchronized.

Closing log at 2013-10-10 13:50:02 +0100.
And as you can see from the log, I exited normally via options. And still got the WARNING thread 0000000000000000 terminated without calling +exit! error in STDERR.txt.


Top
   
PostPosted: Thu Oct 10, 2013 3:29 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon Nov 17, 2008 4:15 pm
Posts: 406
Location: Blighty
Works fine here although haven't taken for more than a spin so far..
Windows 8 x64
Intel Core 2 E8500 3.16 ghz
4 gig RAM (3.25 not claimed by the operating system)
nVidia 630 1gig
Ancient aBit i 45CV motherboard that may well be holding things back

_________________
My OXP attempts available@ http://www.aegidian.org/bb/viewtopic.php?t=8541


Top
   
PostPosted: Fri Oct 11, 2013 10:56 am 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5015
Thanks to all who have provided feedback so far. From the info gathered, we have established that the behaviour of the game is similar and without general surprises on both Win 7 and Win 8 (regarding the JS exceptions in the log from JazHaz, for now I tend to believe that they are OXP related as I've tested the properties reported as undefined using Debug Console and they seem to work there). It looks like we are missing information about what happens on Win XP 64 and Vista 64-bit systems though. The help of anyone with access to these OSs and ability to test would be greatly appreciated.


Top
   
PostPosted: Fri Oct 11, 2013 11:00 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Tue Sep 22, 2009 11:07 am
Posts: 2988
Location: Enfield, Middlesex
I don't think there will be many people running XP 64-bit or Vista 64-bit.


Top
   
PostPosted: Fri Oct 11, 2013 12:00 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12918
Location: Corke's Drift
I have painful memeories of XP 64-bit - I doubt many people are using it. Vista 64-bit? No idea.

_________________
The only good fnord is a dead fnord!


Top
   
PostPosted: Sat Oct 12, 2013 2:50 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5510
I can add another Win7-64 bit thumbs up. Got the stderr.txt as already noted, but aside from that the only thing relevant is:

Code:
15:30:33.633 [script.load.notFound]: ***** ERROR: Could not find script file oolite-missile.js.
But that may I think be cross-pollution to my git trunk install (which contains both 1.77.1 versions too). The 1.77.1 log also has the error in it.

Except that, all is smooth for me. Sorry can't help on XP or Vista.[/color]

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
PostPosted: Sat Oct 12, 2013 4:37 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5015
Guys, I think it's sorted. All of you who have tested, please download the updated gnustep-base-1_20.dll and replace the one in your 64-bit installation with this. On my system I am now getting normal exit without crashes. Linky: https://docs.google.com/file/d/0BwG6R5Q ... sp=sharing

If this is confirmed, I think we've just hit a milestone. FWIW, I have built 64-bit trunk and it rocks so hard you can almost hear the twanging guitars in the background. ;-)


Top
   
PostPosted: Sat Oct 12, 2013 5:00 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12918
Location: Corke's Drift
That seems to work fine here too, normal exits via shift-q and F2 (with both builds) - cool!

_________________
The only good fnord is a dead fnord!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 64 posts ]  Go to page 1 2 3 4 5 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited