Galactic Navy Strikes Back

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: another_commander, winston

User avatar
Fatleaf
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 1988
Joined: Tue Jun 08, 2010 5:11 am
Location: In analysis mode on Phaelon
Contact:

Re: Galactic Navy Strikes Back

Post by Fatleaf »

Errm :oops:

"This isn't the post you are looking for" :roll:
Find out about the early influences of Fatleaf here. Also his OXP's!
Holds the Ooniversal record for "Thread Necromancy"

User avatar
Fatleaf
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 1988
Joined: Tue Jun 08, 2010 5:11 am
Location: In analysis mode on Phaelon
Contact:

Re: Galactic Navy Strikes Back

Post by Fatleaf »

This oxp still has,
<key>missile_launch_position</key>
<string>0.0 0.0 -20.5</string>

And it brings up errors in the log. Is there any chance of updating it to correct this issue?
Find out about the early influences of Fatleaf here. Also his OXP's!
Holds the Ooniversal record for "Thread Necromancy"

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Galactic Navy Strikes Back

Post by Eric Walch »

Fatleaf wrote:And it brings up errors in the log. Is there any chance of updating it to correct this issue?
Nemoricus has not been around since 1.75 was launched. I think I now included the corrected shipdata.plist now in the current patch file that is on the wiki Galnavy page.
We have to just wait until both corrected files from the patch are included in the main oxp and are hosted by someone.

User avatar
Fatleaf
Intergalactic Spam Assassin
Intergalactic Spam Assassin
Posts: 1988
Joined: Tue Jun 08, 2010 5:11 am
Location: In analysis mode on Phaelon
Contact:

Re: Galactic Navy Strikes Back

Post by Fatleaf »

Eric Walch wrote:I think I now included the corrected shipdata.plist now in the current patch file that is on the wiki Galnavy page.
I just checked, the patch file contains a galnavymain.js file and a navysweeperAI.plist file but no shipdata.plist. So it still gives errors.
Find out about the early influences of Fatleaf here. Also his OXP's!
Holds the Ooniversal record for "Thread Necromancy"

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Galactic Navy Strikes Back

Post by Eric Walch »

Fatleaf wrote:I just checked, the patch file contains a galnavymain.js file and a navysweeperAI.plist file but no shipdata.plist. So it still gives errors.
I now included my fixed shipData.plist in the patch and uploaded it. I probably forgot that file in the patch because I fixed my version long before 1.75 was released.

User avatar
sdrubble
Deadly
Deadly
Posts: 231
Joined: Fri Aug 05, 2011 8:30 am
Location: Belo Horizonte, Brazil

Re: Galactic Navy Strikes Back

Post by sdrubble »

Hi folks,

I've just made this post at the ADCK Behemoths thread. As it seemingly deals with missing dependencies within GN itself, I thought it would be a good idea to leave a pointer in this thread also.

Cheers :mrgreen:

User avatar
Nemoricus
---- E L I T E ----
---- E L I T E ----
Posts: 388
Joined: Mon May 18, 2009 8:51 pm

Re: Galactic Navy Strikes Back

Post by Nemoricus »

*returns from unknown regions of space, the hull of his Cobra Mk III badly scorched and dented*

My apologies, pilots and commanders of the Galactic Navy. A misjump left me stranded for a significant period of time, and it's only recently that I was able to return to the friendliest board this side of Riedquat.

However, in the time I've been back, I've looked over the messages that were posted in my absence, and have incorporated fixes for the problems that have been spotted.

In my first post of this topic, you will find a link to the most recent version of Galactic Navy's software. Eric_Walch's fixes have been included, and it should now run without trouble in 1.75.

I've not been able to update the links in the wiki, I fear, for I have either forgotten the password to my account or never had one at all. If a pilot would do this on behalf of the Navy, their assistance would be greatly appreciated.
Dream as if you'll live forever
Live as if you'll die tomorrow

User avatar
JazHaz
---- E L I T E ----
---- E L I T E ----
Posts: 2991
Joined: Tue Sep 22, 2009 11:07 am
Location: Enfield, Middlesex
Contact:

Re: Galactic Navy Strikes Back

Post by JazHaz »

Nemoricus wrote:*returns from unknown regions of space, the hull of his Cobra Mk III badly scorched and dented*

My apologies, pilots and commanders of the Galactic Navy. A misjump left me stranded for a significant period of time, and it's only recently that I was able to return to the friendliest board this side of Riedquat.

In my first post of this topic, you will find a link to the most recent version of Galactic Navy's software. Eric_Walch's fixes have been included, and it should now run without trouble in 1.75.
Welcome back Nem!

The only problem I think that's outstanding is the lack of Behemoths, due to 1.75 compatibility issues with the two main Behemoth OXPs (the original and ADCK's). I think that GalNavy requires Behemoths??
Nemoricus wrote:I've not been able to update the links in the wiki, I fear, for I have either forgotten the password to my account or never had one at all. If a pilot would do this on behalf of the Navy, their assistance would be greatly appreciated.
My wiki password is inaccessible on my broken laptop, so apologies, I cannot get on either.
JazHaz

Gimi wrote:
drew wrote:£4,500 though! :shock: <Faints>
Cheers,
Drew.
Maybe you could start a Kickstarter Campaign to found your £4500 pledge. 8)
Thanks to Gimi, I got an eBook in my inbox tonight (31st May 2014 - Release of Elite Reclamation)!

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Galactic Navy Strikes Back

Post by Eric Walch »

Nemoricus wrote:I've not been able to update the links in the wiki, I fear, for I have either forgotten the password to my account or never had one at all. If a pilot would do this on behalf of the Navy, their assistance would be greatly appreciated.
Great that you are back for updating it. It is one of the most favorite oxps. I just updated the wiki link to the new version and removed my, now obsolete, patch.

User avatar
Nemoricus
---- E L I T E ----
---- E L I T E ----
Posts: 388
Joined: Mon May 18, 2009 8:51 pm

Re: Galactic Navy Strikes Back

Post by Nemoricus »

Thanks for sorting out the wiki for me, Eric!
JazHaz wrote:The only problem I think that's outstanding is the lack of Behemoths, due to 1.75 compatibility issues with the two main Behemoth OXPs (the original and ADCK's). I think that GalNavy requires Behemoths??
Are you using these two in combination? Which versions? I just did some checks with Behemoths 2.6, and it appears to work just fine. However, I haven't used ADCK Behemoths and can't vouch for their compatibility.
Dream as if you'll live forever
Live as if you'll die tomorrow

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Galactic Navy Strikes Back

Post by Eric Walch »

Nemoricus wrote:I haven't used ADCK Behemoths and can't vouch for their compatibility.
That oxp is fully incompatible because it replaces the behemoths from GN with its own, but still uses the shipdata from an old GN version. Thereby removing scripts for ships that now should have one or giving it wrong scripts. Using that oxp in the current form will break some missions.

I just downloaded your new version 5.4.1, but the main script still says version 5.4.0 so I think you uploaded a wrong version. The this.SecComSystemCheck() and this.SecComSystemSetUp() you added at the end of that main script for the never released 5.4.0 version, still uses the static "System" that no longer works with Oolite 1.75. Should be "system".

User avatar
JazHaz
---- E L I T E ----
---- E L I T E ----
Posts: 2991
Joined: Tue Sep 22, 2009 11:07 am
Location: Enfield, Middlesex
Contact:

Re: Galactic Navy Strikes Back

Post by JazHaz »

Nemoricus wrote:
JazHaz wrote: The only problem I think that's outstanding is the lack of Behemoths, due to 1.75 compatibility issues with the two main Behemoth OXPs (the original and ADCK's). I think that GalNavy requires Behemoths??
Are you using these two in combination? Which versions? I just did some checks with Behemoths 2.6, and it appears to work just fine. However, I haven't used ADCK Behemoths and can't vouch for their compatibility.
Ah, it seems I was getting confuzzled due to the time I have been away. Eric Walch's Behemoth Spacewar is the incompatible one, and I had downloaded ADCK's Behemoths, which also has incompatibility problems. Have now deleted that, which is a shame as it has some nice new models including a great new SECOM station, and have installed Behemoths 2.6.
JazHaz

Gimi wrote:
drew wrote:£4,500 though! :shock: <Faints>
Cheers,
Drew.
Maybe you could start a Kickstarter Campaign to found your £4500 pledge. 8)
Thanks to Gimi, I got an eBook in my inbox tonight (31st May 2014 - Release of Elite Reclamation)!

User avatar
Nemoricus
---- E L I T E ----
---- E L I T E ----
Posts: 388
Joined: Mon May 18, 2009 8:51 pm

Re: Galactic Navy Strikes Back

Post by Nemoricus »

Eric Walch wrote:
Nemoricus wrote:I haven't used ADCK Behemoths and can't vouch for their compatibility.
That oxp is fully incompatible because it replaces the behemoths from GN with its own, but still uses the shipdata from an old GN version. Thereby removing scripts for ships that now should have one or giving it wrong scripts. Using that oxp in the current form will break some missions.
I'll have to look into this further, then, to see if there's anything I can do to mitigate that. Otherwise, I'll simply put in a warning not to use Galactic Navy
I just downloaded your new version 5.4.1, but the main script still says version 5.4.0 so I think you uploaded a wrong version. The this.SecComSystemCheck() and this.SecComSystemSetUp() you added at the end of that main script for the never released 5.4.0 version, still uses the static "System" that no longer works with Oolite 1.75. Should be "system".
It turns out that I did fix a capitalization issue that was causing problems. However, I missed those. They're now fixed. I've also gone through the main script and verified that there are no other such capitalization errors. The updated version is linked to in the first post, per usual
Dream as if you'll live forever
Live as if you'll die tomorrow

User avatar
CommonSenseOTB
---- E L I T E ----
---- E L I T E ----
Posts: 1397
Joined: Wed May 04, 2011 10:42 am
Location: Saskatchewan, Canada

Re: Galactic Navy Strikes Back

Post by CommonSenseOTB »

Why don't you just make a shipdata-overrides.plist that puts the proper scripts into the behemoths ships that need it and put that file in the Galactic Navy oxp.?

Welcome back Nemoricus. :)
Take an idea from one person and twist or modify it in a different way as a return suggestion so another person can see a part of it that can apply to the oxp they are working on.


CommonSense 'Outside-the-Box' Design Studios Ltd.
WIKI+OXPs

User avatar
Eric Walch
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
Posts: 5536
Joined: Sat Jun 16, 2007 3:48 pm
Location: Netherlands

Re: Galactic Navy Strikes Back

Post by Eric Walch »

CommonSenseOTB wrote:Why don't you just make a shipdata-overrides.plist that puts the proper scripts into the behemoths ships that need it and put that file in the Galactic Navy oxp.?
That would be way to go, but that should be done in the 'ADCK Behemoths' oxp and is not a job for GN. Instead of overwriting the full ships as now happens, using the shipdata-overrides.plist to only replace the model, texture and subentities of some of the ships. That way it is more likely that 'ADCK Behemoths' keeps working when things in GN change.

Post Reply