hey comanders i found whats been causeing some older oxp bug

Discussion and information relevant to creating special missions, new ships, skins etc.

Moderators: another_commander, winston

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

hey comanders i found whats been causeing some older oxp bug

Post by ashtiboy »

hey comanders i found what has been causeing some older oxp from working at all thats been efecting some poplear oxz ship packs! this will be helpful for the ootlie comutity to restore the funchons of alot of poplear addons. ~ hope this helps ~ ashtiboy the mac oolite fan and player


*i have edited and gotin rid of all misinfomation related to this topic due to finding out that i can indrictly find wich ship that does not work by finding ship data load errors indrectly from how the shipyard plist and ship data entrys efect echother*
Last edited by ashtiboy on Sat Oct 31, 2015 11:49 pm, edited 1 time in total.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Amah »

Itsi, itsi, itsi! !We eat your yak disco!

ok, seriously. this seems to be a some kind of bug report. As far I understood there's bug in shipdata.plist, affects only Mac OS, the curly bracket is not parsed correctly with Oolite v1.82? Can anybody with a Mac confirm and maybe explain what's the deal.I have no problems here on Linux.
Amah

User avatar
phkb
Commodore
Commodore
Posts: 2529
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: hey comanders i found whats been causeing some older oxp

Post by phkb »

Rather than the { at the beginning of the file, I suspect it's the lack of a ; on the last element. Mac's seem to be sensitive to this - each element in the list needs a ; to terminate it, otherwise it doesn't parse. I don't have all those OXP's, so someone else will need to check, but I've certainly run into this issue before (see this post, or here as well).

User avatar
Smivs
Retired Assassin
Retired Assassin
Posts: 8408
Joined: Tue Feb 09, 2010 11:31 am
Location: Disunited Kingdom
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Smivs »

Clippers and YellOo Cabs were updated a while ago to fix this - do you have the current version? The first curly should be there, but the problem lay further down the code - missing semi-colons in the Materials dictionary. The thread discussion is here.
Something similar may be causing problems with the other OXPs as well.
Commander Smivs, the friendliest Gourd this side of Riedquat.

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

Re: hey comanders i found whats been causeing some older oxp

Post by ashtiboy »

ok i will check

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

Re: hey comanders i found whats been causeing some older oxp

Post by ashtiboy »

i checked my logs it seams that my mac with mac os x 9 does in fact can't parse any plist file with a { on the very top of the plist file i compadred my logs from before i delited the { and after and it seams that mac os x 9 does not like haveing a { on line 1 at all

User avatar
phkb
Commodore
Commodore
Posts: 2529
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: hey comanders i found whats been causeing some older oxp

Post by phkb »

I think the issue is not in the "{" on line 1, otherwise every single OXZ will fail because they each have a manifest.plist file that begins with a "{".

The error may be reporting as failing to parse the plist file at character position 1, but I think the error is misleading. The actual bug will be, as smivs said, somewhere in the body of the file. Look for entries that don't have a terminating ";" character.

User avatar
phkb
Commodore
Commodore
Posts: 2529
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: hey comanders i found whats been causeing some older oxp

Post by phkb »

For instance, in the "Noshader Mimoriarty's Radical Logistics ships", in the shipdata.plist file, on line 916, it looks like this:

Code: Select all

                		illumination_map = { name = "noshaders_lira_sub_rud_lit.png"}; 
You can add a semicolon like this:

Code: Select all

                		illumination_map = { name = "noshaders_lira_sub_rud_lit.png";}; 
It's the same with line 1046, 1170 and 1231. Can you add semi-colons to each of these lines and try the OXZ again?

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Amah »

Thanks for clearing up,smiv, phkb and ashtiboy...

I'm currently fixing the missing ";" in the materials of the RL ships... Will upload a first update soon. Please check again.


I'm not sure what's wrong with the missing core ships, yet... but I'll go through that file...
Is there a way for me to check with no Mac for other syntax parsing errors?
Amah

User avatar
Wildeblood
---- E L I T E ----
---- E L I T E ----
Posts: 2161
Joined: Sat Jun 11, 2011 6:07 am
Location: Western Australia
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Wildeblood »

This preciousness of the Mac plist parser would be the one good argument in favour of writing plists in XML format instead of nextstep.

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Amah »

I have to admit as someone who normally codes in C, the javascript style plist is friendlier to my eyes ... but then again, I'm going through the missing core ship shipdata.plist for the second time and I haven't found anything yet...

/e: hmmh... I seem to have found a culprit:

Code: Select all

	"noshaders_missingcoreships_tharglet_organic" =     {
	like_ship = "oolite_template_tharglet";
	model="noshaders_tharglet_organic.dat";
	materials = 
		{ 
			"noshaders_missingcoreships_tharglet_organic_diffuse.png" = 
			{ 
				diffuse_map = "noshaders_missingcoreships_tharglet_organic_diffuse.png"; 
				specular_color = (0.2, 0.3, 0.2 );
				shininess = 25; 
				emission_map = { name = "noshaders_missingcoreships_tharglet_organic_diffuse.png"; extract_channel = "a"; }; 
				emission_modulate_color = (0.80, 0.0, 0.0); 
-->			}
		};
	};
Ashtiboy, could you add a ";" behind the closing curly bracket of the materials section and report back if it works for you now.
Amah

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

Re: hey comanders i found whats been causeing some older oxp

Post by ashtiboy »

thanks for the help but i can't seam to go into the oxz files for some reason becuse my computer does not reconizse a oxz as a file with packaged files inside to add the ;

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13820
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Cody »

On Windows, you rename the .oxz to .zip then extract and tinker - don't know about Macs though. I think the in-game manager will extract stuff too.

Welcome aboard, btw!

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

Re: hey comanders i found whats been causeing some older oxp

Post by ashtiboy »

ok thanks now i'm going to try to fix adcks ffe ships by looking for missing ; to get some of these oxps back up and runing

User avatar
Amah
---- E L I T E ----
---- E L I T E ----
Posts: 485
Joined: Tue Aug 28, 2012 8:05 pm
Location: aboard the Laenina Crowne - Yasen-N class space freighter
Contact:

Re: hey comanders i found whats been causeing some older oxp

Post by Amah »

Has adding the ";" fixed the missingcoreships for you? If yes, I'll upload the fix in the ingame expansion managerfor all.
Amah

Post Reply