Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Aug 21, 2017 10:09 am

All times are UTC




Post new topic  Reply to topic  [ 98 posts ]  Go to page Previous 13 4 5 6 7
Author Message
PostPosted: Thu Oct 22, 2015 4:09 pm 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Sun Jul 12, 2015 2:30 pm
Posts: 591
Location: Bavaria, Germany
A floating holo ad could even "block" the docking port, but I think I wouldn't like it... :roll:

PS: The bugfix worked!

_________________
"You wouldn't kill me just for a few credits, would you?" – "No, I'll do it just for the fun!"


Top
   
 Post subject: Re: [WIP] Station Ads
PostPosted: Fri Oct 23, 2015 11:50 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Tue Mar 03, 2015 11:35 am
Posts: 482
Location: Paris
Quote:
Quote:
But even in real life communist states like the GDR there have been ads around.
Of course.. because what most people don't understand is that the so-called Communist states, aren't really communist, but simply State Capitalism, as opposed to Private Capitalism. :wink:
Yup, and what most people have forgotten is that Communism means one or few owners, not mandatorily the state. The increasing concentration of wealth in the hands of a few families is in fact the increase of Communism, with all related problems.


Top
   
PostPosted: Thu Mar 10, 2016 10:45 pm 
Offline
Average
Average

Joined: Wed Mar 09, 2016 7:54 pm
Posts: 10
Like in this earlier post I get the error
Code:
Exception: TypeError: ship.subEntities[this.$dockSubent] is undefined
    Active script: station_ads_station_script 1.0.1
    station_ads.js, line 66:
    	var lastSubent = ship.subEntities[this.$dockSubent].subEntities.length - 1;
This setup seems to give me the error after starting the game:
Code:
    oolite.oxp.amah.noshaders_extra_stations_addon.oxz
    oolite.oxp.amah.noshaders_extra_stations_resources.oxz
    oolite.oxp.spara.additional_planets_sr_base.oxz
    oolite.oxp.spara.additional_planets_sr_pack_redux.oxz
    oolite.oxp.spara.stations_for_extra_planets.oxz
    oolite.oxp.spara.station_ads.oxz
and if I add YAH plus its Sets to the list, the error comes twice, at the mainscreen and after starting a game.

There is no error in the log if I use only either the noshaders_extra_stations or the stations_for_extra_planets. But, when using the noshaders_extra_stations there is only one blank adscreen at the main stations.
example image

Should I prevent using the noshader addon together with the nice station ads, or is there something I can do to make them happy together? :)

I am using:
Oolite version 1.82 x64
Windows 7, SP 1, 64-bit
OpenGL renderer version: 3.3.0 ("3.3.0"). Vendor: "NVIDIA Corporation". Renderer: "GeForce 210/PCIe/SSE2"
Station Ads OXP ver 1.0.1


Top
   
PostPosted: Tue Mar 15, 2016 6:56 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 15, 2012 4:19 am
Posts: 2444
Location: Finland
Thanks for reporting. New version 1.0.2. It was my oversight not thinking about like_shipping far enough :oops: . Now the error should be gone. Maybe...


Top
   
PostPosted: Wed Mar 16, 2016 2:32 am 
Offline
Average
Average

Joined: Wed Mar 09, 2016 7:54 pm
Posts: 10
Just tried and the log stays quite. :) Thank you very much.
And sorry, my bad, I had taken the readme more serious about supported stations (or just read the one from the extra stations).


Top
   
PostPosted: Wed Mar 16, 2016 7:16 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 885
Location: London, UK
I keep meaning to say how much I enjoy this add-on - it's making me slow most times I dock!


Top
   
PostPosted: Thu Apr 13, 2017 5:40 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 15, 2012 4:19 am
Posts: 2444
Location: Finland
Updated (1.0.3) to work with Griff's new station bundle.


Top
   
PostPosted: Fri Apr 21, 2017 5:41 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 15, 2012 4:19 am
Posts: 2444
Location: Finland
Updated to 1.0.4. Now works with Small System Stations OXP.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 98 posts ]  Go to page Previous 13 4 5 6 7

All times are UTC


Who is online

Users browsing this forum: Baidu [Spider] and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited