Oolite Bulletins

For information and discussion about Oolite.
It is currently Thu Oct 19, 2017 3:42 am

All times are UTC




Post new topic  Reply to topic  [ 154 posts ]  Go to page Previous 17 8 9 10 11 Next
Author Message
 Post subject: Re: Xenon UI OXP
PostPosted: Thu Nov 17, 2016 9:26 pm 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Hmm, that's odd. I'll check it out.

_________________
My OXP's


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Fri Nov 18, 2016 1:34 am 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Double "Hmm". I've tried to reproduce this but can't seem to find the right connections. I've tried with and without Svengali's Library OXP and BGS 2.0, but each time I get the right background on the details page. What OXP's are you running in this setup?

_________________
My OXP's


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Fri Nov 18, 2016 9:59 am 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
Hmm, indeed!

Upon further testing, it only appears to be missing on one particular save - my main commander, which was fine the night before.
Very strange! <scratches head> The problem must be at my end, so I'll have a tinker - the only change was the new nightly.

My apologies for bothering you.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Fri Nov 18, 2016 3:10 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
For the record, if I remove BGS 2.0 and keep Library 1.1, the problem disappears (perhaps unsurprisingly).

Edit to add: correction, it seems to affect all saves.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Fri Nov 18, 2016 10:11 pm 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Ah, that helps. I'll give that a try.

_________________
My OXP's


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Tue Nov 22, 2016 10:20 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Oct 20, 2007 2:52 pm
Posts: 2264
@Cody: What happens if you switch to BGS (through Lib_Config, with Xenon and BGS installed)?


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Tue Nov 22, 2016 10:41 am 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
If I switch to BGS, all is good.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Wed Nov 23, 2016 2:05 am 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
@Cody: I'm really sorry, but I can't reproduce your symptoms at my end. I've tried every combination I can think of, but no matter what I get the Xenon background on the parcel details page. The only way I can think this might be happening is if BGS ends up being loaded after Xenon UI Redux. In that scenario, the "lib_black.png" that BGS applies to the "long_range_chart_mission" and "short_range_chart_mission" settings via the screenbackground.plist file could take precedence over Xenon's entries for the same. One question: is Xenon UI Redux in the ManagedAddons folder, and BGS 2.0 in you Addons folder? If so, try moving Xenon UI Redux to the Addons and see if that helps.

_________________
My OXP's


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Wed Nov 23, 2016 2:15 am 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
Quote:
I've tried every combination I can think of...
You and me both! <grins> Thanks for trying. I'll be doing a clean re-install of just about everything soon - perhaps that'll kick it into shape.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Wed Nov 23, 2016 2:50 am 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
So is Xenon UI Redux in ManagedAddons? Did you try moving it to Addons?

_________________
My OXP's


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Wed Nov 23, 2016 12:08 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
I've tried it every which way. What has me scratching my head is the fact that it was fine one day, then the next day it wasn't.
As I said, a full re-install (which includes Windows) is on the to-do list. I'll not start tinkering again 'til that's all done.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Sun Nov 27, 2016 4:27 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
Quote:
...perhaps that'll kick it into shape.
A clean install of Win7, trunk nightly, and relevant OXPs, has done the trick - all is well again. For the record: BGS, Library, and Xenon Redux (UI and Resources) are currently in the AddOns folder, which is where they were yesterday when I still had the problem. <scratches head>

I'll leave them where they are for the time being, as I don't wish to tempt fate.

_________________
The only good fnord is a dead fnord!


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Tue Dec 06, 2016 10:05 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Oct 20, 2007 2:52 pm
Posts: 2264
Just as reminder. AddOns developers can't rely on loading order nor execution order of scripts. The may differ from system to system and specially the execution order may vary.


Top
   
 Post subject: Re: Xenon UI OXP
PostPosted: Thu Feb 16, 2017 1:15 am 
Online
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1739
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
A small update to version 2.0.2: a new title screen background, plus a fix for an issue when being used with Library GUI. The F5 Cmdr Profile and F5F5 Manifest screens were showing in the wrong order.

_________________
My OXP's


Top
   
PostPosted: Mon Mar 13, 2017 1:40 am 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12842
Location: Corke's Drift
Quote:
If the issue persists, I really will be stumped!
Howzat!


I tried the ordinary Xenon UI instead, and apart from it being too wide, there was no issue with the background.

_________________
The only good fnord is a dead fnord!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 154 posts ]  Go to page Previous 17 8 9 10 11 Next

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited