Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Feb 19, 2018 9:22 pm

All times are UTC




Post new topic  Reply to topic  [ 11 posts ] 
Author Message
 Post subject: GNN
PostPosted: Tue Feb 13, 2018 10:44 pm 
Online
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Oct 20, 2007 2:52 pm
Posts: 2281
Image

[EliteWiki] Galactic News Network has reached v1.0 and I guess it's time to release this baby into the wild. It's the successor to Snoopers, got tidied up quite a bit and should be even easier to use. Hope you will enjoy it.

Library v1.4 is required.

For developers: GNN gives you some infos about usage. Just use the console, e.g. worldScripts.GNN._Help();

Bring the world to its knees


Top
   
 Post subject: Re: GNN
PostPosted: Tue Feb 13, 2018 11:40 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 996
Location: London, UK
Should I remove snoopers before installing, or do they co-exist?


Top
   
 Post subject: Re: GNN
PostPosted: Wed Feb 14, 2018 2:31 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1913
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Looks like they can co-exist fine. There isn't an automatic update for OXP's referencing Snoopers. Authors will need to manually edit code to switch over to GNN (although the changes can be pretty minor). So if an OXP needs Snoopers now, it will still need Snoopers after installing GNN.

_________________
My OXP's


Top
   
 Post subject: Re: GNN
PostPosted: Wed Feb 14, 2018 8:41 am 
Online
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sat Oct 20, 2007 2:52 pm
Posts: 2281
Yes, the can co-exist. GNN uses completely different names, keys, etc.
And as far as I'm aware only the Vector really needs Snoopers. All other OXPs which were using it have done it optionally to add some flavour. So I guess removing it won't break any other OXP, except Vector, but this is broken already since Oolite 1.80. And CCL, Snoopers, OXPConfig and Hyperradio have been marked deprecated quite some time ago. They are written in and for Oolite v1.77.

Switching to GNN is easy. What I've seen is that OXPs are only using ID, Message, Agency and Priority, if at all. So no more advanced option got used and the mentioned settings have not really changed. Only Agency is now in range 1...4, so OXPs can use 'The Tionisla Chronicle' as well.


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 1:51 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 996
Location: London, UK
Tried removing snoopers and installing GNN, but I get this

Image

Annoyingly, Snoopers doesn't want to download for some reason so I've lost Bloomberg for the moment, which is a shame because there was a lucrative market for precious stones up ahead... (download worked when I reloaded Oolite and tried it again)

Any idea what's happening re GNN and how I fix it?


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 2:14 am 
Offline
Competent
Competent

Joined: Mon May 30, 2016 3:54 am
Posts: 63
Quote:
Any idea what's happening re GNN and how I fix it?
You need to update/download [EliteWiki] Library 1.4 then it will work fine :wink:

_________________
Trying to survive behind the controls of a Caduceus Psi XT in Alpha test :lol:


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 6:15 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 996
Location: London, UK
Unfortunately Library 1.4 appears to disable BGS, at least on my computer, and since I really like BGS I think I'm going to have to forget about it for now.


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 6:33 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1913
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
You might need to go into Library Config and turn on BGS in the GUI settings section.

_________________
My OXP's


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 8:17 am 
Offline
Competent
Competent

Joined: Mon May 30, 2016 3:54 am
Posts: 63
Quote:
Unfortunately Library 1.4 appears to disable BGS, at least on my computer, and since I really like BGS I think I'm going to have to forget about it for now.
There is [EliteWiki] BGS 2.2 available now which actually requests Library 1.4.

_________________
Trying to survive behind the controls of a Caduceus Psi XT in Alpha test :lol:


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 10:21 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 996
Location: London, UK
Thanks - I'll take a look.


Top
   
 Post subject: Re: GNN
PostPosted: Thu Feb 15, 2018 9:47 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 996
Location: London, UK
Got there in the end, once I realised I had to uninstall the old background set - GNN seems OK, but I've only had one news flash so far so it's hard to tell. I like the new BGS visually, not so keen on its audio side - see the BGS thread for why. Anyway, I'll stick with it now it's sorted, thanks for all the help.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 11 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited