Ships in Shipyards are way too dark in 1.70.

For test results, bug reports, announcements of new builds etc.

Moderators: another_commander, winston, Getafix

Post Reply
User avatar
julyy
Dangerous
Dangerous
Posts: 84
Joined: Mon May 16, 2005 9:51 am

Ships in Shipyards are way too dark in 1.70.

Post by julyy »

Maybe it's how the station is located against the sun (?)

... but I stopped by in 5 systems now in a row, where it is impossible to see the ships in the shipyard on a station. They are covered in darkness. Only highlighted from time to time.

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5835
Joined: Wed Feb 28, 2007 7:54 am

Post by another_commander »

This must be a result of having full shader effects on. Try it with shader effects set to simple and it should be ok. Having said that, maybe on the shipyard screen only, there should be no lighting applied to ships even with the full shader effects.

User avatar
Griff
Oolite 2 Art Director
Oolite 2 Art Director
Posts: 2312
Joined: Fri Jul 14, 2006 12:29 pm
Location: Wales

Post by Griff »

Maybe it's just the light position & direction that need tweaking? the lights on the start screen seems to shine in from the left of the model and on the shipyard it seems to shine in from the right, could it be changed so the light is locked to the camera on these screens and inherits the cameras position & direction?

User avatar
JensAyton
Grand Admiral Emeritus
Grand Admiral Emeritus
Posts: 6657
Joined: Sat Apr 02, 2005 2:43 pm
Location: Sweden
Contact:

Post by JensAyton »

It is a shader-related issue, caused by a problem in the game. It also occurs on the opening demo. This has to do with the “light 0 fix” that still needs implementing.

Applying no lighting to the ships on the shipyard screen would require all shaders to have a special case, which is not a reasonable approach. The proper thing to do is fix the lighting model in the game.

Post Reply