Glare visible when docked

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Glare visible when docked

Post by phkb » Mon Aug 10, 2015 11:33 pm

I don't know if this is by design, but I just docked in Zarienla in G6. Zarienla has a high level of glare in system. Here's a screenshot of just outside the station:
Image

That's fine. But, when I dock and view any screen that has a ship image on it (F3F3, and the F5 screen with the ship model enabled) the glare is visible on the window.

Here's a sample of the F4 screen at Zarienla. There's no ship here, so the background is nice and black:
Image

And here's a sample of the F5 screen:
Image
Notice that the background has been washed out by the glare.

I tried setting player.ship.sunGlareFilter to 1, but the issue remained.

Layne
---- E L I T E ----
---- E L I T E ----
Posts: 355
Joined: Sat Mar 28, 2015 11:14 pm

Re: Glare visible when docked

Post by Layne » Mon Aug 10, 2015 11:58 pm

I've had this same issue when using Deep Horizon System (which is why I stopped using it) and to a lesser extent (in occasional systems) Spara's Additional Planets OXP. The only system in G1 that I've found with the latter that has the glare (so far) is Edinso, but with Deep Horizons it seemed to be nearly /every/ system. The glare is universal in those cases, even when you're behind a planet, or docked, the whole screen looks washed out. Are you using one of those, phkb?

As it happens I did report the Deep Horizon bug to Cheyd on the Advanced Navigation Computer thread a few days ago, so he may be investigating. In Additional Planets it seems to be pretty rare, I've only found one system that I can remember that had the problem. If you're using that OXP, what does the system look like when you remove it?
Reports of my death have been greatly underestimated.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Glare visible when docked

Post by phkb » Tue Aug 11, 2015 12:41 am

Actually it appears to be Distant Suns that is adjusting the system glare and highlighting the issue. I just removed it and the issue went away. But still, the issue isn't with the Distant Suns OXP itself - it's just bringing the issue to light. The issue is that when a high value is set on the sun glare, it is being translated to dockside screens. Any non external view GUI screen should not be impacted by sun glare, especially when docked, but an argument could be made that even in-flight GUI screens should not have the glare.

Layne
---- E L I T E ----
---- E L I T E ----
Posts: 355
Joined: Sat Mar 28, 2015 11:14 pm

Re: Glare visible when docked

Post by Layne » Tue Aug 11, 2015 1:08 am

phkb wrote:Actually it appears to be Distant Suns that is adjusting the system glare and highlighting the issue. I just removed it and the issue went away. But still, the issue isn't with the Distant Suns OXP itself - it's just bringing the issue to light. The issue is that when a high value is set on the sun glare, it is being translated to dockside screens. Any non external view GUI screen should not be impacted by sun glare, especially when docked, but an argument could be made that even in-flight GUI screens should not have the glare.
I got the same issue on a clean install of 1.82 with /only/ Deep Horizons Systems in place and no other OXPs. It may be doing the same thing to the lighting.

EDIT:
Based on the other testimony I decided to re-check this to make sure I wasn't blaming the wrong OXP, but I just confirmed it by once again running a vanilla install of 1.82 with /only/ DH:S added. Deep Horizon Systems seems to do this to /every/ system I jumped to. If Distant Suns is doing the same thing, then at least it's only doing it to /some/ systems, which isn't so bad. Still, knowing what's wrong might mean both OXPs can be fixed.
Last edited by Layne on Tue Aug 11, 2015 4:29 am, edited 1 time in total.
Reports of my death have been greatly underestimated.

User avatar
ffutures
---- E L I T E ----
---- E L I T E ----
Posts: 1268
Joined: Wed Dec 04, 2013 12:34 pm
Location: London, UK
Contact:

Re: Glare visible when docked

Post by ffutures » Tue Aug 11, 2015 1:49 am

I've had this happen once with Distant Suns, don't have Deep Horizons Systems installed. To be honest, once (and in a system that looks like that) doesn't bother me.

User avatar
phkb
Commodore
Commodore
Posts: 2433
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: Glare visible when docked

Post by phkb » Tue Aug 11, 2015 6:27 am

ffutures wrote:To be honest, once (and in a system that looks like that) doesn't bother me.
It's not a bother, per se. It's just that I think the game could be improved (even if it's just a little-bitty-bit) by getting these sorts of things corrected.

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: Glare visible when docked

Post by cim » Tue Aug 11, 2015 3:44 pm

phkb wrote:I tried setting player.ship.sunGlareFilter to 1, but the issue remained.
The sun glare filter only cleans up direct glare, not "being inside the corona". With the right adjustments to star properties, and with the short default sun-planet distance, you could see that close to the planet.

Shouldn't affect GUI screens any more in tonight's build - thanks for the report.

Post Reply