Bug with info on nova systems

For test results, bug reports, announcements of new builds etc.

Moderators: another_commander, winston, Getafix

Post Reply
User avatar
phkb
Commodore
Commodore
Posts: 2672
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Bug with info on nova systems

Post by phkb »

The system info page on nova systems appears to be out of sync.

Image
In this image, I'm in Gal 4, in the Arrege system (id 235), after the nova mission has been completed. I set my destination to Leenra, and then opened the F7 screen to see the system data.

The title at the top is correct, but the info at the bottom seems to relate to my current system.

The issue doesn't happen with normal systems, just with nova ones.

This is Oolite 1.82 64bit on Windows 8.1. I tested with no OXP's and it still happens, so I don't think it's related to anything I've installed. Is anyone else seeing this?

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5633
Joined: Wed Feb 28, 2007 7:54 am

Re: Bug with info on nova systems

Post by another_commander »

Confirmed.

another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5633
Joined: Wed Feb 28, 2007 7:54 am

Re: Bug with info on nova systems

Post by another_commander »

We should be fixed with commit 5bc299c.

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13887
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Bug with info on nova systems

Post by Cody »

This had me scratching my head, as I'm certain I visited the environs of my nova system several times running 1.81 and never saw anything amiss. Hey-ho!
A squid eating dough in a polyethylene bag is fast and bulbous! Got me?

Post Reply