[solved]Oolite v1.82. Ship Library screen - tradeInFactor

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Griff
Oolite 2 Art Director
Oolite 2 Art Director
Posts: 2296
Joined: Fri Jul 14, 2006 12:29 pm
Location: Wales

[solved]Oolite v1.82. Ship Library screen - tradeInFactor

Post by Griff » Tue Jun 02, 2015 8:12 pm

I think there may be a problem with the tradeInFactor shader binding either not existing or being set to something like 0 when you view a player ship on the Library screen.
I get these messages in the log:

Code: Select all

20:56:00.270 [shader.uniform.unpermittedMethod]: Did not bind uniform "TradeFactor" to property -[ShipEntity tradeInFactor] - unpermitted method.
20:56:00.278 [shader.uniform.unpermittedMethod]: Did not bind uniform "TradeFactor" to property -[ShipEntity tradeInFactor] - unpermitted method.
and the shader on my ship chips all the paint off leaving just the normal map and a grey undercoat :lol:
The ship appears fine in game, no log messages like the ones above and the proper paint coat appears.

Image

The oxz I'm testing with is here
https://app.box.com/s/7cfvpcm9izvggkh47nthmgfd41hi614a

edit: removed upload - not needed
Last edited by Griff on Wed Jun 03, 2015 2:01 pm, edited 2 times in total.

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: Oolite v1.82. Ship Library screen - tradeInFactor

Post by cim » Tue Jun 02, 2015 8:17 pm

The Ship Library screen ships are assumed to be the NPC version, so they're created as "ships" rather than "player ships" and don't get the extra shader parameters. We could check their roles entry and create them as "player ships" if it contained "player" for the next version (or perhaps just always?), but in the meantime you'll have to use the NPC version of the shader I think.

User avatar
Griff
Oolite 2 Art Director
Oolite 2 Art Director
Posts: 2296
Joined: Fri Jul 14, 2006 12:29 pm
Location: Wales

Re: Oolite v1.82. Ship Library screen - tradeInFactor

Post by Griff » Tue Jun 02, 2015 8:22 pm

Thanks cim, I was just about to edit my post to say things looked fine when using an NPC ship but I thought I'd better report this just in case :D

Post Reply