PCLinuxOS: Failed to initialize backend "pulse" :-(

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
xptn
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun May 17, 2015 2:31 am

PCLinuxOS: Failed to initialize backend "pulse" :-(

Post by xptn » Sun May 17, 2015 3:20 am

Hi guys!

I had oolite v 1.77 working last year, but after I changed laptops I decided to install v1.80 from scratch and I have not been able to get it to run.

Read the other (SOLVED) issues but I can't get this to work. This is PCLinuxOS uptodate.

Issued --nosplash but no change there, I excluded de ALSA driver, no changes either.

Here is the "uname -a":

Linux localhost.localdomain 3.4.52-pclos1 #1 SMP Thu Jul 4 17:44:54 CDT 2013 i686 i686 i386 GNU/Linux

For the moment I got it running on an XP in Vbox :-(, but I prefer my PCLinuxOS.

Keep up the good work!!

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: PCLinuxOS: Failed to initialize backend "pulse" :-(

Post by Getafix » Sun May 17, 2015 1:55 pm

Please, run oolite from a terminal, copy the terminal window contents and paste them here.
Having done that, please, also copy and paste here the contents of your ~/.Oolite/Logs/Latest.log

EDIT: ...by the way...Hello and welcome! :)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

xptn
Mostly Harmless
Mostly Harmless
Posts: 2
Joined: Sun May 17, 2015 2:31 am

Re: PCLinuxOS: Failed to initialize backend "pulse" :-(

Post by xptn » Sun May 17, 2015 8:40 pm

:arrow: Ok, here is the instalation:

[gma@localhost Descargas]$ pwd
/home/gma/Descargas
[gma@localhost Descargas]$ ./oo
oolite-1.80.linux-x86.run oolite-1.80-test.linux-x86.run
[gma@localhost Descargas]$ ./oolite-1.80.linux-x86.run
Verifying archive integrity... All good.
Uncompressing Oolite 1.80 ..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Install Oolite system-wide or in your home directory? [s/H]
Removing Oolite from "/home/gma/GNUstep/Applications/Oolite"... Done.
Warning 48: Some folders could not be removed.
Installing Oolite in "/home/gma/GNUstep/Applications/Oolite"...
Copying oolite executable and resources... Done.
Extracting documentation... Done.
Extracting dependencies... Done.
Generating startup and wrapper scripts... Done.
Updating desktop menu... Done.
Cleaning up temporary folders... Done.
Finished!

A desktop menu entry "Oolite (oolite.org)" has been added under Games.
To start Oolite from a shell, run "/home/gma/GNUstep/Applications/Oolite/oolite".
To uninstall Oolite, run "/home/gma/GNUstep/Applications/Oolite/uninstall".

[gma@localhost Descargas]$

:arrow: Now try to run:
[gma@localhost Descargas]$
[gma@localhost Descargas]$ /home/gma/GNUstep/Applications/Oolite/oolite

It seems that your operating system does not have a valid timezone name
configured and is using an abbreviation instead. By comparing timezone
file data it is has been possible to find the actual timezone used, but
doing that is a slow process.

You can avoid slowness of this time zone detecting approach
by setting the environment variable TZ='Chile/Continental'
Or You can override the timezone name by setting the 'Local Time Zone'
NSUserDefault via the 'defaults' command line utility, a Preferences
application, or some other utility.
eg "defaults write NSGlobalDomain 'Local Time Zone' 'Chile/Continental'"

AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
AL lib: (EE) ALSANoMMapProc: available update failed: Tubería rota

SNIP SNIP
SNIP SNIP
SNIP SNIP

AL lib: (EE) ALSANoMMapProc: available update failed: Tubería rota
AL lib: (EE) ALSANoMMapProc: available update failed: Tubería rota
AL lib: (EE) ALSANoMMapProc: available update failed: Tubería rota
intel_do_flush_locked failed: Error de entrada/salida
AL lib: (EE) ALSANoMMapProc: available update failed: Tubería rota
AL lib: (EE) alc_cleanup: 1 device not closed

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)

:arrow: And now the LOGs:

Opening log for Oolite version 1.80 (x86-32) under Linux 3.4.52-pclos1 at 2015-05-17 17:33:53 -0400.
4 processors detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

17:33:54.384 [dataCache.notFound]: No data cache found, starting from scratch.
17:33:54.648 [display.mode.list.native]: X11 native resolution detected: 1366 x 768

Closing log at 2015-05-17 17:33:55 -0400.

:arrow: Thanks and have a good day :-)

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: PCLinuxOS: Failed to initialize backend "pulse" :-(

Post by Getafix » Mon May 18, 2015 7:02 am

In the past such cases had been caused by graphics driver issues and not from OpenAL itself.
I also get these AL warnings in various distros without breaking the game.

Anyhow, please try the following

Code: Select all

$ cd ~/GNUstep/Applications/Oolite/oolite-deps/lib
$ mv libopenal.so.1 libopenal.so.1.oolite
$ cd ~
$ ~/GNUstep/Applications/Oolite/oolite
This will force Oolite to use your system's libopenal.so.1 library
(considering that you have one installed, of course; at my vanilla Ubuntu 10.04 installation resides at /usr/lib/libopenal.so.1)
Last edited by Getafix on Mon May 18, 2015 7:02 am, edited 1 time in total.
Reason: Just formatting a paragraph.
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Post Reply