[Solved] OXZ dependency problem

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

[Solved] OXZ dependency problem

Post by Norby » Wed May 06, 2015 11:33 am

I made a metapackage in Ambience category with dependencies to my recommendations.
Then I selected to install and "download all packs", but after many successfully installed packages the process stopped on this screen:

Image

The "Cancel Downolad" does nothing so I returned to the menu, where my metapackage was shown as installed, but if these are real dependencies then surely can not work without these, so I suggest if somebody exit before finished then do not flag to installed.

Moreover in this case I can not retry by pressing again on the installation, so I removed my package and tried to install again. Downloaded many other packages, then stopped again on this screen:

Image

Ok, remove then install again, but surprisingly this time the "download all packs" does nothing, nor the next pack, so the following packages are remained:

Image

I repeated on another machine with clean install and the whole process was the same so I suspect a bug in the recursive dependency handler.
Last edited by Norby on Thu May 21, 2015 7:44 am, edited 3 times in total.

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: OXZ dependency problem

Post by cim » Wed May 06, 2015 5:38 pm

Found it. One of your dependencies is only installable on Oolite 1.80, so when Oolite 1.82 it gets to that point it tries to install the dependency, fails, and appears to hang.

I'll fix up the bug for tonight's build - Oolite will now say "couldn't satisfy dependency X, please resolve manually" if an automatic dependency installation attempt fails. In the meantime, if you could try removing Captain Solo's Good Fortune from your dependency list and then restarting the download, it should work - or at least, discover a second uninstallable OXZ.

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: OXZ dependency problem

Post by Norby » Wed May 06, 2015 7:54 pm

Thank you, first I ask the author to remove the version limitation. I tried Captain Solo's Good Fortune in 1.82 and worked well, moreover there is no such limit in the manifest.plist in the oxz just in the admin page.

I would like to see an "admin" column in the oxz table (login name of the manifest owner) to know who can modify a field in a similar case.

I need also to get back the unlimited setting in the max. Oolite version field.

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: OXZ dependency problem

Post by cim » Wed May 06, 2015 8:43 pm

Norby wrote:I need also to get back the unlimited setting in the max. Oolite version field.
That should be there and the default for new OXPs now.

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Solved] OXZ dependency problem

Post by Norby » Thu May 07, 2015 11:21 am

Thanks to cim, CaptSolo and Wildeblood, this recommendation package is working now. :)

User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

Re: [Solved] OXZ dependency problem

Post by Day » Thu May 07, 2015 12:20 pm

Norby, I really like meta-packages, congratulations :)

I think meta-packages would benefit from having an announced "flavour". I mean, "Norby's recommendation" doesn't mean anything to a new player. Maybe you could rename it to something like "Most graphically polished oolite" or "Fullest backstory oolite" or what you wish would describe well the spirit of your meta-package?

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Solved] OXZ dependency problem

Post by Norby » Thu May 07, 2015 3:44 pm

If I use a general name then somebody probably will request to change back to a personal recommendation so I adjusted only the description a bit based on your idea.

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13680
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: [Solved] OXZ dependency problem

Post by Cody » Thu May 07, 2015 3:50 pm

Day wrote:Maybe you could rename it to something like "Most graphically polished oolite" or "Fullest backstory oolite"...
Hmm... I see potential problems with those types of label.
Their dreams a tattered sail in the wind

User avatar
Day
---- E L I T E ----
---- E L I T E ----
Posts: 518
Joined: Tue Mar 03, 2015 11:35 am
Location: Paris

Re: [Solved] OXZ dependency problem

Post by Day » Thu May 07, 2015 4:19 pm

Cody wrote:
Day wrote:Maybe you could rename it to something like "Most graphically polished oolite" or "Fullest backstory oolite"...
Hmm... I see potential problems with those types of label.
Well, "Tentative of most graphically polished oolite according to Day with the help of bb members"? :-p

I mean, I totally see your point, what I'd like is the name to be at least a little informative.

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: OXZ dependency problem

Post by Norby » Wed May 20, 2015 11:45 am

I can not install my Ambiences pack regardless of no more version problems about since the BGS is doubled.

Starting without any installed OXZs the installation of my package stopped there:
Image

Then I removed my package, installed Ship's Library and tried my package again, but stopped again here:
Image

Then I removed my package, installed Ship Storage Helper and this time my package is installed well without more problems.

If I install the two "missing" packages before my own then no problems.


Another thing if I remove BGS after the succesfull install of Ambiences then a reinstall of my package can not start. The displayed message is weird due to P.A. Groove's pack is already installed:
ImageMoreover the downoad menu items does nothing when pressed.

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: OXZ dependency problem

Post by cim » Wed May 20, 2015 5:04 pm

There were a couple of issues with how the manager was handling A -> B -> C chains where A and B were installed but not C: essentially it wasn't able to load B because C was missing, so it considered this to be failing to meet A's dependency on B (correct: when trying to load OXPs to run the game!).

Tonight's build will let the manager recognise downloaded but not loaded OXZs so it can get out of these situations. Thanks for reporting the issue.

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: [Solved] OXZ dependency problem

Post by Norby » Thu May 21, 2015 7:46 am

Working well, thank you!

The message about install an already installed dependency of a required package (BGS Soundset if no BGS) is still there but now a cosmetic problem only.

Post Reply