Issues with textures with Oolite 1.80 (HEAD) on OS X

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
webbasan
Average
Average
Posts: 8
Joined: Sat Aug 07, 2010 2:39 pm
Location: Mundito Rosinante - a small world at the border of the city.

Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by webbasan » Sun Jul 06, 2014 12:07 pm

Hello,

I'm currently following the current state of Oolite development, checking out the stuff from github and building it for myself. I do this on very irregular intervals, so hadn't the time to investigate any issues further -- I just wanted to have an up-to-date "rich universe" and had some issues with the previous stable build and the current Griff shipset which I hoped to remedy with the current development version (at least with that I succeeded... :) )

But I discovered some new issues related to texture mapping:
  • It's especially easy to see with the BGS-OXP enabled: immediately after startup, the "Commander Status"-screen (F5) either appears with a white background or some random wrong texture. In the latest iteration it's mostly a texture of a character set.
  • In game, sometimes planets do have the wrong texture (for example a background image from the BGS-OXP) or none at all (planet is rendered black).
  • Issues with planet texturing appear sometimes also on the "Planet Info" Screen (F7). Here it seems to appear always on the first planet that is shown after startup, the other planets seem to be rendered correctly.
  • Having OXPs installed which require/deliver additional textures (BGS, Additional Planets, Povray planets, etc.) seem to provoke these issues, but I've had similar issues with a "bare metal" setup.
  • After some time running the game, I get an issue where the characters are not correctly rendered: instead of the transparent background I get only the rectangles in foreground color.
I still have to take the time and effort to do a thoroughly and consistent testing: some checks where done with different versions, I upgraded in the mean time to the newest OS X version and NVIDIA Web-Driver, etc.
But the symptoms didn't change that much during these changes so I'm somewhat confident that these are not related.

But maybe more it could be triggered with my hardware setup:
Mac Pro (2008, 2x2,8GHz Quad-Core), NVIDIA GeForce 8800 GT (512MB)
Currently running OX X 10.9.4 w/ NVIDIA Web Driver 334.01.02f02

Up to now, I didn't discover any issues with any other application, so I don't think I have a broken hardware or driver issue. But to eliminate these possibilities I still have to try again to get consistent test results (using Apples default driver, fresh restart w/ no other apps interfering, no OXPs, etc.). So maybe I can give more details in further posts...

So for now: Does anybody else has seen similar issues? Does anybody have additional ideas how I could track theses issues down?

Any input is very appreciated... :D

Kind regards,
webbasan

User avatar
Diziet Sma
---- E L I T E ----
---- E L I T E ----
Posts: 6310
Joined: Mon Apr 06, 2009 12:20 pm
Location: Aboard the Pitviper S.E. "Blackwidow"

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by Diziet Sma » Sun Jul 06, 2014 1:27 pm

Webbasan, since you're building yourself, from source, could you please post the full version number of your current build? It should look something like:

1.80.0.5831-140630-07cbf8f (The current release version)
or
1.81.0.5841-140706-ed44de8 (The current development version)

Also, you should note that Griff has just this weekend released an updated shipset for 1.80 which addressed a number of issues. See this post for details.
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied

User avatar
webbasan
Average
Average
Posts: 8
Joined: Sat Aug 07, 2010 2:39 pm
Location: Mundito Rosinante - a small world at the border of the city.

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by webbasan » Sun Jul 06, 2014 3:33 pm

Ooookay... Hmm, I didn't find out anything about the full version, but I'm definitely at Git version ed44de8.

My current log output looks like this:

Opening log for Oolite version 1.81 (x86-64 debug) under Mac OS X Version 10.9.4 (Build 13E28) at 2014-07-06 15:12:28 +0000.
Machine type: MacPro3,1, 16384 MiB memory, 8 x x86 (Penryn) @ 2800 MHz.
Build options: OpenAL, new planets, heavy OpenGL error checking, JavaScript console support, Debug plug-in support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.
[...]
17:12:29.203 [joystick.error.init]: Cannot open HID manager; joystick support will not function.
17:12:29.203 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 NVIDIA-8.27.26 334.01.02f02"). Vendor: "NVIDIA Corporation". Renderer: "NVIDIA GeForce 8800 GT OpenGL Engine".
17:12:29.204 [rendering.opengl.extensions]: OpenGL extensions (137):
[... details about GL extensions removed ...]
17:12:29.322 [rendering.opengl.shader.support]: Shaders are supported.
17:12:29.436 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
/Applications/Spiele/Space/Oolite-HEAD.mac/Oolite.app/Contents/Resources
~/Library/Application Support/Oolite/Managed AddOns
/Applications/Spiele/Space/Oolite-HEAD.mac/AddOns
[... many OXPs ;-) ...]
17:12:29.531 [shipData.load.begin]: Loading ship data.
17:12:29.657 [script.javascript.init]: JavaScript reset successful.
17:12:30.662 [debugSupport.load.success]: Debug Bundle loaded successfully.
17:12:30.781 [startup.complete]: ========== Loading complete in 1.70 seconds. ==========
17:12:30.886 [joystick.connect]: Joystick connected: Saitek X52 Pro Flight Control System
17:12:30.887 [joystick.connect]: Joystick connected: Logitech Cordless RumblePad 2
17:12:37.558 [script.javascript.init]: JavaScript reset successful.
17:12:38.748 [script.load.world.listAll]: Loaded 142 world scripts:
[... many more plugins ;-) ...]
17:12:40.904 [files.notFound]: ----- WARNING: Could not find texture file "griff_decals_set1_flipped_V.png".

Interesting enough: I've overlooked previously this last message, so I will follow your pointer to the update of the Griff ships.
As a side note: I've recognized the contradiction between "Cannot open HID manager; joystick support will not function." and "Joystick connected: Saitek X52 Pro Flight Control System" already in 1.77 -- and I can actually use my Saitek in the game! ;-)

Back to the current situation: during test starts to find the full version number I started also with a "new commander" - and this issue didn't appear. (I started with a new commander with 1.79 and used that file since then. With that file these issues are occuring. I didn't use any older files, since I didn't want to use them without a similar OXP setup as it was then they were created...)

I think I should follow this path further and see where it leads to...

User avatar
Diziet Sma
---- E L I T E ----
---- E L I T E ----
Posts: 6310
Joined: Mon Apr 06, 2009 12:20 pm
Location: Aboard the Pitviper S.E. "Blackwidow"

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by Diziet Sma » Sun Jul 06, 2014 6:23 pm

webbasan wrote:Ooookay... Hmm, I didn't find out anything about the full version
That's found in release.txt, but on the Mac, you'd have to go Show Package Contents on the Oolite app and browse inside it to find that file. Sorry.. I keep forgetting about the way Macs do things.

As for the rest, hopefully, one of the resident Mac geniuses here will be along shortly..
Most games have some sort of paddling-pool-and-water-wings beginning to ease you in: Oolite takes the rather more Darwinian approach of heaving you straight into the ocean, often with a brick or two in your pockets for luck. ~ Disembodied

User avatar
webbasan
Average
Average
Posts: 8
Joined: Sat Aug 07, 2010 2:39 pm
Location: Mundito Rosinante - a small world at the border of the city.

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by webbasan » Sun Jul 06, 2014 7:33 pm

Ok: no, it seems that this file doesn't get produced in the OS X build. It's neither in build folder nor in the Package.

A "Mac genius" ? Oh, that's what I missed (not) in the Ooniverse: a "Genius Bar"... :lol:


Although, with some consideration - not any more crazy than the "Black Monks":

---
"Hello, how can I help you?"

"I hear rattling noises when I bank left my Cobra."

"Oh, you didn't press Ctrl-Alt-Del to reboot, do you?"

" ... (WTF?)"

"Ok, never mind. Before going any further please reset your PRAM. And when you're at it, you can just reset the SMC also. To reset the PRAM you have to turn your Cobra upside down and shut it completely off. Even disconnect every energy cell and wait 10 seconds. After that connect the cells again and reboot the system. during reboot roll 97 degrees to the right and then yaw 142 degrees to the left. Then wait until everything is online again before rechecking if the issues persist."

"uh..."

"Can I do something else for you?"

"Uh, ... ah, yes: where are some yellow blotches on my windscreen!"

"Oh, yes, that happens sometimes. It's because the glue had not enough time to dry. Just wait some days and they will go away. Anything else? Ok, then, have a nice day!"

---

May be where is something in it... ;-)

Ok, never mind, I know what you really meant and thanks for your help so far! :)

bitsai
Mostly Harmless
Mostly Harmless
Posts: 3
Joined: Wed Sep 09, 2015 10:41 pm

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by bitsai » Wed Sep 09, 2015 11:01 pm

FWIW, I'm seeing all of the following texture issues as well:
webbasan wrote:
  • It's especially easy to see with the BGS-OXP enabled: immediately after startup, the "Commander Status"-screen (F5) either appears with a white background or some random wrong texture. In the latest iteration it's mostly a texture of a character set.
  • In game, sometimes planets do have the wrong texture (for example a background image from the BGS-OXP) or none at all (planet is rendered black).
  • Issues with planet texturing appear sometimes also on the "Planet Info" Screen (F7). Here it seems to appear always on the first planet that is shown after startup, the other planets seem to be rendered correctly.
  • Having OXPs installed which require/deliver additional textures (BGS, Additional Planets, Povray planets, etc.) seem to provoke these issues, but I've had similar issues with a "bare metal" setup.
  • After some time running the game, I get an issue where the characters are not correctly rendered: instead of the transparent background I get only the rectangles in foreground color.
Laptop specs:
MacBook Pro (Retina, 13-inch, Early 2015)
3.1 GHz Intel Core i7
Intel Iris Graphics 6100 1536 MB
Log output looks like this:
Opening log for Oolite version 1.82 (x86-64) under Mac OS X Version 10.10.5 (Build 14F27) at 2015-09-09 22:43:11 +0000.
Machine type: MacBookPro12,1, 16384 MiB memory, 2 (4 logical) x x86 (family 0x582ed09c) @ 3100 MHz.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

15:43:12.303 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 INTEL-10.6.33"). Vendor: "Intel". Renderer: "Intel(R) Iris(TM) Graphics 6100".
15:43:12.303 [rendering.opengl.extensions]: OpenGL extensions (128):
GL_EXT_texture_compression_dxt1, GL_EXT_rescale_normal, GL_EXT_transform_feedback, GL_EXT_blend_func_separate, GL_EXT_framebuffer_sRGB, GL_ATI_texture_env_combine3, GL_ARB_draw_elements_base_vertex, GL_EXT_debug_label, GL_EXT_geometry_shader4, GL_EXT_secondary_color, GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_NV_texgen_reflection, GL_NV_blend_square, GL_ARB_texture_compression_rgtc, GL_EXT_stencil_wrap, GL_ARB_texture_env_crossbar, GL_EXT_framebuffer_blit, GL_ATI_separate_stencil, GL_APPLE_vertex_point_size, GL_EXT_texture_rectangle, GL_APPLE_specular_vector, GL_EXT_packed_depth_stencil, GL_EXT_blend_color, GL_ARB_fragment_program_shadow, GL_EXT_texture_env_add, GL_EXT_provoking_vertex, GL_EXT_texture_array, GL_ARB_texture_env_combine, GL_ARB_point_sprite, GL_ARB_multisample, GL_EXT_framebuffer_object, GL_ARB_framebuffer_sRGB, GL_EXT_texture_lod_bias, GL_APPLE_pixel_buffer, GL_ARB_vertex_program, GL_EXT_bgra, GL_APPLE_fence, GL_APPLE_ycbcr_422, GL_EXT_timer_query, GL_EXT_vertex_array_bgra, GL_ARB_depth_clamp, GL_IBM_rasterpos_clip, GL_ARB_pixel_buffer_object, GL_SGIS_generate_mipmap, GL_EXT_framebuffer_multisample_blit_scaled, GL_ARB_shader_texture_lod, GL_ARB_texture_float, GL_ARB_texture_rectangle, GL_ARB_vertex_shader, GL_NV_texture_barrier, GL_ARB_provoking_vertex, GL_ARB_texture_env_add, GL_APPLE_object_purgeable, GL_ARB_texture_env_dot3, GL_APPLE_rgb_422, GL_NV_depth_clamp, GL_ARB_texture_mirrored_repeat, GL_ARB_texture_cube_map, GL_APPLE_element_array, GL_ATI_texture_float, GL_ARB_window_pos, GL_ARB_sync, GL_ARB_vertex_buffer_object, GL_APPLE_texture_range, GL_NV_conditional_render, GL_EXT_stencil_two_side, GL_ARB_texture_compression, GL_ARB_instanced_arrays, GL_EXT_blend_minmax, GL_ARB_texture_border_clamp, GL_EXT_draw_buffers2, GL_ARB_shading_language_100, GL_EXT_blend_equation_separate, GL_ARB_vertex_blend, GL_EXT_blend_subtract, GL_EXT_packed_float, GL_APPLE_aux_depth_stencil, GL_APPLE_row_bytes, GL_NV_light_max_exponent, GL_EXT_abgr, GL_EXT_texture_filter_anisotropic, GL_ARB_vertex_array_bgra, GL_ARB_draw_buffers, GL_ARB_transpose_matrix, GL_ARB_color_buffer_float, GL_EXT_gpu_program_parameters, GL_APPLE_client_storage, GL_ARB_texture_non_power_of_two, GL_ARB_multitexture, GL_EXT_gpu_shader4, GL_APPLE_flush_render, GL_ARB_framebuffer_object, GL_APPLE_vertex_program_evaluators, GL_APPLE_transform_hint, GL_EXT_texture_compression_s3tc, GL_APPLE_flush_buffer_range, GL_EXT_texture_integer, GL_SGIS_texture_edge_clamp, GL_NV_fog_distance, GL_ARB_occlusion_query, GL_ARB_fragment_shader, GL_ARB_texture_rg, GL_ARB_fragment_program, GL_ARB_seamless_cube_map, GL_ARB_shader_objects, GL_EXT_draw_range_elements, GL_APPLE_vertex_array_object, GL_ARB_depth_texture, GL_EXT_texture_sRGB, GL_ARB_half_float_vertex, GL_APPLE_vertex_array_range, GL_ARB_shadow, GL_EXT_multi_draw_arrays, GL_ARB_half_float_pixel, GL_APPLE_packed_pixels, GL_ARB_point_parameters, GL_EXT_debug_marker, GL_EXT_texture_sRGB_decode, GL_EXT_clip_volume_hint, GL_SGIS_texture_lod, GL_EXT_fog_coord, GL_EXT_texture_shared_exponent, GL_ATI_texture_mirror_once, GL_APPLE_float_pixels, GL_EXT_framebuffer_multisample, GL_ARB_depth_buffer_float, GL_ARB_draw_instanced
15:43:12.341 [rendering.opengl.shader.support]: Shaders are supported.
15:43:12.389 [searchPaths.dumpAll]: Resource paths:
~/Desktop/Oolite 1.82/Oolite.app/Contents/Resources
~/Library/Application Support/Oolite/Managed AddOns
~/Library/Application Support/Oolite/AddOns
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Norby.CombatMFD.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Norby.HUDSelector.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Norby.LaserCannons.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Norby.Trails.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.spara.additional_planets_sr_base.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.spara.additional_planets_sr_pack_redux.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.spara.market_observer.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.spara.random_hits.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.spara.random_hits_resources.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Svengali.BGS.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.Svengali.CCL.oxz
~/Library/Application Support/Oolite/Managed AddOns/oolite.oxp.ZygoUgo.ZygoCinematicSkyNebulas.oxz
15:43:12.419 [shipData.load.begin]: Loading ship data.
15:43:13.416 [startup.complete]: ========== Loading complete in 1.30 seconds. ==========
15:54:26.228 [shipData.load.begin]: Loading ship data.
15:54:27.000 [script.load.world.listAll]: Loaded 36 world scripts:
Additional Planets SR pack Redux 1.1
BGS-M 1.10.7
BGS-XMapping 1.10.1
Cabal_Common_Briefing 1.7
Cabal_Common_Comms 1.7
Cabal_Common_Functions 1.7
Cabal_Common_Keyboard 1.7
Cabal_Common_MissionHandling 1.7
Cabal_Common_Music 1.7
Cabal_Common_Overlay 1.7
Cabal_Common_OXPStrength 1.7.1
Cabal_Common_SpecialMarkets 1.7
combat_MFD 1.11
hudselector 1.16
lasercannons 1.8
market_observer3 3.4.1
mo-traders_rating3 3.4.1
Oolite Equipment Control 1.82
Oolite Ship Library 1.82
oolite-cloaking-device 1.82
oolite-constrictor-hunt 1.82
oolite-contracts-cargo 1.82
oolite-contracts-helpers 1.82
oolite-contracts-parcels 1.82
oolite-contracts-passengers 1.82
oolite-libPriorityAI 1.82
oolite-nova 1.82
oolite-populator 1.82
oolite-primable-equipment-register 1.82
oolite-registership 1.82
oolite-thargoid-plans 1.82
oolite-trumbles 1.82
oolite-tutorial 1.82
Random_Hits 1.10.4
System Redux 0.7
trails 1.2
15:54:27.106 [Check]: BGS-XMapping requirement not matched : snoopers not installed.
15:54:27.918 [hudselector]: HUDs: Default HUD,hud,ExtraLarge HUD with 10 MFDs and custom dials,hudselector-extralarge,hudselector-extralarge10,Large HUD with 10 MFDs and custom dials,hudselector-large,Small HUD with 10 MFDs and custom dials,hudselector-small
15:54:27.959 [hudselector]: Scanner NonLinear:false UltraZoom:false HUD:hudselector-large.plist Crosshairs: null, scanner settings is not fixed.
16:00:24.140 [shipData.load.begin]: Loading ship data.
16:00:25.747 [exit.context]: Exiting: Exit Game selected on start screen.

Closing log at 2015-09-09 23:00:25 +0000.

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13680
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by Cody » Thu Sep 10, 2015 8:19 pm

Welcome aboard, bitsai - and thanks! Not that I'm a Mac person, of course - they're a bit scarce here lately!
Their dreams a tattered sail in the wind

ashtiboy
Competent
Competent
Posts: 37
Joined: Thu Oct 29, 2015 9:41 pm

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by ashtiboy » Thu Oct 29, 2015 9:50 pm

i think the problem is the the bgm oxz/oxp needs the snoopers oxp installed or bgm won't work properly

Scoopy
Above Average
Above Average
Posts: 28
Joined: Mon May 05, 2008 4:37 pm
Location: Oslo

Re: Issues with textures with Oolite 1.80 (HEAD) on OS X

Post by Scoopy » Tue Nov 17, 2015 5:55 pm

I have two Mac mini´s. An old one and one I bought last week and they both experience similar issues. One on Maverick and on on Yosemeti

I load and unload various OXP´s in attempts to rectify the problems. I get the white background screen mentioned above, the lovely but somewhat bizarre rectangles in space, invisible cargo pods but the worst is when some sound drops out especially the being hit sound and the laser sound. That makes fighting a bit of a challenge and I die a lot when I can´t tell I´m being hit.

It seems somewhat random and exiting and re-loading always changes things a bit with it usually being playable and looking sensible (except the sound drop out happens maybe once in an hour).

I do have the BGS-OXP loaded and until recently, snoopers.

I do appreciate that this isn´t very helpful but it at least serves to show that these issues are are perhaps somewhat common on Mac.

Post Reply