Sounds stop playing in combination with BGS on Mac

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
pagroove
---- E L I T E ----
---- E L I T E ----
Posts: 3033
Joined: Wed Feb 21, 2007 11:52 pm
Location: On a famous planet

Sounds stop playing in combination with BGS on Mac

Post by pagroove » Thu Jun 12, 2014 10:31 pm

I have a problem that after a while sounds stops playing.
These messages are in the Latest.log.

I use BGS.
Any Idea why there is a sudden problem with the OpenAL buffer?
I can sometimes do 2/3 system jumps and then the problem does manifest. But at random times. Combat situations with repeating laser fire seems to lead to some sort of buffer overflow.

Is this also on other systems?

I'm on Os X 10.9.3.
No problems with other sound applications.


Code: Select all

00:11:29.447 [sound.load.error]: Could not create OpenAL buffer
00:11:30.674 [sound.load.error]: Could not create OpenAL buffer
00:11:34.926 [sound.load.error]: Could not create OpenAL buffer
00:11:36.103 [sound.load.error]: Could not create OpenAL buffer
00:11:36.113 [sound.load.error]: Could not create OpenAL buffer
00:11:36.113 [sound.load.error]: Could not create OpenAL buffer
00:11:36.676 [sound.load.error]: Could not create OpenAL buffer
00:11:37.451 [sound.load.error]: Could not create OpenAL buffer
00:11:40.466 [sound.load.error]: Could not create OpenAL buffer
00:11:41.686 [sound.load.error]: Could not create OpenAL buffer
00:11:42.986 [sound.load.error]: Could not create OpenAL buffer
00:11:44.051 [sound.load.error]: Could not create OpenAL buffer
00:11:46.472 [sound.load.error]: Could not create OpenAL buffer
00:11:46.481 [sound.load.error]: Could not create OpenAL buffer
00:11:48.411 [sound.load.error]: Could not create OpenAL buffer
00:11:54.956 [sound.load.error]: Could not create OpenAL buffer
00:11:56.798 [sound.load.error]: Could not create OpenAL buffer
00:12:24.484 [sound.load.error]: Could not create OpenAL buffer
00:12:29.993 [sound.load.error]: Could not create OpenAL buffer
00:12:32.398 [sound.load.error]: Could not create OpenAL buffer
00:12:32.984 [sound.load.error]: Could not create OpenAL buffer
00:12:34.149 [sound.load.error]: Could not create OpenAL buffer
00:12:34.883 [sound.load.error]: Could not create OpenAL buffer
00:12:35.728 [sound.load.error]: Could not create OpenAL buffer
00:12:38.643 [sound.load.error]: Could not create OpenAL buffer
00:12:38.849 [sound.load.error]: Could not create OpenAL buffer
00:12:39.028 [sound.load.error]: Could not create OpenAL buffer
00:12:39.223 [sound.load.error]: Could not create OpenAL buffer
00:12:39.393 [sound.load.error]: Could not create OpenAL buffer
00:12:39.579 [sound.load.error]: Could not create OpenAL buffer
00:12:39.758 [sound.load.error]: Could not create OpenAL buffer
00:12:39.928 [sound.load.error]: Could not create OpenAL buffer
For P.A. Groove's music check
https://soundcloud.com/p-a-groove
Famous Planets v 2.7. (for Povray)
Image
http://aegidian.org/bb/viewtopic.php?f=4&t=13709

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: Sounds stop playing in combination with BGS on Mac

Post by cim » Fri Jun 13, 2014 7:00 am

There's a limit of 1,024 AL buffers simultaneously available, but any individual sound should only be using at most two of them, and there are only 32 sound channels, so we should never get anywhere near that limit.

There is one possibility, reading the OpenAL documentation again, that the way deallocation of buffers is done may be the problem. I'm slightly surprised it's not come up on Linux or Windows if so but maybe their OpenAL library is designed differently - I'll try to put a patch together for that tonight.

User avatar
pagroove
---- E L I T E ----
---- E L I T E ----
Posts: 3033
Joined: Wed Feb 21, 2007 11:52 pm
Location: On a famous planet

Re: Sounds stop playing in combination with BGS on Mac

Post by pagroove » Fri Jun 13, 2014 7:07 am

Ok Cim Thanks. Let me know when I can try it out. :)
For P.A. Groove's music check
https://soundcloud.com/p-a-groove
Famous Planets v 2.7. (for Povray)
Image
http://aegidian.org/bb/viewtopic.php?f=4&t=13709

User avatar
cim
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 4018
Joined: Fri Nov 11, 2011 6:19 pm

Re: Sounds stop playing in combination with BGS on Mac

Post by cim » Fri Jun 13, 2014 5:18 pm

If I'm right about what's causing it, then it should be fixed in commit 853e0be for tonight's build.

User avatar
pagroove
---- E L I T E ----
---- E L I T E ----
Posts: 3033
Joined: Wed Feb 21, 2007 11:52 pm
Location: On a famous planet

Re: Sounds stop playing in combination with BGS on Mac

Post by pagroove » Fri Jun 13, 2014 6:59 pm

cim wrote:If I'm right about what's causing it, then it should be fixed in commit 853e0be for tonight's build.
Will look into it Sunday and report back.
For P.A. Groove's music check
https://soundcloud.com/p-a-groove
Famous Planets v 2.7. (for Povray)
Image
http://aegidian.org/bb/viewtopic.php?f=4&t=13709

jtarheel42
Average
Average
Posts: 12
Joined: Wed Aug 26, 2015 4:14 am

Re: Sounds stop playing in combination with BGS on Mac

Post by jtarheel42 » Mon Aug 31, 2015 7:57 am

I still keep getting that same problem.

Post Reply