Regarding the stutter I'm experiencing (visible in my videos)

For test results, bug reports, announcements of new builds etc.

Moderators: another_commander, winston, Getafix

Post Reply
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

It was suggested that the source of the stutter might be identifiable from the logs, so I pastebinned the last 2 minutes of my most recent session (not recorded, because it was just shuttling back and forth for an hour):

https://pastebin.com/i7YKcfB3

One thing I'm seeing here is a garbage collection warning every few seconds, which... sounds about right?
Here is my YouTube channel, where I play poorly: Arquebus X
hiran
---- E L I T E ----
---- E L I T E ----
Posts: 764
Joined: Fri Mar 26, 2021 1:39 pm
Location: a parallel world I created for myself. Some call it a singularity...

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by hiran »

If garbage collection happens that often I'd say the system is desperately low on heap memory. But that wisdom is transferred from Java environments and this one is JavaScript so I may be wrong here.

Looking at your logfile this is what catches my attention:

Code: Select all

[script.javaScript.unrootedTimer]: ----- WARNING: Timer <OOJSTimer 0x59782270>{nextTime: 2027.98, one-shot, running, function: anonymous} is being garbage-collected while still running. You must keep a reference to all running timers, or they will stop unpredictably!
I guess that some of your OXPs performs bad memory management. Why else would active timers loose all their references and be subject to garbage collection? And poor memory management would lead to the garbage collector getting desperate as well.

So you'd probably need to find the OXP that - when removed - resolves these issues.
I have not failed. I've just found 10,000 ways that won't work. [Thomas Edison]
User avatar
tsoj
Deadly
Deadly
Posts: 155
Joined: Wed May 18, 2016 8:19 pm
Location: Berlin
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by tsoj »

hiran's right, though I am not sure if this warning has anything to do with the stuttering. I would have expected something that appears every second or so, if it's related to the stuttering. Unfortunately, from the log file we can't really know which OXP does this, so quickly trying it out is probably not feasible, except maybe if someone here has an idea which OXP might cause these kinds of warnings.
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

tsoj wrote: Sun Dec 05, 2021 11:02 pm hiran's right, though I am not sure if this warning has anything to do with the stuttering. I would have expected something that appears every second or so, if it's related to the stuttering. Unfortunately, from the log file we can't really know which OXP does this, so quickly trying it out is probably not feasible, except maybe if someone here has an idea which OXP might cause these kinds of warnings.
Yeah the garbage collection issue isn't related to the stuttering, from my tests today. If I start a new game with ALL my oxps installed, I don't get a stutter at the beginning but I do get the garbage collection entries. I fly out of the station, spin around a few times and then quit - and I see the garbage collection message, but I didn't get stuttering.

I've also determined that it seems that multiple oxps are causing the garbage collection error - unless there's a chain of dependencies I missed. I did some high level A/B testing (pulled half, kept half - pulled half of half, etc.) and discovered that I was getting garbage collection errors for a few of the batches.

I may someday do a more granular test, but with 400 oxps installed, evidence that the garbage collection error isn't related, and a stuttering issue that *I* can live with, I don't quite have the motivation at the moment!
Here is my YouTube channel, where I play poorly: Arquebus X
another_commander
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 5969
Joined: Wed Feb 28, 2007 7:54 am

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by another_commander »

Try removing the Trails OXP and see if this resolves the stutter. This OXP was known to be a huge resource hog, but I am not sure if this was addressed in one of its later versions or not.
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

I found the problem!

You'll never guess.

You'll never, ever guess. It's such a weird thing to be causing the problem.

UsefulMFDs.

I suspect that the General Info MFD is constantly polling for updates, but I can't be sure, as there is nothing in the log reflecting its behavior.
Here is my YouTube channel, where I play poorly: Arquebus X
User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 15080
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by Cody »

arquebus wrote: Mon Dec 06, 2021 7:30 amI found the problem! [...] UsefulMFDs.
How very... useful!
We pray for one last landing
On the globe that gave us birth
Let us rest our eyes on the fleecy skies
And the cool, green hills of Earth
hiran
---- E L I T E ----
---- E L I T E ----
Posts: 764
Joined: Fri Mar 26, 2021 1:39 pm
Location: a parallel world I created for myself. Some call it a singularity...

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by hiran »

arquebus wrote: Sun Dec 05, 2021 11:10 pm I've also determined that it seems that multiple oxps are causing the garbage collection error - unless there's a chain of dependencies I missed. I did some high level A/B testing (pulled half, kept half - pulled half of half, etc.) and discovered that I was getting garbage collection errors for a few of the batches.
A/B testing (or a binary search as I'd call it) is the most effective way to find the offender(s).
arquebus wrote: Sun Dec 05, 2021 11:10 pm I may someday do a more granular test, but with 400 oxps installed, evidence that the garbage collection error isn't related, and a stuttering issue that *I* can live with, I don't quite have the motivation at the moment!
That is something only you can decide, but it is a valid point.

Note though that garbage collection kicks in on demand, which means when the system needs more memory. As long as there is plenty it simply does not bother cleaning up. So even if you have memory management problems it is natural they do not show up directly after starting the application. How quickly they start up depends on how much memory is available in total and how quickly the application bleeds it away. And the bleeding may be related to what you are doing with the application...
I have not failed. I've just found 10,000 ways that won't work. [Thomas Edison]
hiran
---- E L I T E ----
---- E L I T E ----
Posts: 764
Joined: Fri Mar 26, 2021 1:39 pm
Location: a parallel world I created for myself. Some call it a singularity...

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by hiran »

arquebus wrote: Mon Dec 06, 2021 7:30 am I found the problem!

You'll never guess.

You'll never, ever guess. It's such a weird thing to be causing the problem.

UsefulMFDs.

I suspect that the General Info MFD is constantly polling for updates, but I can't be sure, as there is nothing in the log reflecting its behavior.
Oh. A lucky catch then. Congratulations!

Now what are we (the community) going to do with this information? Get someone to fix it? Ping the author? Or mark the OXP as buggy? Or...
I have not failed. I've just found 10,000 ways that won't work. [Thomas Edison]
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 2414
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty (currently plague-ridden)
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by Cholmondely »

hiran wrote: Mon Dec 06, 2021 11:30 am
arquebus wrote: Mon Dec 06, 2021 7:30 am I found the problem!

You'll never guess.

You'll never, ever guess. It's such a weird thing to be causing the problem.

UsefulMFDs.

I suspect that the General Info MFD is constantly polling for updates, but I can't be sure, as there is nothing in the log reflecting its behavior.
Oh. A lucky catch then. Congratulations!

Now what are we (the community) going to do with this information? Get someone to fix it? Ping the author? Or mark the OXP as buggy? Or...
I've put up a post on the Useful MFD's thread.

Useful MFD's was written by Zireael who, encountering the Witchspace Lobster back in 2017 fought manfully, but ended up being devoured with his bones spat out into interstellar space, and then trodden on by hordes of lobstoid acolytes....

Dybal put it on the Expansions Manager last year - and added the (cronky) compatibility with Stranger's World. He then, in his turn, was ritually extirpated by the the demon Ebortsa, cast into the outer wilderness, defenestrated, rusticated and pelted with Alien Items.

Nobody else now dares goes near this one, for fear of the wrath of the ineffable....

The Hounding of Ebortsa, provenance unknown: painting in the nave of the Grand Cathedral of Digebiti
Note the alternating hues of the demonic loincloths, a matter of profound analysis in the renowned treatise on Theological Arithmetics by Saint Phibo Nacci, the famed Tibecean Sacerdote

Image
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte

Oolite BB Topic icons guide
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

It's also possible that UsefulMFD isn't the precise culprit, but is reacting to another OXP that is behaving incorrectly. However, since the problem goes away when I take UsefulMFD out and the only thing I'm using UsefulMFD for is... the... useful mfd... I can live without it.

But let us not forget that I have roughly 400 OXPs installed. The chances of two of them negatively interacting with one another, where neither one is strictly speaking "a problem" on its own, is probably pretty high.
Here is my YouTube channel, where I play poorly: Arquebus X
User avatar
Cholmondely
Wiki Wizard
Wiki Wizard
Posts: 2414
Joined: Tue Jul 07, 2020 11:00 am
Location: The Delightful Domains of Her Most Britannic Majesty (currently plague-ridden)
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by Cholmondely »

arquebus wrote: Mon Dec 06, 2021 4:26 pm It's also possible that UsefulMFD isn't the precise culprit, but is reacting to another OXP that is behaving incorrectly. However, since the problem goes away when I take UsefulMFD out and the only thing I'm using UsefulMFD for is... the... useful mfd... I can live without it.

But let us not forget that I have roughly 400 OXPs installed. The chances of two of them negatively interacting with one another, where neither one is strictly speaking "a problem" on its own, is probably pretty high.
Indeed. But Useful MFD's does perform a continual analysis of the Solar Flux (important for scooping fuel in normal flight - but only if you have the HardWay.oxp running), which varies with distance from the sun and with solar activity. So there is a constant montoring activity going on inside the Dyballic variant. And, as adumbrated elsewhere, this bit of it is buggy.

The two things that the useful MFD's do give you are
(i) the Service Level (on the second line). When this falls below 85%, your ship starts acting up.
(ii) the second useful MFD tells you what cargo you have in your hold - and the current price at the local main orbital station.
Denizen of the Dark and Dismal Deserts of Digebiti.

Milo wrote Dancing the Gavotte

Oolite BB Topic icons guide
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

Cholmondely wrote: Mon Dec 06, 2021 4:53 pm The two things that the useful MFD's do give you are
(i) the Service Level (on the second line). When this falls below 85%, your ship starts acting up.
(ii) the second useful MFD tells you what cargo you have in your hold - and the current price at the local main orbital station.
Vimana shows the brown wrench so that will do the job, I think. And losing the cargo MFD is unfortunate but I wasn't using it anyway, and I can always F5 if I really need to see what I've got on me (and F8 if I need to see the local market). Those two MFDs are certainly *useful*, but luckily not *crucial.*
Here is my YouTube channel, where I play poorly: Arquebus X
hiran
---- E L I T E ----
---- E L I T E ----
Posts: 764
Joined: Fri Mar 26, 2021 1:39 pm
Location: a parallel world I created for myself. Some call it a singularity...

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by hiran »

arquebus wrote: Mon Dec 06, 2021 4:26 pm But let us not forget that I have roughly 400 OXPs installed. The chances of two of them negatively interacting with one another, where neither one is strictly speaking "a problem" on its own, is probably pretty high.
This is interesting. In that case you might want to remove all OXPs but the Useful MFDs and then add more OXPs until you get that stutter again...
I have not failed. I've just found 10,000 ways that won't work. [Thomas Edison]
arquebus
Deadly
Deadly
Posts: 217
Joined: Sun Oct 31, 2021 6:07 am
Contact:

Re: Regarding the stutter I'm experiencing (visible in my videos)

Post by arquebus »

hiran wrote: Mon Dec 06, 2021 7:21 pm
arquebus wrote: Mon Dec 06, 2021 4:26 pm But let us not forget that I have roughly 400 OXPs installed. The chances of two of them negatively interacting with one another, where neither one is strictly speaking "a problem" on its own, is probably pretty high.
This is interesting. In that case you might want to remove all OXPs but the Useful MFDs and then add more OXPs until you get that stutter again...
Yup, that's on the docket for some point in the future.
Here is my YouTube channel, where I play poorly: Arquebus X
Post Reply