star issue

General discussion for players of Oolite.

Moderators: winston, another_commander

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

star issue

Post by sprocket » Sun Nov 15, 2015 7:20 pm

since 1.82 upgrade, i got stars, then don't have stars, then, stars again. i'm thinking it's a graphics issue, got ideas?
this does not happen during the game, only when starting new ones.

sprocket

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13753
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: star issue

Post by Cody » Sun Nov 15, 2015 7:43 pm

When you say 'no stars', do you mean the sky is completely black? No nebulae, no stars, nothing?
Their dreams a tattered sail in the wind

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Tue Nov 17, 2015 2:20 pm

fuzzy squares, no nebula or dust clouds...all other graphics work, 3d, ect...it's like the background graphics detail is not there.

sprocket

User avatar
Redspear
---- E L I T E ----
---- E L I T E ----
Posts: 1346
Joined: Thu Jun 20, 2013 10:22 pm

Re: star issue

Post by Redspear » Tue Nov 17, 2015 3:46 pm

Sounds like this problem...

http://aegidian.org/bb/viewtopic.php?f= ... 51#p222085

(potential fix included in the link).
"With our thoughts, we make the world" :-) - - - Game too slow for you? Masslock Compensators - - - Trouble getting out of trouble? Indestructible Injectors

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Thu Nov 19, 2015 2:43 am

ok, think i just messed it all up...

...uninstalled all, re-downloaded and installed 1.82, 32 bit windows...

now, still got no stars, just squares in place of stars, nebula...

have saved 'sprocket' as commander, loads only as jameson...

...not real good at this...

sprocket...

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Thu Nov 19, 2015 3:08 am

i've lost the game...

...need it back...

User avatar
phkb
Commodore
Commodore
Posts: 2451
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: star issue

Post by phkb » Thu Nov 19, 2015 3:15 am

When you installed the game, did you install it to "C:\Oolite", or to "C:\Program Files\Oolite"? I think Oolite does a lot better if you install it to "C:\Oolite".

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Fri Nov 20, 2015 7:12 pm

ok, after my 'lost my world' break down, iv'e got it covered...

before i uninstalled all of oolite, i did save all of my oolite-saves files in an other location...i have survived...!

re-installed oolite and yes, "C:\Oolite"...

left the station as jameson, 'no stars', same as it was...

decided to install oolite on an other computer to test my theory of it simply being my own graphics issue and not the game...

i was right...! the other computer is say, much 'more' than my little laptop, nice stars too...

...time to upgrade...!

thanks for the suggestions...

sprocket...

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13753
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: star issue

Post by Cody » Fri Nov 20, 2015 7:14 pm

Cool!
Their dreams a tattered sail in the wind

User avatar
Imaginos
Deadly
Deadly
Posts: 138
Joined: Tue Nov 04, 2014 2:06 pm

Re: star issue

Post by Imaginos » Fri Dec 11, 2015 10:00 am

sprocket wrote:fuzzy squares, no nebula or dust clouds...all other graphics work, 3d, ect...it's like the background graphics detail is not there.

sprocket
I've been having the same issue. Also when I played last night (the first time in a week or two) I had no engine or laser sounds. The voice SFX were there though.

User avatar
Imaginos
Deadly
Deadly
Posts: 138
Joined: Tue Nov 04, 2014 2:06 pm

Re: star issue

Post by Imaginos » Sat Dec 12, 2015 3:01 pm

I amended .GNUstepDefaults as advised and it works a treat.

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Mon Dec 21, 2015 11:05 pm

"I amended .GNUstepDefaults as advised and it works a treat."

Ok, what I am in need of are detailed instructions starting with step one as to how to do this. Windows has no clue on my laptop as to what program to open .GNUstepDefaults to make changes. Need some assist, please?

cmdr Sprocket...

User avatar
Cody
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
Posts: 13753
Joined: Sat Jul 04, 2009 9:31 pm
Location: Corke's Drift
Contact:

Re: star issue

Post by Cody » Mon Dec 21, 2015 11:08 pm

If you're gonna tinker, it's probably best to grab notepad++ and use that - it's good free software (other editors are available).
Remember the golden rule: after saving an edit, restart Oolite with the shift key held down 'til the spinning Cobra appears.
Their dreams a tattered sail in the wind

sprocket
Average
Average
Posts: 13
Joined: Mon Sep 28, 2015 11:44 pm

Re: star issue

Post by sprocket » Tue Dec 22, 2015 3:33 am

Ok, thanks...

...so i'm in the thick of it, blasting, dodging, launching, running...

...the game stops, locks up, shuts down, game closes out and i,m at my main computer screen...?

Ok, so i bring Oolite back up and wow, got stars, nubula...

...run a couple of hops, all good, time to shut down for the night...

Restarted computer, had to see, brought Oolite back up...

... ...

...no stars...nebula...

...sprocket...

User avatar
phkb
Commodore
Commodore
Posts: 2451
Joined: Tue Jan 21, 2014 10:37 pm
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...

Re: star issue

Post by phkb » Tue Dec 22, 2015 3:35 am

Are you able to post the content of your "latest.log" file? And maybe the "previous.log" file from the session that worked? There might be something in there to help track the issue.

Post Reply