Oolite Bulletins

For information and discussion about Oolite.
It is currently Sun Sep 24, 2017 6:56 am

All times are UTC




Post new topic  Reply to topic  [ 36 posts ]  Go to page 1 2 3 Next
Author Message
PostPosted: Wed Jul 22, 2015 7:43 am 
Offline
Harmless
Harmless

Joined: Wed Jul 22, 2015 5:30 am
Posts: 1
Hi,

I have recently downloaded Oolite v1.82 (for mac). On running the game for the first time, all works as expected. However, on exiting the game and trying to run it again, the loading screen appears but nothing further happens..

I have to delete the entire game directory, the Preferences plist, Cache and Log files, restart my mac book, unzip the game directory again and then the game will restart.

Has anyone experienced this problem, and does anyone have any thoughts as to why this might be happening?.

The Oolite Latest log file contains the following :

Opening log for Oolite version 1.82 (x86-64) under Mac OS X Version 10.10.4 (Build 14E46) at 2015-07-22 05:40:49 +0000.
Machine type: MacBookPro11,3, 16384 MiB memory, 4 (8 logical) x x86 (Haswell) @ 2300 MHz.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

15:40:49.798 [dataCache.notFound]: No data cache found, starting from scratch.
15:40:50.529 [system]: -[SUHost sharedFrameworksPath]: unrecognized selector sent to instance 0x6000000013f0


The System log files contains:

Jul 22 16:27:16 {computername}.local Oolite[1337]: -[SUHost sharedFrameworksPath]: unrecognized selector sent to instance 0x608000001740
Jul 22 16:27:16 {computername} com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.Oolite.1337): Failed to bootstrap path: path = /Users/{username}/Downloads/Oolite 1.82/Oolite.app/Contents/Frameworks/Sparkle.framework/Versions/A/Sparkle, error = 20: Not a directory


Top
   
PostPosted: Wed Jul 22, 2015 9:13 am 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 4923
I think this is an already known problem, reported with version 1.80 and registered as issue #128 on github. The description is very similar but the versions of both the game and OSX involved are different in the two reports. In any case, I believe they are closely related so I updated the issue with the additional information you have provided.

I am afraid that actual investigation of the report may have to wait for response from one of our Mac maintainers, of whom none seems to be active at the moment.


Top
   
PostPosted: Thu Jul 23, 2015 6:41 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
Assuming I really don't want to roll back the OS, what's the last version of Oolite for Mac that's still working properly?


Top
   
PostPosted: Thu Jul 23, 2015 6:54 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 4923
Theoretically, it is 1.82. Just because there are two similar reports of a problem does not necessarily mean that the game does not run properly on every single Mac. We need to find what is the common denominator in these reports and see if there is a way to resolve it for those with the problem. Unfortunately, this might be quite tricky when the current team works on non-Mac machines, but implying this is a generic Mac problem is a long shot, unless proven otherwise.


Top
   
PostPosted: Thu Jul 23, 2015 7:28 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
Quote:
Theoretically, it is 1.82. Just because there are two similar reports of a problem does not necessarily mean that the game does not run properly on every single Mac. We need to find what is the common denominator in these reports and see if there is a way to resolve it for those with the problem. Unfortunately, this might be quite tricky when the current team works on non-Mac machines, but implying this is a generic Mac problem is a long shot, unless proven otherwise.
Unfortunately I wouldn't be asking if I wasn't having the same problem - same OS etc.


Top
   
PostPosted: Thu Jul 23, 2015 8:42 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 4923
Quote:
Unfortunately I wouldn't be asking if I wasn't having the same problem - same OS etc.
Fair enough. In this case I don't think there is an answer to the question at this moment. It would help tremendously though if you could test it out using the archived builds at https://drive.google.com/folderview?id= ... aring#list and seeing if any of them actually works on 10.10.4. Also, can you please provide the version of Sparkle in use?

Unfortunately we need to collect as much information as possible and hope that something obvious comes up. It is nearly impossible to troubleshoot without being able to access a Mac, but the more information we can gather the better the chance.


Top
   
PostPosted: Thu Jul 23, 2015 11:23 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
Just tried re-installing 1.80, that's not working either (but was the last time I used it, a week or two before 1.82 came out)

Where do I find the Sparkle version?


Top
   
PostPosted: Fri Jul 24, 2015 3:15 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sun Feb 23, 2014 11:26 am
Posts: 329
Location: Sweden
The game is working on my mac, I can relaunch it without problems, so not a generic problem with 10.10.4
Code:
Opening log for Oolite version 1.82 (x86-64) under Mac OS X Version 10.10.4 (Build 14E46) at 2015-07-24 15:06:39 +0000.
Machine type: MacBookAir6,2, 8192 MiB memory, 2 (4 logical) x x86 (Haswell) @ 1300 MHz.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

17:06:39.894 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1 INTEL-10.6.31"). Vendor: "Intel Inc.". Renderer: "Intel HD Graphics 5000 OpenGL Engine".

_________________
Taurus Driving through the galaxy since... .


Top
   
PostPosted: Fri Jul 24, 2015 4:40 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
What I'm not finding is any logs at all - where should they be on the Mac version?


Top
   
PostPosted: Fri Jul 24, 2015 4:42 pm 
Offline
Jedi Spam Assassin
Jedi Spam Assassin
User avatar

Joined: Thu Jul 12, 2007 10:54 pm
Posts: 5821
Location: Carter's Snort
From the [wiki]Oolite FAQ[/wiki]:
Quote:
Restart Oolite, and select “Show Previous Log” from the “Oolite” menu in the menu bar. Alternatively, in the Finder, select “Go to Folder…” from the Go menu, and enter “~/Library/Logs/Oolite/”, and find Latest.log.

_________________
Oofiction: Calliope: a Captain Hesperus adventure | Stranglehold: a Captain Hesperus adventure | Local Midnight in the Vacuum Bar | A Farewell to Arms, Legs, etc.: the Blaze O'Glory Story


Top
   
PostPosted: Fri Jul 24, 2015 4:55 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
OK - nothing about Sparkle in the log at all.

I just managed to reload a saved game from 1.80 without crashing, so it may be that the saved game I previously tried was corrupt in some way. So what I'll do next is install 1.82, save a Jameson, and see how that goes. Must say it's going to be a bit annoying if I can't reload old saved games.


Top
   
PostPosted: Fri Jul 24, 2015 5:14 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
OK, so now 1.82 is working with the game I saved from 1.80, but not older saved games, they crash it or fail to load.

I finally found the sparkle version in the OSX crash report - looks to be Sparkle (1.5 Beta 6 - 313)

The message I just got from one that failed to load is:

Failed to restore saved game
Could not set up player ship

Which seems odd because it's a boa cruiser. Does this mean it doesn't have some of the OXPs or something?


Top
   
PostPosted: Fri Jul 24, 2015 5:22 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Fri Nov 11, 2011 6:19 pm
Posts: 4012
1.82 should be able to load any previous version's saves - could you put one that fails to load up somewhere for a look?

(It's possible your previous save was using an addition shipset's Boa II, which you don't currently have installed, but other than that I can't think of an obvious reason for that error)

_________________
OXPs: [EliteWiki] New Cargoes, [EliteWiki] Skilled NPCs, [EliteWiki] Curse of the Black Sunspot, and more


Top
   
PostPosted: Fri Jul 24, 2015 7:20 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Dec 04, 2013 12:34 pm
Posts: 913
Location: London, UK
Well, this is weird - I just tried it again to make sure I'd send the right one and the one that crashed loaded. Then I tried it again and it crashed. The weird part is it's just a new Jameson at Lave.

So I tried re-opening the game I saved with 1.80 that was previously fine, and that one crashed too. So my feeling here is that there's some instability associated with loading which may not be connected with the actual contents of the file.

I just restarted the mac and so far they're either loading or failing to load with the

Failed to restore saved game
Could not set up player ship

So I've saved that one to my dropbox as

https://dl.dropboxusercontent.com/u/472 ... olite-save

Hope that helps.


Top
   
PostPosted: Fri Jul 24, 2015 7:59 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Fri Nov 11, 2011 6:19 pm
Posts: 4012
Quote:
So my feeling here is that there's some instability associated with loading which may not be connected with the actual contents of the file.
Yes, seems that way. The file loads absolutely fine here.

Can you post the full Latest.log from just after it's failed to load, please?

_________________
OXPs: [EliteWiki] New Cargoes, [EliteWiki] Skilled NPCs, [EliteWiki] Curse of the Black Sunspot, and more


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 36 posts ]  Go to page 1 2 3 Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited